Applies ToMicrosoft Outlook 2010 Exchange Server 2010 Enterprise Exchange Server 2010 Standard Microsoft Business Productivity Online Dedicated Exchange Online

Příznaky

Pokud přenesete nebo přesunete poštovní schránku na sadu Office 365 nebo na server Exchange Server 2010, dojde k jednomu nebo více z následujících příznaků:

  • Nastavení nevyžádané pošty nasazené pomocí zásad skupiny se nezdaří nebo se nezdaří. Tato nastavení zahrnují seznamy bezpečných a blokovaných odesílatelů a nastavení filtrování nevyžádané pošty v aplikaci Outlook.

  • Pokud v aplikaci Outlook přidáte e-mailovou adresu do seznamu blokovaných nebo bezpečných odesílatelů, nebude adresa zobrazena v seznamu nebo bude zobrazena v seznamu, ale nebude nikdy synchronizována s poštovní schránkou na serveru Exchange.

  • Zprávy jsou neočekávaně označeny jako nevyžádaná pošta.

  • Zprávy nejsou označeny jako nevyžádaná pošta.

  • Všimnete si rozdílů mezi seznamem bezpečných odesílatelů zobrazených v aplikaci Outlook a Bezpeční odesílatelé podle zobrazení v aplikaci Outlook Web App (OWA).

Poznámka: Tento specifický problém je k dispozici až po přesunutí poštovní schránky do databáze serveru Exchange Server 2010. To by se nemělo zaměňovat s jinými problémy s nevyžádanou poštou.

Příčina

Pravidlo Nevyžádaná pošta je poškozeno nebo bylo při migraci do poštovní schránky serveru Exchange Server 2010 nesprávně generováno.

Řešení

Chcete-li tento problém vyřešit, nainstalujte před přesunutím nebo migrací poštovní schránky následující kumulativní aktualizaci:

2685289 Popis kumulativní aktualizace 3 pro Exchange Server 2010 Service Pack 2Poznámka: Tato kumulativní aktualizace tento problém nevyřeší, pokud tuto aktualizaci použijete po přesunutí nebo migraci poštovní schránky.

Alternativní řešení

Chcete-li tento problém obejít, existuje několik možností.

  • Pomocí nástroje Editor MFCMAPI odstraňte pravidlo Nevyžádaná pošta. Všimněte si, že tato metoda může způsobit ztrátu původního nastavení nevyžádaných e-mailů.

  • Pomocí aplikace OWA přidejte položku do seznamu bezpečných nebo blokovaných odesílatelů. Potom spusťte aplikaci Outlook a buď ručně přidejte položku do seznamu bezpečných nebo blokovaných odesílatelů, nebo použijte k aktualizaci seznamu Zásady skupiny (GPO). V některých případech může být nutné spustit aplikaci Outlook vícekrát.

  • Přidání položek do seznamu bezpečných odesílatelů pomocí prostředí PowerShell serveru Exchange. Příkazy prostředí PowerShell serveru Exchange lze použít pro přidávání položek do seznamů bezpečných nebo blokovaných odesílatelů hromadných poštovních schránek. Další informace o použití příkazů prostředí Exchange PowerShell k přidání položek do seznamu Bezpeční nebo Blokovaní odesílatelé získáte v následujícím článku znalostní báze Microsoft Knowledge Base:

    2545137 jak nakonfigurovat nastavení bezpečných odesílatelů a blokovaných odesílatelů v sadě Office 365Poznámka: Tento článek platí jak pro místní, tak pro poštovní schránky sady Office 365. Uživatelé BPOS by měli otevřít případ s BPOS OPS.

  • Pomocí skriptu opravte pravidla nevyžádaných e-mailů. Ukázka kódu skriptu je k dispozici na následujícím webu Microsoft TechNet:http://Gallery.technet.Microsoft.com/scriptcenter/Fix-junk-email-Rule-Script-7202a7f8

Další informace o podobném problému, ke kterému dochází po přesunutí nebo migraci poštovní schránky, získáte v následujícím článku znalostní báze Microsoft Knowledge Base:

2695011 nastavení nevyžádané pošty nefunguje očekávaným způsobem po migraci nebo přesunu poštovní schránky na poštovní server Exchange Server 2010 SP1

Další informace

Když se vyskytne podmínka popsaná v části Příznaky, při použití MFCMAPI k zobrazení pravidla Nevyžádaná pošta chybí pole Předmět. Následující snímek obrazovky zobrazuje pravidlo Nevyžádaná pošta s chybějícím předmětem (PR_SUBJECT):alternate text Vlastnost PR_EXTENDED_RULE_CONDITION MAPI obsahuje seznam blokovaných a bezpečných odesílatelů. alternate text Můžete porovnat to, co vidíte v uživatelském rozhraní (UI) aplikace Outlook, proti hodnotě řetězce text earlierMAPI Prop. To vám může pomoci určit, zda hodnoty zobrazené v aplikaci Outlook a ty, které byly synchronizovány se serverem, nesouhlasí. Kromě toho mohou být v následujícím klíči registru uloženy informace o bezpečných a blokovaných odesílatelů:

HKEY_CURRENT_USER \Software\Microsoft\Windows NT\CurrentVersion\Windows Messaging Subsystem\Profiles\ < profil > \ < GUID >Následující hodnoty registru odpovídají následujícím seznamům nevyžádané pošty:

Hodnotu

Seznamu

001f0418

Bezpeční odesílatelé

001f0419

Důvěryhodní příjemci

001f041a

Blokovaní odesílatelé

001f041c

Kontakty

Odstranění pravidla Nevyžádaná pošta pomocí MFCMAPI

  1. Exportujte seznam bezpečných odesílatelů a blokovaných odesílatelů do textového souboru pomocí postupu v následujícím článku: Export adres ze seznamů filtru nevyžádané pošty

  2. Ukončete aplikace Outlook a ukončete aplikaci OWA na všech pracovních stanicích připojených k poštovní schránce uživatele.

  3. Stáhněte MFCMAPI z GitHub (přejděte dolů a klepněte na poslední verzi).

  4. Spuštění souboru MFCMAPI. exe

  5. Klepněte na nabídku nástrojea potom na příkaz Možnosti.

  6. Klepnutím povolíte použití MDB_ONLINE při volání funkce OpenMsgStore.

  7. V nabídce relace klepněte na příkaz Přihlásit.

  8. Pokud se zobrazí výzva k zadání profilu, vyberte název profilu a klepněte na tlačítko OK.

  9. V horním podokně vyhledejte řádek, který odpovídá vaší poštovní schránce, a potom rozbalte položku úložiště informací.

  10. Klepněte pravým tlačítkem myši na složku Doručená pošta a vyberte možnost otevřít přidruženou tabulku obsahu.

  11. V horním podokně vyhledejte a vyberte zprávu, která obsahuje zprávu třídy IPM. ExtendedRule. Message.

  12. Klepněte pravým tlačítkem myši na IPM. ExtendedRule. Message a vyberte zprávu Delete.

  13. V okně Odstranit zboží vyberte trvalé odstranění předáním DELETE_HARD_DELETE (neodstranitelné) a pak klepněte na OK.

  14. Ukončit funkci MFCMAPI

  15. Spusťte Outlook.

  16. Ověřte, zda jsou seznamy bezpečných odesílatelů, bezpečných příjemců a blokovaných odesílatelů prázdné.

  17. Nakonec importujte e-mailové adresy do seznamů filtru nevyžádané pošty pomocí kroků v následujícím článku: Importovat e-mailové adresy do seznamů filtru nevyžádané pošty

Potřebujete další pomoc?

Chcete další možnosti?

Prozkoumejte výhody předplatného, projděte si školicí kurzy, zjistěte, jak zabezpečit své zařízení a mnohem více.

Komunity vám pomohou klást otázky a odpovídat na ně, poskytovat zpětnou vazbu a vyslechnout odborníky s bohatými znalostmi.