Příznaky
Předpokládejme, že používáte rutiny New-OWAVirtualDirectory nebo Nové ECPVirtualdirectory znovu vytvořit "owa" nebo "ECP" virtuální adresář na serveru Microsoft Exchange Server 2013 nebo poštovní schránky aplikace Microsoft Exchange Server 2016. V této situaci uživatel pokusí o přístup k aplikaci Outlook Web App a Outlook na webu nebo serveru Exchange Administration Center (EAC), obdrží kód chyby "Http 404".
Příčina
K tomuto problému dochází, protože metoda nesprávné ověřování je nastavena pro "owa" a "ECP" virtuální adresáře. Při spuštění rutiny Nový OWAVirtualDirectory nebo Nové ECPVirtualdirectory "owa" nebo "ECP" virtuální adresář vytvořit rutiny nesprávně umožňuje ověřování pomocí formulářů a základní ověřování, nikoli ověřování systému Windows.
Jak potíže obejít
Chcete-li tento problém vyřešit, postupujte takto.
Pro virtuální adresář "owa"
-
Otevřete Exchange Management Shell (EMS) a potom spusťte následující rutiny můžete změnit metodu ověřování pro virtuální adresář "owa" ověřování systému Windows:
set-Owavirtualdirectory-identity "E15MBX\owa (Exchange Back End)" - WindowsAuthentication $True - Basicauthentication $false - ověřování pomocí formulářů $false
-
Na serverech přístupu klienta i poštovní schránku k restartování Internetová informační služba (IIS) spusťte následující příkaz:
příkaz iisreset/noforce
Pro virtuální adresář "ECP"
-
Spusťte prostředí Windows PowerShell.
-
Zadejte následující příkazy a za každým řádkem stiskněte klávesu Enter:
Přidat PSSnapin * výměny *
Sada EcpVirtualDirectory-Identity "E15MBX\ecp (Exchange Back End)" - WindowsAuthentication $true - ověřování pomocí formulářů $false -
Na serverech přístupu klienta i poštovní schránku k restartování Internetová informační služba (IIS) spusťte následující příkaz:
příkaz iisreset/noforce