Příznaky
Jde o takovouto situaci:
-
Máte dokumentu specifikace XPS (XML Paper), jehož hostitelem je na webovém serveru.
-
Webový server je nakonfigurován používat základní ověřování nebo ověřování pomocí formulářů pomocí souboru cookie relace.
-
Můžete spustit XPSViewer.exe přístup k dokumentu XPS v počítači, který používá rozhraní.NET Framework 3.5 Service Pack 1 (SP1).
V tomto případě dojde k chybě XPSViewer.exe. Dále se zobrazí následující chybová zpráva:
XPSViewer.exe došlo k problému a je třeba ji ukončit. Omlouváme se za případné nepříjemnosti se.
Příčina
K tomuto problému dochází z důvodu chyby v XPSViewer.exe. Tuto chybu způsobuje chybu při XPS viewer zobrazí výzvu k zadání pověření uživatele.
Řešení
Informace o opravě hotfix
Společnost Microsoft má k dispozici podporovanou opravu hotfix. Tato oprava hotfix je však určena pouze problému popsanému v tomto článku. Tuto opravu hotfix instalujte pouze do systémů, ve kterých dochází k potížím popsaným v tomto článku. Tato oprava hotfix může být dále testována. Proto pokud nejste vážně ohrožen tímto problémem, doporučujeme počkat na další aktualizaci softwaru, která obsahuje tuto opravu hotfix.
Pokud je oprava hotfix k dispozici ke stažení, je v horní části tohoto článku znalostní báze Knowledge Base oddíl "Oprava Hotfix je dostupná ke stažení" . Pokud tato sekce není uvedena, obraťte se na Zákaznický servis a podporu společnosti Microsoft k získaní opravy hotfix. Poznámka: Pokud nastanou další problémy nebo bude nutné další řešení potíží, bude možná třeba vytvořit další samostatný požadavek na služby. Běžná cena za technickou podporu se vztahuje k dodatečným otázkám podpory a k problémům, které se netýkají této konkrétní opravy hotfix. Úplný seznam telefonních čísel služeb zákazníkům společnosti Microsoft a podpoře nebo vytvořit zvláštní požadavek na službu naleznete na následujícím webu společnosti Microsoft:http://support.microsoft.com/contactus/?ws=supportPoznámka: Ve formuláři „Oprava hotfix je dostupná ke stažení“ se zobrazují jazyky, pro které je oprava hotfix k dispozici. Pokud váš jazyk není zobrazen, to je protože oprava hotfix není k dispozici pro daný jazyk.
Předpoklady
Musíte mít rozhraní.NET Framework 3.5 SP1 nainstalovali tuto opravu hotfix.
Požadavek na restartování
Nemáte k restartování počítače po instalaci této opravy hotfix Pokud žádná instance rozhraní.NET Framework je používán.
Informace o nahrazení opravy hotfix
Tato oprava hotfix nenahrazuje další opravy hotfix.
Informace o souborech
Anglická verze této opravy hotfix má atributy (nebo pozdější atributy souborů) uvedené v následující tabulce. Kalendářní data a časy jednotlivých souborů jsou uvedeny v koordinovaném světovém čase (UTC). Při zobrazení informací o souboru je převeden na místní čas. Rozdíl mezi místním časem a časem UTC naleznete na kartě Časové pásmo v položce Datum a čas v okně Ovládací panely.
Pro všechny podporované verze x86 systému Windows 2000 Server, Windows Server 2003 a Windows XP
Název souboru |
Verze souboru |
Velikost souboru |
Datum |
Čas |
Platforma |
---|---|---|---|---|---|
Xpsviewer.exe |
3.0.6920.4008 |
298,304 |
25-Sep-2009 |
01:54 |
x86 |
Jak potíže obejít
Chcete-li tento problém vyřešit, použijte jednu z následujících metod:
-
Nepoužívejte ověřování pro webový server.
-
Použijte integrované ověřování systému Windows, jako je například ověřování NTLM nebo Kerberos. Ujistěte se, že dokument lze přistupovat bez pověření uživatele. Například webové servery v zóně intranet nebo Důvěryhodné servery lze přistupovat bez pověření uživatele.
-
Ověřování pomocí formulářů a trvalý soubor cookie.
-
Otevření dokumentu pomocí Microsoft XPS Viewer Essentials Pack (EP) místo XPSViewer.exe.
Stav
Společnost Microsoft potvrdila, že se jedná o problém v produktech společnosti Microsoft, které jsou uvedeny v části "Platí pro".
Další informace
Chcete-li získat Microsoft XPS Essentials Pack, navštivte následující web služby Stažení softwaru:
http://www.microsoft.com/downloads/details.aspx?FamilyId=B8DCFFDD-E3A5-44CC-8021-7649FD37FFEE