Příznaky
Problém 1
Jde o takovouto situaci:
-
Uživatelský účet umožňuje připojit se k Microsoft Team Foundation Server 2010 (TFS 2010) z aplikace Microsoft Visual Studio Team Explorer.
Poznámka: Uživatelský účet byl nedávno přidán do skupiny zabezpečení. -
Pokoušíte se otevřít pracovní položku v kolekci týmového projektu.
V tomto případě nelze přistupovat pracovní položka nebo v uzlu pracovní položky se zobrazí červená ikona X chyba.
Problém 2
Jde o takovouto situaci:
-
Používáte uživatelský účet pro připojení k TFS 2010 Visual Studio Team Explorer.
-
Uživatelský účet skupiny zabezpečení je display_name hodnota, která obsahuje více než 256 znaků.
Poznámka: Hodnoty display_name pole jsou uloženy v tbl_security_identity_cache tabulka databáze Tfs_Configuration . -
Pokoušíte se otevřít pracovní položku v kolekci týmového projektu.
V tomto případě nelze přistupovat pracovní položka nebo v uzlu pracovní položky se zobrazí červená ikona X chyba.
Příčina
Příčina 1
K tomuto problému dochází, protože logiku uživatelské identity znovu synchronizovat je nesprávně spuštěna. Navíc trvá dlouhou dobu k dokončení procesu synchronizace. Proto nově přidané uživatele nebudou synchronizovány bezprostředně procesu sledování pracovní položku.
Příčina 2
K tomuto problému dochází, protože mnoho uživatelských účtů, členství nebo seznamy řízení přístupu (ACL) jsou odstraněny při display_name hodnota obsahuje více než 256 znaků.
Řešení
Informace o opravě hotfix
Podporovaná oprava hotfix je nyní k dispozici od společnosti Microsoft. Je však určena opravit pouze problému popsaného v tomto článku. Použijte ji pouze u systémů, ve kterých dochází k tomuto konkrétnímu problému.
Chcete-li vyřešit tento problém, obraťte se na technickou podporu společnosti Microsoft získat opravu hotfix. Úplný seznam telefonních čísel služeb podpory zákazníků společnosti Microsoft a informace o cenách podpory naleznete na následujícím webu společnosti Microsoft:
http://support.microsoft.com/contactus/?ws=supportPoznámka: Ve zvláštních případech mohou být stornovány poplatky, které jsou třeba obvykle zaplatit za telefonní hovory, pokud pracovník služeb podpory společnosti Microsoft určí, že konkrétní aktualizace odstraní váš problém. Výdaje na technickou podporu použije dalších otázek a problémů, které nelze vyřešit konkrétní aktualizací.
Předpoklady
Chcete-li nainstalovat tuto opravu hotfix, musíte mít Microsoft Team Foundation Server 2010 (TFS 2010) Service Pack 1 (SP1) nainstalován.
Požadavek na restartování
Máte k restartování počítače po instalaci této opravy hotfix Pokud zasažené soubory jsou používány.
Doporučujeme, abyste před instalací této opravy hotfix zavřete všechny instance aplikace Visual Studio.
Informace o souborech
Globální verze této opravy hotfix má atributy souborů (nebo novější) uvedené v následující tabulce. Kalendářní data a časy jednotlivých souborů jsou uvedeny v koordinovaném světovém čase (UTC). Při zobrazení informací o souboru je převeden na místní čas. Rozdíl mezi místním časem a časem UTC naleznete na kartě Časové pásmo v položce Datum a čas v okně Ovládací panely.
Název souboru |
Verze souboru |
Velikost souboru |
Datum |
Čas |
Platforma |
---|---|---|---|---|---|
Microsoft.teamfoundation.admin.dll |
10.0.40219.339 |
24,698,232 |
03. srpna 2011 |
19:03 |
x86 |
Microsoft.teamfoundation.server.deploy.tfcollection.dll |
10.0.40219.339 |
561,576 |
03. srpna 2011 |
19:03 |
x86 |
Microsoft.teamfoundation.workitemtracking.server.dataaccesslayer.dll |
10.0.40219.339 |
589,256 |
03. srpna 2011 |
19:03 |
x86 |
Microsoft.teamfoundation.workitemtracking.server.dataservices.dll |
10.0.40219.339 |
142,784 |
03-Aug-2011 |
19:03 |
x86 |
Jak potíže obejít
Chcete-li tento problém vyřešit, upravte hodnoty display_name tak, aby obsahoval méně než 256 znaků.
Stav
Společnost Microsoft potvrdila, že se jedná o problém v produktech společnosti Microsoft, které jsou uvedeny v části "Platí pro".