Příznaky
Při použití Microsoft BizTalk Server 2010 Accelerator pro HL7 (BTAHL7), potvrzení (ACK) je generována v nesprávném formátu.
Potvrzení je například generována v následujícím formátu:
ERR || OBX_ObservationResult ^ 9 ^ 23 | HL7nnnn ^ Chyba datového typu ^ 102 | E|||||||| ^^^^^^^^^^^
Správný formát pro potvrzení se však takto:
ERR || OBX ^ 9 ^ 23 | 102 ^ Chyba datového typu ^ HL70369 | E|||||||| ^^^^^^^^^^^
Poznámky
-
"OBX_ObservationResult" je název uzlu XML, nikoli identifikátor HL7.
-
"HL7nnnn" by měl být ve skutečnosti kód "HL70369".
-
Pořadí polí v segmentu ERR je nesprávná. "HL7nnnn ^ typ dat chyba ^ 102" by měla být "102 ^ Chyba datového typu ^ HL70369".
Příčina
K problému dochází v důsledku vady výrobku.
Řešení
Tato oprava hotfix řeší následující tři aspekty problému:
-
Potvrzení má identifikátor HL7 namísto název uzlu XML. Například PĚT má "OBX" místo "OBX_ObservationResult".
-
Informace o chybě ERR segment je generován pomocí následujících pokynů:
-
Pokud hodnota tabulky nebyl nalezen, vrátí "HL7nnnn".
Poznámka: "nnnn" je číslo tabulky HL7, který je prověřen. -
Chyby ověření tabulky-změňte na "HL79999" "HL7nnnn".
Poznámka: "HL79999" je hodnota tabulky-chyba, která je zvláštní chyba pro BizTalk Server.
-
-
Pořadí polí v segmentu ERR je nesprávná. Například "HL7nnnn ^ typ dat chyba ^ 102" je změněn na "102 ^ Chyba datového typu ^ HL7nnnn".
Informace o opravě hotfix
Společnost Microsoft má k dispozici podporovanou opravu hotfix. Tato oprava hotfix je však určena pouze problému popsanému v tomto článku. Použití této opravy hotfix pouze u systémů, ve kterých dochází k tomuto konkrétnímu problému.
Pokud je oprava hotfix k dispozici ke stažení, je v horní části tohoto článku znalostní báze Knowledge Base oddíl "Oprava Hotfix je dostupná ke stažení" . Pokud tento oddíl není uveden, odešlete požadavek na Microsoft Zákaznický servis a podporu k získání opravy hotfix.
Poznámka: Pokud nastanou další problémy nebo bude nutné další řešení potíží, bude možná třeba vytvořit další samostatný požadavek na služby. Běžná cena za technickou podporu se vztahuje k dodatečným otázkám podpory a k problémům, které se netýkají této konkrétní opravy hotfix. Úplný seznam telefonních čísel služeb zákazníkům společnosti Microsoft a podpoře nebo vytvořit zvláštní požadavek na službu navštivte následující web společnosti Microsoft:
http://support.microsoft.com/contactus/?ws=supportPoznámka: Ve formuláři „Oprava hotfix je dostupná ke stažení“ se zobrazují jazyky, pro které je oprava hotfix k dispozici. Pokud váš jazyk není zobrazen, to je protože oprava hotfix není k dispozici pro daný jazyk.
Předpoklady
Musíte mít nainstalován tuto opravu hotfix BTAHL7. Navíc musíte nainstalovat opravy hotfix, které jsou popsány v následujících článcích znalostní báze Microsoft Knowledge Base (KB):
2564013 oprava: je k dispozici oprava hotfix, která poskytuje další vlastnosti režim doručení minimální dolní Layer Protocol odesílat a přijímat adaptéry v BizTalk Accelerator pro HL7 v prostředí BizTalk Server 2010
2607536 oprava: oprava Hotfix přidá podporu pro zpracování zprávy HL7 v2.5.1 a opravuje několik problémů v BizTalk Server 2010 akcelerátor pro HL7
Požadavek na restartování
Po instalaci této opravy hotfix, bude pravděpodobně třeba restartovat počítač. Pokud nejste vyzváni k restartování počítače, je nutné restartovat BizTalk hostitele instance služby.
Pokyny k instalaci
Důležité: Tento oddíl, metoda nebo úkol obsahuje kroky, které popisují úpravu registru. Při nesprávné úpravě registru mohou nastat závažné problémy Proto se ujistěte, že budete opatrně postupovat podle těchto kroků Pro zvýšení ochrany před úpravou zálohujte registr. Pokud dojde k potížím, pak můžete registr obnovit ze zálohy. Pro další informace o zálohování a obnovení registru klepněte na následující číslo článku databáze Microsoft Knowledge Base:
322756 postup zálohování a obnovení registru v systému WindowsPokud aktuální opravy hotfix je nutné a BTAHL7 generuje potvrzení podle změny schématu, postupujte takto kromě instalace této opravy hotfix. Pokud je oprava hotfix není nutné, například BTAHL7 generuje potvrzení, který nemá podobné příznak, který je popsán v části "Příznaky", nemáte k provedení těchto kroků.
Poznámka: Následující postup vyžaduje nastavení nového klíče registru upravené schémata opětovné vytvoření BTAHL7V2XCommon projektu a potom znovu nasazení projektu. Pokud tato schémata jsou uvedené v jiných projektech, také vyžaduje opětovné sestavení a opětovného nasazení těchto projektů.
-
Zastavte hostitelské instance serveru BizTalk.
-
Znovu nasaďte BTAHL7V2XCommon projektu nové upravené schémata. Chcete-li to provést, proveďte následující akce:
-
Přejmenujte ACK_24_GLO_DEF_949029 v \%\Microsoft BizTalk 2010 Accelerator pro HL7\Templates\Schemas\V2. X\2.4 jako ACK_24_GLO_DEF
-
Přejmenujte ACK_25_GLO_DEF_949029 v \%\Microsoft BizTalk 2010 Accelerator pro HL7\Templates\Schemas\V2. X\2.5 jako ACK_25_GLO_DEF
Poznámky
-
BTAHL7V2XCommon projektu již byla nasazena, zrušit nasazení projektu a sestavení a znovu nasaďte projektu.
-
Pokud tato schémata jsou uvedené v jiných projektech, postup také vyžaduje opětovné sestavení a opětovného nasazení projektů tyto upravené schémata.
-
-
Vytvořte položku registru typu DWORD s názvem "UseModifiedAck" v následujícím podklíči registru:
-
Pro 32-bit (x86) operačního systému:
Akcelerátor HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\BizTalk pro HL7\Version 2010 -
Pro 64-bit (x64) operačního systému:
Akcelerátor HKEY_LOCAL_MACHINE\SOFTWARE\Wow6432Node\Microsoft\BizTalk pro HL7\Version 2010
-
-
Pokud po dokončení kroku 2 je nutné opravu hotfix, nastavte hodnotu klíče registru nově vytvořené 1. Pokud není k dispozici klíč registru nebo hodnota je nastavena na jinou hodnotu než 1, bude generovat BTAHL7 ACK, který nemá příznaky podobné co jsou popsány v části "Příznaky" (Tento postup se provádí s cílem zajistit, aby nebyly narušeny stávající zákaznických řešení). Proto v případě nejsou nasazeny upravené schémata (krok 2 není dokončeno), hodnota klíče registru nastavena na jinou hodnotu, která není 1. Pokud jsou nasazeny upravené schémata (po dokončení kroku 2), ujistěte se, nastavte klíč registru na hodnotu 1.
-
Restartujte hostitele instance serveru BizTalk.
Informace o souborech
Anglická verze této opravy hotfix má atributy (nebo pozdější atributy souborů) uvedené v následující tabulce. Kalendářní data a časy jednotlivých souborů jsou uvedeny v koordinovaném světovém čase (UTC). Při zobrazení informací o souboru je převeden na místní čas. Rozdíl mezi místním časem a časem UTC naleznete na kartě Časové pásmo v položce Datum a čas v okně Ovládací panely.
Název souboru |
Verze souboru |
Velikost souboru |
Datum |
Čas |
Platforma |
---|---|---|---|---|---|
Microsoft.solutions.btahl7.pipelinecommon.dll |
3.9.559.2 |
90,528 |
13-Jul-2012 |
17:41 |
x86 |
Microsoft.solutions.btahl7.pipelinemessagecore.dll |
3.9.559.2 |
86,448 |
13-Jul-2012 |
17:41 |
x86 |
Stav
Společnost Microsoft potvrdila, že se jedná o problém v produktech společnosti Microsoft, které jsou uvedeny v části "Platí pro".
Další informace
Další informace o opravách hotfix serveru BizTalk Server klepněte na následující číslo článku databáze Microsoft Knowledge Base:
2003907 informace o podpoře BizTalk služba oprav hotfix a aktualizací Service pack