Přihlásit se pomocí účtu Microsoft
Přihlaste se nebo si vytvořte účet.
Dobrý den,
Vyberte jiný účet.
Máte více účtů.
Zvolte účet, pomocí kterého se chcete přihlásit.

Příznaky

Pokud se uživatel pokusí připojit k serveru se systémem Microsoft Host Integration Server 2009, může neočekávaně zastavit proces SnaBase.

Příčina

K tomuto problému dochází, protože dochází k narušení přístupu a server kontroluje, zda je povoleno šifrování pro uživatele, který se pokouší připojit. Konkrétně narušení přístupu dochází při pokusu o uvolnění bloku paměti vnitřní kontroly, který byl uvolněn dříve Snadmod.dll souboru. Druhý pokus o uvolnění tohoto bloku paměti způsobuje narušení přístupu, který vede k neobvyklému ukončení procesu SnaBase.

Řešení

Informace o kumulativní aktualizaci

Microsoft Host Integration Server 2009

Oprava, která řeší tento problém je zahrnuta v kumulativní aktualizace 6 pro Host Integration Server 2009.

Informace o opravě hotfix

Společnost Microsoft má k dispozici podporovanou opravu hotfix. Tato oprava hotfix je však určena opravit pouze problému popsaného v tomto článku. Tuto opravu hotfix instalujte pouze do systémů, ve kterých dochází k potížím popsaným v tomto článku. Tato oprava hotfix může být dále testována. Proto pokud nejste vážně ohrožen tímto problémem, doporučujeme počkat na další aktualizaci softwaru, která obsahuje tuto opravu hotfix.

Pokud je oprava hotfix k dispozici ke stažení, je v horní části tohoto článku znalostní báze Knowledge Base oddíl "Oprava Hotfix je dostupná ke stažení" . Pokud tato sekce není uvedena, obraťte se na Zákaznický servis a podporu společnosti Microsoft k získaní opravy hotfix.

Poznámka: Pokud nastanou další problémy nebo bude nutné další řešení potíží, bude možná třeba vytvořit další samostatný požadavek na služby. Běžná cena za technickou podporu se vztahuje k dodatečným otázkám podpory a k problémům, které se netýkají této konkrétní opravy hotfix. Úplný seznam telefonních čísel Zákaznického servisu a podpory společnosti Microsoft naleznete na následujícím webu podpory společnosti Microsoft, kde také můžete vytvořit samostatný požadavek na služby:

http://support.microsoft.com/contactus/?ws=supportPoznámka: Ve formuláři „Oprava hotfix je dostupná ke stažení“ se zobrazují jazyky, pro které je oprava hotfix k dispozici. Pokud váš jazyk není zobrazen, to je protože oprava hotfix není k dispozici pro daný jazyk.

Předpoklady

Musí mít kumulativní aktualizace 5 pro Host Integration Server 2009 nainstalovali tuto opravu hotfix.

Informace o restartování počítače

Bude pravděpodobně nutné restartovat počítač po instalaci této opravy hotfix.

Informace o nahrazení

Tato oprava hotfix nenahrazuje dříve vydanou opravu hotfix.

Informace o souborech

Anglická verze této opravy hotfix má atributy (nebo pozdější atributy souborů) uvedené v následující tabulce. Kalendářní data a časy jednotlivých souborů jsou uvedeny v koordinovaném světovém čase (UTC). Při zobrazení informací o souboru je převeden na místní čas. Rozdíl mezi místním časem a časem UTC naleznete na kartě Časové pásmo v položce Datum a čas v okně Ovládací panely.

Microsoft Host Integration Server 2009, 32bitové verze

Název souboru

Verze souboru

Velikost souboru

Datum

Čas

Platforma

Snadmod.dll

8.0.4081.2

815,256

01-Aug-2013

00:18

x86

Microsoft Host Integration Server 2009, 64-bit Edition

Název souboru

Verze souboru

Velikost souboru

Datum

Čas

Platforma

Snadmod.dll

8.0.4081.2

815,256

01-Aug-2013

00:18

x86

Snadmod.dll

8.0.4081.2

1,022,616

01-Aug-2013

00:22

x64

Poznámka: Vzhledem k závislostem souborů může nejnovější oprava, která obsahuje tyto soubory také obsahovat další soubory.

Stav

Společnost Microsoft potvrdila, že se jedná o problém v produktech společnosti Microsoft, které jsou uvedeny v části "Platí pro".

Další informace

Pokud soubor s výpisem stavu paměti narušení přístupu zachytit, když nastane tento problém, soubor s výpisem stavu paměti obsahuje trasování zásobníku, která se podobá následující:

snadmod!GetUserEncryptionFlag_cb+0x95a
snadmod!LocalProcessRpc+0xaeb
snadmod!DMODReleaseLtab+0x923
kernel32!BaseThreadInitThunk+0xe
ntdll!__RtlUserThreadStart+0x23
ntdll!_RtlUserThreadStart+0x1b

Potřebujete další pomoc?

Chcete další možnosti?

Prozkoumejte výhody předplatného, projděte si školicí kurzy, zjistěte, jak zabezpečit své zařízení a mnohem více.

Komunity vám pomohou klást otázky a odpovídat na ně, poskytovat zpětnou vazbu a vyslechnout odborníky s bohatými znalostmi.

Byly tyto informace užitečné?

Jak jste spokojeni s kvalitou jazyka?
Co ovlivnilo váš názor?
Po stisknutí tlačítka pro odeslání se vaše zpětná vazba použije k vylepšování produktů a služeb Microsoftu. Váš správce IT bude moci tato data shromažďovat. Prohlášení o zásadách ochrany osobních údajů.

Děkujeme vám za zpětnou vazbu.

×