Příznaky
Jde o takovouto situaci:
-
Máte některé oddíly relačních Online analytické zpracování (ROLAP) v krychli Microsoft SQL Server 2008 R2 Analysis Services (SSAS 2008 R2).
-
Při spuštění dotazu Multidimensional Expressions (MDX) proti ROLAP oddíly. Proto některé ROLAP dotazy jsou odesílány do serveru SQL Server.
-
Dojde k chybě během vyhodnocení dotazu MDX a zablokuje zpracování úlohy pro dotaz MDX. Například SQL Server vrátí následující chybovou zprávu na ROLAP dotazy:
V této relaci aktivní transakce byla potvrzena nebo přerušena jinou relací
V tomto scénáři žádné transakce může být potvrzena a nemůžete se připojit k SSAS.
Příčina
K problému dochází, protože při ROLAP dotazy jsou odesílány do serveru SQL a dotazy se nezdaří s chybou, podřízeného podprocesu dotazu MDX se zastaví v SSAS. Však dotaz hlavní podproces čeká ještě podřízeného podprocesu. Proto hlavní vlákno zablokuje zpracování potvrzení a bloky hodnocení zabezpečení u všech nových uživatelských relací.
Řešení
Tento problém byl poprvé opraven v následující kumulativní aktualizace serveru SQL Server.
Kumulativní aktualizace 12 pro SQL Server 2008 R2 s aktualizací SP2/en-us/help/2938478
Každé nové kumulativní aktualizace pro SQL Server obsahuje všechny opravy hotfix a všechny opravy zabezpečení, které byly součástí předchozí kumulativní aktualizace. Rezervovat nejnovější kumulativní aktualizace pro SQL Server:
Společnost Microsoft má k dispozici podporovanou opravu hotfix. Tato oprava hotfix je však určena pouze problému popsanému v tomto článku. Použití této opravy hotfix pouze u systémů, ve kterých dochází k tomuto konkrétnímu problému.
Pokud oprava hotfix je k dispozici ke stažení, je sekce "Oprava Hotfix je k dispozici ke stažení" v horní části tohoto článku znalostní báze Knowledge Base. Pokud tento oddíl není uveden, odešlete požadavek na Microsoft Zákaznický servis a podporu k získání opravy hotfix.
Poznámka: Pokud nastanou další problémy nebo bude nutné další řešení potíží, bude možná třeba vytvořit další samostatný požadavek na služby. Běžná cena za technickou podporu se vztahuje k dodatečným otázkám podpory a k problémům, které se netýkají této konkrétní opravy hotfix. Úplný seznam telefonních čísel služeb zákazníkům společnosti Microsoft a podpoře nebo vytvořit zvláštní požadavek na službu navštivte následující web společnosti Microsoft:
http://support.microsoft.com/contactus/?ws=supportPoznámka: "Hotfix stažení k dispozici" formulář zobrazí jazyky, pro které je oprava hotfix k dispozici. Pokud váš jazyk není zobrazen, to je protože oprava hotfix není k dispozici pro daný jazyk.
Stav
Společnost Microsoft potvrdila, že se jedná o problém v produktech společnosti Microsoft, které jsou uvedeny v části "Platí pro".