Platí pro
Exchange Server 2016 Enterprise Edition Exchange Server 2016 Standard Edition Exchange Server 2013 SP1 Exchange Server 2013 Standard Edition Windows Server 2008 R2 Enterprise Exchange Server 2010 Enterprise

Příznaky

Zvažte následující scénář:

  • Používáte Microsoft Exchange Server 2013 nebo Microsoft Exchange Server 2016 v prostředí koexistence společně s Microsoft Exchange serverem 2010 nebo Exchange Server 2007.

  • Poštovní schránky v tomto prostředí se připojují prostřednictvím serveru Exchange 2013 Server pro klientský přístup (CAS) nebo Exchange Server 2016 Client Access.

  • Uživatelé v tomto prostředí se pokusí připojit k poštovním schránkám Exchange serveru Exchange 2010 nebo Exchange Server 2007 pomocí funkce Outlook Anywhere.

V tomto scénáři nemohou vytvářet připojení. Místo toho se zobrazí výzva k zadání přihlašovacích údajů. Klienti Outlooku můžou zůstat i v odpojeném stavu. Tento problém se týká taky připojení Outlooku odkudkoli k Exchange serveru 2010 nebo Exchange Server 2007 starší veřejné složky nebo offline adresáře (OAB). Poradce při potížích označuje, že se uživatelé nemohou připojit přímo ke starším serverům Client Access (CAS) pomocí Outlooku kdekoli.

Příčina

Tento problém nastane, když servery Exchange Server 2010 nebo Exchange Server 2007, které mají roli CAS, jsou v systému Windows Server 2008 R2. K tomuto problému dochází, protože po změně hesla počítače pro CAS je nastaven nesprávný příznak u globálního přihlašovacího údaje. Další informace o tomto problému najdete v balíčku oprav hotfix uvedeném v části řešení.

Řešení

Tento problém vyřešíte instalací následující aktualizace na všechny certifikační autority Exchange Server 2010 a Exchange Server 2007, které jsou v systému Windows Server 2008 R2:

3140410 Aktualizace zabezpečení pro Microsoft Windows pro zvýšení úrovně oprávnění: 8. března 2016Poznámka Po instalaci této aktualizace zabezpečení je třeba restartovat počítač.

Další informace

Když dojde k tomuto problému, zaznamená se chyba do protokolů proxy serveru HTTP RPC v následujícím umístění:

C:\Program Files\Microsoft\Exchange Server\V15\Logging\HttpProxy\RpcHttpTato položka protokolu se podobá následujícímu:Complete=PrepareServerRequest;,WebExceptionStatus=ProtocolError;ResponseStatusCode= 401;WebException=System.Net.WebException: The remote server returned an error: (401) Unauthorized. atSystem.Net.HttpWebRequest.EndGetResponse(IAsyncResult asyncResult) atMicrosoft.Exchange.HttpProxy.RpcHttpProxyRequestHandler.<>c__DisplayClass1.nullb__0 ();HttpException=System.Web.HttpException (0x80004005): NegotiateSecurityContext failed with for host 'mail.contoso.com' with status 'InvalidToken' at Microsoft.Exchange.HttpProxy.KerberosUtilities.GenerateKerberosAuthHeader.

Alternativní řešení

Pokud chcete tento problém vyřešit, nakonfigurujte výchozí fond aplikací pro všechny certifikační autority 2010/2007 pro provoz pod identitou síťové služby místo identity fondu aplikací. Toto alternativní řešení je dočasné. Pokud chcete změnit výchozí konfiguraci fondu aplikací, postupujte takto:

  1. Spusťte Správce Internetové informační služby.

  2. Klikněte na fondy aplikací, pravým tlačítkem klikněte na DefaultAppPoola potom klikněte na Upřesnit nastavení.

  3. Klikněte na Identitaa potom klikněte na tři tečky (...) tlačítka.

  4. Klikněte na šipku rozevíracího seznamu a potom v seznamu pod předdefinovaným účtemvyhledejte položku Síťová služba .

  5. Klikněte pravým tlačítkem na výchozí fond aplikací a potom klikněte na Recycle .

Potřebujete další pomoc?

Chcete další možnosti?

Prozkoumejte výhody předplatného, projděte si školicí kurzy, zjistěte, jak zabezpečit své zařízení a mnohem více.