Příznaky
Jde o takovouto situaci:
-
Máte počítač se systémem Windows Server 2008 R2 Service Pack 1 (SP1) nebo Windows Server 2008 Service Pack 2 (SP2).
-
Počítač pracuje jako server pro systém souborů NFS.
-
Vytvářet a sdílet soubory na serveru systému souborů NFS.
-
Pomocí příkazu Připojit na NFS klienta připojit k serveru systému souborů NFS.
-
Můžete otevřít více než jedno okno terminálu v klientovi NFS.
-
Spuštěním následujícího příkazu ls v každé okno terminálu ve stejnou dobu, chcete-li vypsat všechny sdílené soubory:
CD < sdílení NFS >
ls-lR
V tomto scénáři trvá déle, než bylo očekáváno, chcete-li zobrazit sdílené soubory ze serveru systému souborů NFS.
Příčina
K tomuto problému dochází, pokud klient systému souborů NFS odešle GETATTR volat dvakrát za sebou. Čekání na potvrzení paketu od klienta systému souborů NFS pro první paket odpovědi GETATTR před jeho odesláním ve frontě druhý paket odpovědi GETATTR má server systému souborů NFS.
Poznámka: Ve většině případů trvá asi 0,04 sec druhý paket odpovědi GETATTR odeslat z důvodu zpožděné ACK z klienta systému souborů NFS. Proto při spuštění příkazu ls trvá více než dvě hodiny do seznamu všech souborů pro informace o atributu, pokud celkový počet souborů je více než 400,000.
(400,000 * 0,04 sec / 2 volání Nfs3GetAttr() / 3600 sec = 2.22 hodin)
Můžete ověřit, jak dlouho trvá pošle odpověď GETATRR klient systému souborů NFS pomocí Sledování síťových paketů.
Řešení
Chcete-li tento problém vyřešit, nainstalujte opravu hotfix 2957486 na serveru systému souborů NFS.
Poznámka: I když tento problém byl zaznamenán pouze Windows Server 2008 R2 nebo Windows Server 2008, je oprava hotfix platí také pro systém Windows 7 nebo Windows Vista.
Informace o opravě hotfix
Společnost Microsoft má k dispozici podporovanou opravu hotfix. Tato oprava hotfix je však určena pouze problému popsanému v tomto článku. Použití této opravy hotfix pouze u systémů, ve kterých dochází k tomuto konkrétnímu problému.
Pokud oprava hotfix je k dispozici ke stažení, je sekce "Oprava Hotfix je k dispozici ke stažení" v horní části tohoto článku znalostní báze Knowledge Base. Pokud tento oddíl není uveden, odešlete požadavek na Microsoft Zákaznický servis a podporu k získání opravy hotfix.
Poznámka: Pokud nastanou další problémy nebo bude nutné další řešení potíží, bude možná třeba vytvořit další samostatný požadavek na služby. Běžná cena za technickou podporu se vztahuje k dodatečným otázkám podpory a k problémům, které se netýkají této konkrétní opravy hotfix. Úplný seznam telefonních čísel služeb zákazníkům společnosti Microsoft a podpoře nebo vytvořit zvláštní požadavek na službu navštivte následující web společnosti Microsoft:
http://support.microsoft.com/contactus/?ws=supportPoznámka: "Hotfix stažení k dispozici" formulář zobrazí jazyky, pro které je oprava hotfix k dispozici. Pokud váš jazyk není zobrazen, to je protože oprava hotfix není k dispozici pro daný jazyk.
Předpoklady
Neexistují žádné požadavky pro instalaci této opravy hotfix.
Informace o registrech
Pro použití tohoto hotfixu nemusíte provádět žádné změny v registrech.
Požadavek na restartování
Po instalaci této opravy hotfix musíte restartovat počítač.
Informace o nahrazení opravy hotfix
Tato oprava hotfix nenahrazuje dříve vydanou opravu hotfix.
Globální verze této opravy hotfix nainstaluje soubory, jejichž atributy jsou uvedeny v následujících tabulkách. Kalendářní data a časy jednotlivých souborů jsou uvedeny v koordinovaném světovém čase (UTC). Kalendářní data a časy těchto souborů v místním počítači jsou zobrazeny dle vašeho místního času a také podle aktuálního letního času (DST). Navíc data a časy se mohou změnit při provádění některých operací se soubory.
Informace o souboru a poznámky systému Windows 7 a Windows Server 2008 R2
Důležité: Opravy hotfix pro systém Windows 7 a Windows Server 2008 R2 opravy hotfix jsou součástí stejných balíčků. Opravy hotfix na stránce žádost o opravu Hotfix jsou však uvedeny pod oběma operačními systémy. Chcete-li požádat o balíček oprav hotfix, který se vztahuje k jednomu nebo oboum operačním systémům, vyberte opravu hotfix, která je uvedena na stránce v části "Windows 7/Windows Server 2008 R2". Vždy se v článcích podívejte v části "Platí pro" na to, pro který operační systém je oprava hotfix určená.
-
Soubory týkající se konkrétního produktu, milníku (RTM, SPn) a složky služby (LDR, GDR) lze identifikovat porovnáním čísel verzí souborů podle následující tabulky:
Verze
Výrobek
Milník
Složka služby
6.1.760 1.18xxx
Windows 7 a Windows Server 2008 R2
SP1
GDR
6.1.760 1.22xxx
Windows 7 a Windows Server 2008 R2
SP1
LDR
-
Soubory MANIFEST (.manifest) a soubory MUM (.mum) instalované pro každé prostředí jsou uvedeny samostatně v části "Další informace o souborech". MUM, MANIFEST a příslušné soubory (.cat) katalogu zabezpečení jsou důležité k uchování stavu aktualizované součásti. Soubory katalogu zabezpečení, pro něž nejsou uvedeny atributy, jsou podepsané digitálním podpisem společnosti Microsoft.
Pro všechny podporované verze x86 systému Windows 7
Název souboru |
Verze souboru |
Velikost souboru |
Datum |
Čas |
Platforma |
---|---|---|---|---|---|
Rpcxdr.mof |
Není k dispozici |
4,445 |
10-Jun-2009 |
21:39 |
Není k dispozici |
Rpcxdr.sys |
6.1.7601.18581 |
87,552 |
29-Aug-2014 |
00:32 |
x86 |
Rpcxdr.mof |
Není k dispozici |
4,445 |
10-Jun-2009 |
21:39 |
Není k dispozici |
Rpcxdr.sys |
6.1.7601.22787 |
87,552 |
29-Aug-2014 |
00:33 |
x86 |
Pro všechny podporované verze x64 systému Windows 7 a Windows Server 2008 R2
Název souboru |
Verze souboru |
Velikost souboru |
Datum |
Čas |
Platforma |
---|---|---|---|---|---|
Rpcxdr.mof |
Není k dispozici |
4,445 |
10-Jun-2009 |
21:00 |
Není k dispozici |
Rpcxdr.sys |
6.1.7601.18581 |
105,472 |
29-Aug-2014 |
00:46 |
x64 |
Rpcxdr.mof |
Není k dispozici |
4,445 |
10-Jun-2009 |
21:00 |
Není k dispozici |
Rpcxdr.sys |
6.1.7601.22787 |
105,472 |
29-Aug-2014 |
00:49 |
x64 |
Pro všechny podporované verze IA-64 systému Windows Server 2008 R2
Název souboru |
Verze souboru |
Velikost souboru |
Datum |
Čas |
Platforma |
---|---|---|---|---|---|
Rpcxdr.mof |
Není k dispozici |
4,445 |
04-Jul-2013 |
12:30 |
Není k dispozici |
Rpcxdr.sys |
6.1.7601.18581 |
262,656 |
29-Aug-2014 |
00:20 |
IA-64 |
Rpcxdr.mof |
Není k dispozici |
4,445 |
09-Jul-2013 |
06:36 |
Není k dispozici |
Rpcxdr.sys |
6.1.7601.22787 |
262,656 |
29-Aug-2014 |
00:25 |
IA-64 |
Informace o souborech systému Windows Vista a Windows Server 2008 a poznámky
Důležité: Opravy hotfix pro systém Windows Vista a Windows Server 2008 opravy hotfix jsou součástí stejné balíčků. Opravy hotfix na stránce žádost o opravu Hotfix jsou však uvedeny pod oběma operačními systémy. Chcete-li požádat o balíčku oprav hotfix, která se vztahuje k jedné nebo obou operačních systémů, vyberte opravu hotfix, která je uvedena v části "Windows Vista, Windows Server 2008" na stránce. Vždy se v článcích podívejte v části "Platí pro" na to, pro který operační systém je oprava hotfix určená.
-
Soubory týkající se konkrétního produktu, milníku (RTM, SPn) a složky služby (LDR, GDR) lze identifikovat porovnáním čísel verzí souborů podle následující tabulky:
Verze
Výrobek
Milník
Složka služby
6.0.600 2.19xxx
Systém Windows Vista a Windows Server 2008
SP2
GDR
6.0.600 2.23xxx
Systém Windows Vista a Windows Server 2008
SP2
LDR
-
Soubory MANIFEST (.manifest) a soubory MUM (.mum) instalované pro každé prostředí jsou uvedeny samostatně v části "Další informace o souborech". MUM, MANIFEST a příslušné soubory (.cat) katalogu zabezpečení jsou důležité k uchování stavu aktualizované součásti. Soubory katalogu zabezpečení, pro něž nejsou uvedeny atributy, jsou podepsané digitálním podpisem společnosti Microsoft.
Pro všechny podporované verze systému Windows Vista x86
Název souboru |
Verze souboru |
Velikost souboru |
Datum |
Čas |
Platforma |
---|---|---|---|---|---|
Rpcxdr.mof |
Není k dispozici |
4,424 |
18-Sep-2006 |
21:41 |
Není k dispozici |
Rpcxdr.sys |
6.0.6002.19195 |
77,312 |
24-Sep-2014 |
23:22 |
x86 |
Rpcxdr.mof |
Není k dispozici |
4,424 |
07-May-2014 |
23:50 |
Není k dispozici |
Rpcxdr.sys |
6.0.6002.23499 |
77,824 |
23-Sep-2014 |
23:27 |
x86 |
Pro všechny podporované verze x64 systému Windows Vista a Windows Server 2008
Název souboru |
Verze souboru |
Velikost souboru |
Datum |
Čas |
Platforma |
---|---|---|---|---|---|
Rpcxdr.mof |
Není k dispozici |
4,424 |
18-Sep-2006 |
21:37 |
Není k dispozici |
Rpcxdr.sys |
6.0.6002.19195 |
90,624 |
24-Sep-2014 |
23:32 |
x64 |
Rpcxdr.mof |
Není k dispozici |
4,424 |
07-May-2014 |
23:49 |
Není k dispozici |
Rpcxdr.sys |
6.0.6002.23499 |
91,648 |
23-Sep-2014 |
23:52 |
x64 |
Pro všechny podporované verze IA-64 systému Windows Server 2008
Název souboru |
Verze souboru |
Velikost souboru |
Datum |
Čas |
Platforma |
---|---|---|---|---|---|
Rpcxdr.mof |
Není k dispozici |
4,424 |
03-Jan-2008 |
19:03 |
Není k dispozici |
Rpcxdr.sys |
6.0.6002.19195 |
231,936 |
24-Sep-2014 |
23:21 |
IA-64 |
Rpcxdr.mof |
Není k dispozici |
4,424 |
07-May-2014 |
23:49 |
Není k dispozici |
Rpcxdr.sys |
6.0.6002.23499 |
233,984 |
23-Sep-2014 |
23:27 |
IA-64 |
Stav
Společnost Microsoft potvrdila, že se jedná o problém v produktech společnosti Microsoft, které jsou uvedeny v části "Platí pro".
Další informace
Pro další informace o terminologii používané v aktualizacích softwaru, klepněte na následující číslo článku k zobrazení článku v databázi Microsoft Knowledge Base:
824684 Popis standardní terminologie používané při popisu aktualizací softwaru společnosti Microsoft.
Informace o sledovaných síťových paketůTime Delta Description========== =============================================
0.0000730 NFS:V3 NFSPROC3_GETATTR Service Call Message
0.0000140 NFS:V3 NFSPROC3_GETATTR Service Call Message
0.0000390 NFS:V3 NFSPROC3_GETATTR Service Reply Message
0.0397670 TCP:Flags=...A...., SrcPort=1004, DstPort=NFS(2049)
0.0000200 NFS:V3 NFSPROC3_GETATTR Service Reply Message
Další informace o souborech