Použití aliasu pole v dotazu nefunguje s některé databáze třetích stran

Příznaky

Při pokusu o použití aplikace Microsoft Query vrátit data do aplikace Microsoft Excel z některé databáze třetích stran, apostrofy (') kolem názvů aliasu může způsobit, že se dotaz nezdaří. Chybová zpráva, která se zobrazí, závisí na zdroji dat, který používáte.

Příčina

Toto chování je výsledkem změny návrhu v aplikaci Microsoft Query. Apostrofy jsou nyní automaticky při použití vyhlazení, aby se zabránilo chybám, které jsou způsobeny aliasu, který obsahuje mezery nebo vyhrazená slova.

Řešení

Společnost Microsoft má k dispozici podporovanou opravu hotfix. Tato oprava hotfix je však určena pouze problému popsanému v tomto článku. Použití této opravy hotfix pouze u systémů, ve kterých dochází k tomuto konkrétnímu problému.

Pokud je oprava hotfix k dispozici ke stažení, je v horní části tohoto článku znalostní báze Knowledge Base oddíl "Oprava Hotfix je dostupná ke stažení" . Pokud tento oddíl není uveden, odešlete požadavek na Microsoft Zákaznický servis a podporu k získání opravy hotfix.

Poznámka: Pokud nastanou další problémy nebo bude nutné další řešení potíží, bude možná třeba vytvořit další samostatný požadavek na služby. Běžná cena za technickou podporu se vztahuje k dodatečným otázkám podpory a k problémům, které se netýkají této konkrétní opravy hotfix. Úplný seznam telefonních čísel služeb zákazníkům společnosti Microsoft a podpoře nebo vytvořit zvláštní požadavek na službu naleznete na následujícím webu společnosti Microsoft:

Poznámka: Ve formuláři „Oprava hotfix je dostupná ke stažení“ se zobrazují jazyky, pro které je oprava hotfix k dispozici. Pokud váš jazyk není zobrazen, to je protože oprava hotfix není k dispozici pro daný jazyk.

Aplikace Excel 2003 a Excel 2007

Nemusíte stahovat žádné potíže v aplikaci Microsoft Office Excel 2003 nebo Microsoft Office Excel 2007. Naleznete v části "Další informace" tohoto článku, vyhledejte pokyny pro povolení této funkce

Aplikace Excel 2002

Globální aplikace Excel 2002 verze této opravy hotfix má atributy souborů (nebo novější) uvedené v následující tabulce. Kalendářní data a časy jednotlivých souborů jsou uvedeny v koordinovaném světovém čase (UTC). Při zobrazení informací o souboru je převeden na místní čas. Rozdíl mezi časem UTC a místním časem, naleznete na kartě časové pásmo na panelu Datum a čas v okně Ovládací panely.

Název souboru

Velikost souboru

Datum

Čas

Msqry32.msp

2,100,760

24-Sep-2002

01:29

Msqry32_admin.msp

1,331,424

24-Sep-2002

03:52

Po instalaci opravy hotfix budou následující soubory obsahovat uvedené atributy nebo novější:

Název souboru

Verze souboru

Velikost souboru

Datum

Čas

Msqry32.exe

10.0.4510.0

739,912

13-Sep-2002

03:52

Aplikace Excel 2000

Globální aplikace Excel 2000 verze této opravy hotfix má atributy souborů (nebo novější) uvedené v následující tabulce. Kalendářní data a časy jednotlivých souborů jsou uvedeny v koordinovaném světovém čase (UTC). Při zobrazení informací o souboru je převeden na místní čas. Rozdíl mezi časem UTC a místním časem, naleznete na kartě časové pásmo na panelu Datum a čas v okně Ovládací panely.

Název souboru

Velikost souboru

Datum

Čas

Msqry32.msp

1,166,692

08-Nov-2002

13:41

Msqry32_admin.msp

1,419,628

08-Nov-2002

16:36

Po instalaci opravy hotfix budou následující soubory obsahovat uvedené atributy nebo novější:

Název souboru

Verze souboru

Velikost souboru

Datum

Čas

Msqry32.exe

9.0.0.6919

1,089,536

19-Sep-2002

20:31

Po instalaci této opravy hotfix postupujte podle kroků, které jsou uvedeny v části "Další informace" tohoto článku nastavit klíč registru AllowAlias a aktivaci opravy hotfix.

Poznámka: Po instalaci opravy popsané v tomto článku a nastavit klíč registru AllowAlias Microsoft Query se bude chovat stejně jako v aplikaci Excel 97.


Jak potíže obejít

Společnost Microsoft poskytuje ukázky programování pouze pro ilustraci bez žádné záruky výslovně uvedené nebo odvozené. To zahrnuje, ale není omezen pouze na předpokládané záruky obchodovatelnosti nebo vhodnosti pro určitý účel. Tento článek předpokládá, že jste obeznámeni s programovacím jazykem, který je předmětem ukázky a s nástroji, které slouží k vytvoření a ladění skriptu. Pracovníci podpory společnosti Microsoft mohou pomoci vysvětlit funkce určitého postupu, nemohou však následující příklady rozšířit o další funkce nebo vytvářet postupy podle vašich konkrétních požadavků.

Chcete-li tento problém vyřešit, přidejte uvozovky alias z uvnitř aplikace Microsoft Query. Chcete-li to provést, postupujte takto:

  1. Poklepejte na název pole v aplikaci Microsoft Query.

  2. V dialogovém okně Upravit sloupce zadejte název aliasu pole uzavřeny v uvozovkách.

    Zadejte například
    "Petr" (včetně uvozovek) a potom klepněte na tlačítko
    OK.

    Poté, co vrátíte data zpět do aplikace Excel můžete použít Microsoft Visual základy pro Applications (VBA) SQL upravit a odstranit uvozovky z tabulky dotazu nebo z kontingenční tabulky:

    ActiveSheet.Querytable(1).SQL = "new sql string"
    ActiveSheet.PivotTables(1).Pivotcache.Commandtext = "new sql string"

Stav

Společnost Microsoft potvrzuje, že se jedná o problém v produktech této společnosti, které jsou uvedeny v části "Platí pro" tohoto článku.

Další informace

Důležité: Tento oddíl, metoda nebo úkol obsahuje kroky, které popisují úpravu registru. Při nesprávné úpravě registru mohou nastat závažné problémy Proto se ujistěte, že budete opatrně postupovat podle těchto kroků Pro zvýšení ochrany před úpravou zálohujte registr. Pokud dojde k potížím, pak můžete registr obnovit ze zálohy. Pro další informace o zálohování a obnovení registru klepněte na následující číslo článku databáze Microsoft Knowledge Base:

postup zálohování a obnovení registru v systému WindowsPo instalaci této opravy hotfix, postupujte takto Chcete-li nastavit klíč registru AllowAlias a aktivaci opravy hotfix. Proveďte příslušné kroky pro vaši verzi aplikace Excel.

Aplikace Excel 2010

Nemáte nainstalujte opravu hotfix. Chcete-li povolit tuto opravu hotfix, postupujte takto:

  1. Ukončete všechny aplikace sady Office.

  2. Klepněte na tlačítko Starta potom klepněte na příkaz Spustit.

  3. Do pole Otevřít zadejte příkaz regedita klepněte na tlačítko OK.

  4. Vyhledejte a poté klepnutím vyberte následující podklíč registru: HKEY_CURRENT_USER\Software\Microsoft\Office\14.0\query\optionspoté, co vyberete podklíč určený v kroku 4, v nabídce Úpravy přejděte na příkaz Nový a klepněte na příkaz Hodnota DWORD.

  5. Zadejte AllowAliasa stiskněte klávesu ENTER.

  6. AllowAliasklepněte pravým tlačítkem myši a potom klepněte na příkaz změnit.

  7. V poli Údaj hodnoty zadejte 2a potom klepněte na tlačítko OK.

  8. V nabídce soubor klepněte na tlačítko Ukončit ukončete Editor registru.


Excel 2007

Nemáte nainstalujte opravu hotfix. Chcete-li povolit tuto opravu hotfix, postupujte takto:

  1. Ukončete všechny aplikace sady Office.

  2. Klepněte na tlačítko Start a potom klepněte na příkaz Spustit.

  3. Do pole Otevřít zadejte regedita klepněte na tlačítko OK.

  4. Vyhledejte a poté klepnutím vyberte následující podklíč registru:

    HKEY_CURRENT_USER\Software\Microsoft\Office\12.0\query\options

  5. Poté, co vyberete podklíč určený v kroku 4, v nabídce Úpravy přejděte na příkaz Nový a klepněte na příkaz Hodnota DWORD.

  6. Zadejte AllowAliasa stiskněte klávesu ENTER.

  7. AllowAliasklepněte pravým tlačítkem myši a potom klepněte na příkaz změnit.

  8. V poli Údaj hodnoty zadejte hodnotu 2 a pak klepněte na tlačítko OK.

  9. V nabídce Soubor klepněte na tlačítko Ukončit k ukončení Editoru registru.

Aplikace Excel 2003

Nemáte nainstalujte opravu hotfix. Chcete-li povolit tuto opravu hotfix, postupujte takto:

  1. Ukončete všechny aplikace sady Office.

  2. Klepněte na tlačítko Start a potom klepněte na příkaz Spustit.

  3. Do pole Otevřít zadejte regedita klepněte na tlačítko OK.

  4. Vyhledejte a poté klepnutím vyberte následující podklíč registru:

    HKEY_CURRENT_USER\Software\Microsoft\Office\11.0\query\options

  5. Poté, co vyberete podklíč určený v kroku 4, v nabídce Úpravy přejděte na příkaz Nový a klepněte na příkaz Hodnota DWORD.

  6. Zadejte AllowAliasa stiskněte klávesu ENTER.

  7. AllowAliasklepněte pravým tlačítkem myši a potom klepněte na příkaz změnit.

  8. V poli Údaj hodnoty zadejte hodnotu 2 a pak klepněte na tlačítko OK.

  9. V nabídce Soubor klepněte na tlačítko Ukončit k ukončení Editoru registru.

Aplikace Excel 2002

Tato aktualizace byla poprvé zahrnuta v aktualizaci Office XP Service Pack 3. Další informace o nejnovější aktualizaci service pack pro sadu Office XP klepněte na následující číslo článku databáze Microsoft Knowledge Base:

jak získat nejnovější Service Pack XP OfficeChcete-li povolit tuto opravu hotfix, postupujte takto:

  1. Ukončete všechny aplikace sady Office.

  2. Klepněte na tlačítko Starta potom klepněte na tlačítko
    Spustit.

  3. Do pole Otevřít zadejte
    regedita klepněte na tlačítko OK.

  4. Vyhledejte a poté klepnutím vyberte následující podklíč registru:

    HKEY_CURRENT_USER\Software\Microsoft\Office\10.0\query\options

  5. Poté, co vyberete podklíč určený v kroku 4, v nabídce Úpravy přejděte na příkaz Nový a potom klepněte na tlačítko
    Hodnota DWORD.

  6. Zadejte AllowAliasa stiskněte klávesu ENTER.

  7. AllowAliasklepněte pravým tlačítkem myši a potom klepněte na tlačítko
    Upravit.

  8. Do pole Údaj hodnoty zadejte
    2a potom klepněte na tlačítko OK.

  9. V nabídce soubor klepněte na tlačítko
    Ukončete Editor registru Ukončete .

Aplikace Excel 2000

Chcete-li povolit tuto opravu hotfix, postupujte takto:

  1. Ukončete všechny aplikace sady Office.

  2. Klepněte na tlačítko Starta potom klepněte na tlačítko
    Spustit.

  3. Do pole Otevřít zadejte
    regedita klepněte na tlačítko OK.

  4. Vyhledejte a poté klepnutím vyberte následující podklíč registru:

    HKEY_CURRENT_USER\Software\Microsoft\Office\9.0\query\options

  5. Poté, co vyberete podklíč určený v kroku 4, v nabídce Úpravy přejděte na příkaz Nový a potom klepněte na tlačítko
    Hodnota DWORD.

  6. Zadejte AllowAliasa stiskněte klávesu ENTER.

  7. AllowAliasklepněte pravým tlačítkem myši a potom klepněte na tlačítko
    Upravit.

  8. Do pole Údaj hodnoty zadejte
    2a potom klepněte na tlačítko OK.

  9. V nabídce soubor klepněte na tlačítko
    Ukončete Editor registru Ukončete .

Odkazy

Pokud není nutné použít vyhlazení s aplikací Microsoft Query, můžete vypnout vytváření aliasů úplně.

Další informace o tom, jak vypnout vytváření aliasů v aplikaci Microsoft Query klepněte na následující číslo článku databáze Microsoft Knowledge Base:

XL2000: chybová zpráva: ORA-00923: Z není nalezeno očekávané klíčové slovo

Potřebujete další pomoc?

Rozšiřte své znalosti a dovednosti
Projít školení
Získejte nové funkce jako první
Připojit se k programu Microsoft Insider

Byly tyto informace užitečné?

Děkujeme za váš názor!

Děkujeme vám za váš názor! Pravděpodobně bude užitečné, když vás spojíme s některým z našich agentů podpory Office.

×