Přihlásit se pomocí účtu Microsoft
Přihlaste se nebo si vytvořte účet.
Dobrý den,
Vyberte jiný účet.
Máte více účtů.
Zvolte účet, pomocí kterého se chcete přihlásit.

Příznaky

Problém 1

Jde o takovouto situaci:

  • Vytvoření virtuálního počítače technologie Hyper-V v počítači se systémem Windows Server 2008.

  • Vyberete možnost připojit rozdílový disk, který byl vytvořen v počítači se systémem Windows Server 2008 R2.

V tomto scénáři může zobrazit následující chybové zprávy:

Server zjistil chybu při konfiguraci pevného disku na VMName.
Přidání zařízení ' Microsoft virtuální pevný Disk' se nezdařilo.
Nelze otevřít přílohu'< NazevAdresare >\Filename.vhd'. Chyba: "soubor nebo adresář je poškozený a nečitelný."
Nelze získat informace o přílohu'< NazevAdresare >\Filename.vhd'.

Problém 2

Jde o takovouto situaci:

  • System Center Virtual Machine Manager 2008 R2 je Správa serveru Windows Server 2008, který má roli komponenty Hyper nainstalována a serveru Windows Server 2008 R2, který má nainstalovanou rolí Hyper-V

  • Virtuálního počítače technologie Hyper-V migraci ze systému Windows Server 2008 R2 na Windows Server 2008.

V tomto scénáři můžete obdržet následující chybová zpráva::

Chyba (1730)
Vybranou akci nelze dokončit, protože virtuální počítač není ve stavu, ve kterém je akce platná.

Příčina

K tomuto problému dochází, protože ovladač Vhdparser.sys v systému Windows Server 2008 nesprávně zpracovává hodnoty metadat. Tato hodnota se používá v rozdílové disky, které jsou vytvořeny na serveru se systémem Windows Server 2008 R2.

Řešení

Informace o opravě hotfix

Společnost Microsoft má k dispozici podporovanou opravu hotfix. Tato oprava hotfix je však určena pouze problému popsanému v tomto článku. Tuto opravu hotfix instalujte pouze do systémů, ve kterých dochází k potížím popsaným v tomto článku. Tato oprava hotfix může být dále testována. Proto pokud nejste vážně ohrožen tímto problémem, doporučujeme počkat na další aktualizaci softwaru, která obsahuje tuto opravu hotfix.

Pokud je oprava hotfix k dispozici ke stažení, je v horní části tohoto článku znalostní báze Knowledge Base oddíl "Oprava Hotfix je dostupná ke stažení" . Pokud tato sekce není uvedena, obraťte se na Zákaznický servis a podporu společnosti Microsoft k získaní opravy hotfix.

Poznámka: Pokud nastanou další problémy nebo bude nutné další řešení potíží, bude možná třeba vytvořit další samostatný požadavek na služby. Běžná cena za technickou podporu se vztahuje k dodatečným otázkám podpory a k problémům, které se netýkají této konkrétní opravy hotfix. Úplný seznam telefonních čísel služeb zákazníkům společnosti Microsoft a podpoře nebo vytvořit zvláštní požadavek na službu naleznete na následujícím webu společnosti Microsoft:

http://support.microsoft.com/contactus/? ws=supportPoznámka: Ve formuláři „Oprava hotfix je dostupná ke stažení“ se zobrazují jazyky, pro které je oprava hotfix k dispozici. Pokud váš jazyk není zobrazen, to je protože oprava hotfix není k dispozici pro daný jazyk.

Důležité opravy hotfix systému Windows Vista a Windows Server 2008 jsou součástí stejné balíčků. Pouze jeden z těchto produktů však může být uvedena na stránce "Hotfix požadavek". Chcete-li požádat o balíčku oprav hotfix vztahující se k systému Windows Vista a Windows Server 2008, stačí pouze vyberte produkt, který je uveden na stránce.

Předpoklady

Chcete-li nainstalovat tuto opravu hotfix, musí být v počítači spuštěn jeden z následujících operačních systémů:

  • Windows Server 2008

  • Windows Server 2008 Service Pack 2 (SP2)

Navíc musíte mít roli Hyper-v počítači nainstalována.

Požadavek na restartování

Po instalaci této opravy hotfix musíte restartovat počítač.

Informace o registrech

Nemáte změnu registru.

Informace o souborech

Anglická verze této opravy hotfix má atributy (nebo pozdější atributy souborů) uvedené v následující tabulce. Kalendářní data a časy jednotlivých souborů jsou uvedeny v koordinovaném světovém čase (UTC). Při zobrazení informací o souboru je převeden na místní čas. Rozdíl mezi místním časem a časem UTC naleznete na kartě Časové pásmo v položce Datum a čas v okně Ovládací panely.


Pro všechny podporované verze systému Windows Server 2008 x64

Název souboru

Verze souboru

Velikost souboru

Datum

Čas

Platforma

Požadavek na aktualizaci SP

Isoparser.sys

6.0.6001.22445

19,968

08-Jun-2009

17:43

x64

SP1

Passthruparser.sys

6.0.6001.22445

28,672

08-Jun-2009

17:43

x64

SP1

Storvsp.sys

6.0.6001.22445

133,120

08-Jun-2009

17:43

x64

SP1

Vhdparser.sys

6.0.6001.22445

94,208

08-Jun-2009

17:43

x64

SP1

Wstorvsp.inf

Není k dispozici

6,462

08-Jun-2009

14:59

Není k dispozici

SP1


Pro všechny podporované verze systému Windows Server 2008 SP2 x64

Název souboru

Verze souboru

Velikost souboru

Datum

Čas

Platforma

Požadavek na aktualizaci SP

Isoparser.sys

6.0.6002.22148

19,968

08-Jun-2009

17:27

x64

SP2

Passthruparser.sys

6.0.6002.22148

28,672

08-Jun-2009

17:27

x64

SP2

Storvsp.sys

6.0.6002.22148

122,880

08-Jun-2009

17:27

x64

SP2

Vhdparser.sys

6.0.6002.22148

87,552

08-Jun-2009

17:27

x64

SP2

Wstorvsp.inf

Není k dispozici

6,462

08-Jun-2009

14:59

Není k dispozici

SP2


Další informace

Další informace získáte v následujícím článku znalostní báze Microsoft Knowledge Base:

824684 Popis standardní terminologie používané při popisu aktualizací softwaru společnosti Microsoft


Stav

Společnost Microsoft potvrdila, že se jedná o problém v produktech společnosti Microsoft, které jsou uvedeny v části "Platí pro".

Potřebujete další pomoc?

Chcete další možnosti?

Prozkoumejte výhody předplatného, projděte si školicí kurzy, zjistěte, jak zabezpečit své zařízení a mnohem více.

Komunity vám pomohou klást otázky a odpovídat na ně, poskytovat zpětnou vazbu a vyslechnout odborníky s bohatými znalostmi.

Byly tyto informace užitečné?

Jak jste spokojeni s kvalitou jazyka?
Co ovlivnilo váš názor?
Po stisknutí tlačítka pro odeslání se vaše zpětná vazba použije k vylepšování produktů a služeb Microsoftu. Váš správce IT bude moci tato data shromažďovat. Prohlášení o zásadách ochrany osobních údajů.

Děkujeme vám za zpětnou vazbu.

×