Přihlásit se pomocí účtu Microsoft
Přihlaste se nebo si vytvořte účet.
Dobrý den,
Vyberte jiný účet.
Máte více účtů.
Zvolte účet, pomocí kterého se chcete přihlásit.

Příznaky

Jde o takovouto situaci:

  • Použít službu Distributed soubor systému replikace (DFSR) v prostředí domény se systémem Windows Server 2008 R2.

  • Máte v prostředí domény skupiny replikace distribuovaného systému souborů (DFS).

  • Služba DFSR je použít k replikaci souborů ve skupině replikace distribuovaného systému souborů. Jsou velké velikosti některých souborů. Velikost souboru je například 10 gigabajtů (GB).

V tomto scénáři nelze replikovat, jsou velké soubory.

Poznámky

  • K tomuto problému obvykle dochází při připojení replikace je otevřen a pak často uzavřen. To je způsobeno úlohy naplánované replikace nebo nespolehlivá síťová připojení.

  • V protokolu ladění DFSR jsou informace, které uvádí částečnou kopii replikovaného souboru uložen a pak klesla. Například pokud dojde k problému, je generován následující informace v protokolu ladění DFSR:
    20121031 08:32:17.168 2376 RDCX 882 [WARN] Rdc::SeedFile::Initialize (Ignored) Abandoning candidate file . uid:{C5B5CBC3-EAFF-4C3B-9F5F-BC5C27EC44A8}-v103 gvsn:{C5B5CBC3-EAFF-4C3B-9F5F-BC5C27EC44A8}-v104 fileName :
    ri2k3-dc1.vhd csId:{A739B084-9C47-4514-97DB-D8E4344D6438}
    Candidate(uid:{C5B5CBC3-EAFF-4C3B-9F5F-BC5C27EC44A8}-v103
    gvsn:{C5B5CBC3-EAFF-4C3B-9F5F-BC5C27EC44A8}-v104
    fileName:104-{C5B5CBC3-EAFF-4C3B-9F5F-BC5C27EC44A8}-v103-{C5B5CBC3-EAFF-4C3B-9F5F-BC5C27EC44A8}-v104- Partial.frx )
    + [Error:9048(0x2358) StageReader::Serialize staging.cpp:529 2376 C The compressed data is invalid ]
    + [Error:9048(0x2358) Rdc::StagingClosure::Run rdc.cpp:3947 2376 C The compressed data is invalid]
    + [Error:9048(0x2358) Rdc::Common::StageFile rdc.cpp:3574 2376 C The compressed data is invalid]
    + [Error:9048(0x2358) StreamToIndex rdc.cpp:529 2376 C The compressed data is invalid]
    + [Error:9048(0x2358) SignatureGenerator rdc.cpp:279 2376 C The compressed data is invalid]
    + [Error:9048(0x2358) XpressUncompressReader::Read xpressstreams.cpp:1379 2376 C The compressed data is invalid]
    + [Error:9048(0x2358) XpressUncompressReader::Read xpressstreams.cpp:1323 2376 C The compressed data is invalid]

Příčina

K tomuto problému dochází, protože DFSR domnívá, částečnou kopii replikovaného souboru jako neplatné. Pokud v jedné relaci nelze replikovat velký soubor, uloží DFSR částečné kopie replikovaných souborů, takže proces replikace může pokračovat od místa zastavení. Vzhledem k tomu, že částečná kopie tohoto souboru je považován za neplatný DFSR, je opětovné spuštění procesu replikace DFSR. Připojení replikace je nikdy otevřen dostatečně dlouhou dobu k dokončení procesu replikace. Proto nelze replikovat velké soubory.

Řešení

Informace o opravě hotfix

Společnost Microsoft má k dispozici podporovanou opravu hotfix. Tato oprava hotfix je však určena pouze problému popsanému v tomto článku. Tuto opravu hotfix instalujte pouze do systémů, ve kterých dochází k potížím popsaným v tomto článku. Tato oprava hotfix může být dále testována. Proto pokud nejste vážně ohrožen tímto problémem, doporučujeme počkat na další aktualizaci softwaru, která obsahuje tuto opravu hotfix.

Pokud je oprava hotfix k dispozici ke stažení, je v horní části tohoto článku znalostní báze Knowledge Base oddíl "Oprava Hotfix je dostupná ke stažení" . Pokud tato sekce není uvedena, obraťte se na Zákaznický servis a podporu společnosti Microsoft k získaní opravy hotfix.

Poznámka: Pokud nastanou další problémy nebo bude nutné další řešení potíží, bude možná třeba vytvořit další samostatný požadavek na služby. Běžná cena za technickou podporu se vztahuje k dodatečným otázkám podpory a k problémům, které se netýkají této konkrétní opravy hotfix. Pro úplný seznam telefonních čísel společnosti Microsoft Zákaznikého servisu a podpory nebo chcete-li vytvořit zvláštní požadavek na službu navštivte následující web společnosti Microsoft:

http://support.microsoft.com/contactus/?ws=supportPoznámka: Ve formuláři „Oprava hotfix je dostupná ke stažení“ se zobrazují jazyky, pro které je oprava hotfix k dispozici. Pokud váš jazyk není zobrazen, to je protože oprava hotfix není k dispozici pro daný jazyk.

Předpoklady

Chcete-li nainstalovat tuto opravu hotfix, musíte používat systém Windows Server 2008 R2 Service Pack 1 (SP1).

Další informace o získání aktualizace service pack systému Windows 7 nebo Windows Server 2008 R2 klepněte na následující číslo článku naleznete v článku znalostní báze Microsoft Knowledge Base:

976932 Informace o aktualizaci Service Pack 1 pro systém Windows 7 a Windows Server 2008 R2

Informace o registrech

Chcete-li nainstalovat tuto opravu hotfix, není nutné provádět žádné změny registru.

Požadavek na restartování

Po instalaci této opravy hotfix musíte restartovat počítač.

Informace o nahrazení opravy hotfix

Tato oprava hotfix nenahrazuje dříve vydanou opravu hotfix.

Globální verze této opravy hotfix nainstaluje soubory, jejichž atributy jsou uvedeny v následujících tabulkách. Kalendářní data a časy jednotlivých souborů jsou uvedeny v koordinovaném světovém čase (UTC). Kalendářní data a časy těchto souborů v místním počítači jsou zobrazeny dle vašeho místního času a také podle aktuálního letního času (DST). Navíc data a časy se mohou změnit při provádění některých operací se soubory.

Poznámky k informacím o souboru systému Windows Server 2008 R2Důležité: Opravy hotfix pro systém Windows 7 a Windows Server 2008 R2 opravy hotfix jsou součástí stejných balíčků. Opravy hotfix na stránce žádost o opravu Hotfix jsou však uvedeny pod oběma operačními systémy. Chcete-li požádat o balíček oprav hotfix, který se vztahuje k jednomu nebo oboum operačním systémům, vyberte opravu hotfix, která je uvedena na stránce v části "Windows 7/Windows Server 2008 R2". Vždy se v článcích podívejte v části "Platí pro" na to, pro který operační systém je oprava hotfix určená.

  • Soubory týkající se konkrétního produktu, SR_Level (RTM, SPn) a služby (LDR, GDR) lze identifikovat porovnáním čísel verzí souborů podle následující tabulky:

    Verze

    Výrobek

    Milník

    Složka služby

    6.1.760
    1.17 xxx

    Windows Server 2008 R2

    SP1

    GDR

    6.1.760
    1.22 xxx

    Windows Server 2008 R2

    SP1

    LDR

  • Složky služby GDR obsahují pouze opravy, které byly veřejně vydány k odstranění rozšířených závažných problémů. Větve LDR obsahují kromě veřejně vydaných oprav i opravy hotfix.

  • Soubory MANIFEST (.manifest) a soubory MUM (.mum) instalované pro každé prostředí jsou uvedeny samostatně v části "Další informace o souborech pro systém Windows Server 2008 R2". MUM a MANIFEST soubory a soubory katalogu (CAT) přidružené zabezpečení, jsou velice důležité k uchování stavu aktualizované součásti. Soubory katalogu zabezpečení, pro něž nejsou uvedeny atributy, jsou podepsané digitálním podpisem společnosti Microsoft.

Pro všechny podporované verze systému Windows Server 2008 R2 x64

Název souboru

Verze souboru

Velikost souboru

Datum

Čas

Platforma

Dfsrprovs.mof

Není k dispozici

75,761

29-Mar-2013

07:32

Není k dispozici

Dfsrress.dll

6.1.7601.17514

2 048

20-Nov-2010

12:57

x64

Dfsrs.exe

6.1.7601.22288

4,535,808

29-Mar-2013

11:18

x64


Stav

Společnost Microsoft potvrdila, že se jedná o problém v produktech společnosti Microsoft, které jsou uvedeny v části "Platí pro".

Další informace

Další informace o terminologii aktualizace softwaru klepněte na následující číslo článku naleznete v článku znalostní báze Microsoft Knowledge Base:

824684 Popis standardní terminologie používané k popisu aktualizací softwaru společnosti Microsoft

Další informace o souborech pro systém Windows Server 2008 R2

Další soubory pro všechny podporované verze systému Windows Server 2008 R2 x64

Název souboru

Amd64_microsoft-windows-dfsr-core-serveronly_31bf3856ad364e35_6.1.7601.22288_none_fbf38684d7b9c678.manifest

Verze souboru

Není k dispozici

Velikost souboru

35,681

Datum (čas UTC)

31-Mar-2013

Čas (UTC)

17:28

Platforma

Není k dispozici


Potřebujete další pomoc?

Chcete další možnosti?

Prozkoumejte výhody předplatného, projděte si školicí kurzy, zjistěte, jak zabezpečit své zařízení a mnohem více.

Komunity vám pomohou klást otázky a odpovídat na ně, poskytovat zpětnou vazbu a vyslechnout odborníky s bohatými znalostmi.

Byly tyto informace užitečné?

Jak jste spokojeni s kvalitou jazyka?
Co ovlivnilo váš názor?
Po stisknutí tlačítka pro odeslání se vaše zpětná vazba použije k vylepšování produktů a služeb Microsoftu. Váš správce IT bude moci tato data shromažďovat. Prohlášení o zásadách ochrany osobních údajů.

Děkujeme vám za zpětnou vazbu.

×