Přihlásit se pomocí účtu Microsoft
Přihlaste se nebo si vytvořte účet.
Dobrý den,
Vyberte jiný účet.
Máte více účtů.
Zvolte účet, pomocí kterého se chcete přihlásit.

Příznaky

Jde o takovouto situaci:

  • Služba TN3270 Server vyhledá certifikát SSL od poskytovatele infrastruktury veřejných klíčů (PKI).

  • Certifikát SSL byl společný název požadované.

V tomto scénáři služba TN3270 Server nenajde certifikát SSL. Proto nemůže implementovat certifikát SSL.

Při kontrole trasování služby TN3270 Server, které jsou zachyceny pomocí nástroj SNA Trace zobrazí následující řádky sledování:

Look for server auth cert with subject containing CN 'Sernername.Company.Com' Find a certificate with required subject CN Find Certificate in Store failed, error 0x80092004 Search 0 exhausted Find a certificate with required subject CN Find Certificate in Store failed, error 0x80092004 Search 1 exhausted Failed to get certificate from the store

Příčina

K tomuto problému dochází, protože běžný název certifikátu vystaveného používá kódování CERT_RDN_UTF8_STRING. Pokud kódování CERT_RDN_PRINTABLE_STRING je použita, vše funguje správně.

Řešení

Informace o opravě hotfix



Společnost Microsoft má k dispozici podporovanou opravu hotfix. Tato oprava hotfix je však určena pouze problému popsanému v tomto článku. Tuto opravu hotfix instalujte pouze do systémů, ve kterých dochází k potížím popsaným v tomto článku. Tato oprava hotfix může být dále testována. Proto pokud nejste vážně ohrožen tímto problémem, doporučujeme počkat na další aktualizaci softwaru, která obsahuje tuto opravu hotfix.
Pokud je oprava hotfix k dispozici ke stažení, je v horní části tohoto článku znalostní báze Knowledge Base oddíl "Oprava Hotfix je dostupná ke stažení" . Pokud tato sekce není uvedena, obraťte se na Zákaznický servis a podporu společnosti Microsoft k získaní opravy hotfix.

Poznámka: Pokud nastanou další problémy nebo bude nutné další řešení potíží, bude možná třeba vytvořit další samostatný požadavek na služby. Běžná cena za technickou podporu se vztahuje k dodatečným otázkám podpory a k problémům, které se netýkají této konkrétní opravy hotfix. Úplný seznam telefonních čísel Zákaznického servisu a podpory společnosti Microsoft naleznete na následujícím webu podpory společnosti Microsoft, kde také můžete vytvořit samostatný požadavek na služby:

http://support.microsoft.com/default.aspx?scid=fh; [LN]; CNTACTMS

Poznámka: Ve formuláři „Oprava hotfix je dostupná ke stažení“ se zobrazují jazyky, pro které je oprava hotfix k dispozici. Pokud váš jazyk není zobrazen, to je protože oprava hotfix není k dispozici pro daný jazyk.

Předpoklady

Musí mít balíček kumulativní aktualizace 10 pro Microsoft Host Integration Server 2010 nainstalovat tuto opravu hotfix. Další informace o tom, jak získat balíček kumulativní aktualizace, klepněte na následující číslo článku databáze Microsoft Knowledge Base:

2917398 kumulativní aktualizace 10 pro server Host Integration Server 2010

Další informace

Po instalaci opravy hotfix, pokusí se služba TN3270 Server obě kódování při hledání certifikátu.

Informace o kumulativní aktualizaci

Oprava tohoto problému je zahrnuta v balíčku kumulativní aktualizace 3 pro Host Integration Server 2013. Další informace o tom, jak získat kumulativní balíček aktualizace naleznete v tématu kumulativní aktualizace 3 pro Host Integration Server 2013.

Stav

Společnost Microsoft potvrdila, že se jedná o problém v produktech společnosti Microsoft, které jsou uvedeny v části "Platí pro".

Potřebujete další pomoc?

Chcete další možnosti?

Prozkoumejte výhody předplatného, projděte si školicí kurzy, zjistěte, jak zabezpečit své zařízení a mnohem více.

Komunity vám pomohou klást otázky a odpovídat na ně, poskytovat zpětnou vazbu a vyslechnout odborníky s bohatými znalostmi.

Byly tyto informace užitečné?

Jak jste spokojeni s kvalitou jazyka?
Co ovlivnilo váš názor?
Po stisknutí tlačítka pro odeslání se vaše zpětná vazba použije k vylepšování produktů a služeb Microsoftu. Váš správce IT bude moci tato data shromažďovat. Prohlášení o zásadách ochrany osobních údajů.

Děkujeme vám za zpětnou vazbu.

×