Přihlásit se pomocí účtu Microsoft
Přihlaste se nebo si vytvořte účet.
Dobrý den,
Vyberte jiný účet.
Máte více účtů.
Zvolte účet, pomocí kterého se chcete přihlásit.

Příznaky

Tato aktualizace řeší následující problémy s tiskem v počítači se systémem Windows Vista nebo Windows Server 2008.

Problém 1

Jde o takovouto situaci:

  • Pokusíte se vytisknout soubor v počítači se systémem Windows Vista nebo Windows Server 2008.

  • Tiskárna používá tiskový procesor WinPrint.

  • Můžete vytisknout jednu kopii vícestránkového dokumentu.

  • Můžete vytisknout více kopií dokumentu jednostránkové.

  • V dialogovém okně Tisk vyberete možnost Kompletovat .

V tomto scénáři je objednáno výstup, pokud není vybrána možnost Kompletovat.


Poznámka: Tiskárny může mít několik funkcí, které mohou způsobit, že tištěný výstup obsahuje více stránek než původní soubor. To zahrnuje následující funkce:

  • Přidat vazby na přední nebo zadní

  • Vložit stránky v zadaném umístění tiskové úlohy

  • Vložit oddělovací stránky

  • Tisk s uloženou úlohu. Například přidání průvodní dopis do uložených dokumentů a jejich tisk společně jako jedna úloha.

Problém 2

Jde o takovouto situaci:

  • Nastavit tiskový server převzetí služeb při selhání clusteru v počítači se systémem Windows Server 2008.

  • Je-li nainstalovat tiskárnu, která podporuje vlastní formuláře v clusteru. Podpora vlastního formuláře umožňuje tisknout vlastní formuláře, jako je například přání, vizitek a jiných vlastních formulářů.

  • Vytvoříte novou položku registru DWORD s názvem AllowUserManageForms v následujícím podklíči:

    HKLM\Cluster\Resources\<PrintSpoolerGUID>\Parameters
    Potom nastavte hodnotu položky registru na 1.

  • V Ovládacích panelechklepněte na položku tiskárnya potom vytvořit vlastní formulář v dialogovém okně Vlastnosti tiskového serveru .

  • Nastavení předvoleb tisku na tiskárně, takže tiskárny lze použít vlastní formulář.

  • Přesunutí prostředku služby zařazování tisku rychle mezi dvěma uzly několikrát.

V tomto scénáři zhroutí služba zařazování tisku (Spoolsv.exe), která je volána pro tuto tiskovou úlohu. V protokolu aplikací je dále zaznamenána chybová zpráva podobná následující:


Chyba aplikace: ID události 1000

Obecné: Chybující aplikace spoolsv.exe, verze 6.0.6002.18005, časové razítko 0x49e03626, chybující modul ntdll.dll, verze 6.0.6002.18005, časové razítko 0x49e0421d, kód výjimky 0xc0000005, posun poruchy < posun >id procesu < id >čas zahájení aplikace < čas zahájení >.







Když nastane tento problém, zobrazí se stav prostředku služby zařazování tisku jako "Čekající Online," "Čekající Offline" nebo "Online".

Poznámka: Může být stále tato chybová zpráva Pokud je prostředek služby zařazování tisku v tomto uzlu úspěšně přesunut v modulu snap-in Správa clusteru převzetí služeb při selhání. K tomuto chování dochází, protože služba zařazování tisku byla restartována.

Příčina

K tomuto problému dochází, protože služba zařazování tisku se pokusí získat přístup k uvolněné paměti. To způsobí selhání služby zařazování.

Řešení

Oprava hotfix je k dispozici pro řešení výše uvedených problémů.

Poznámka: Tiskárny ovladač musí explicitely nastavit klíč registru SinglePageKeepCollate na tiskové frontě voláním (funkce SetPrinterData) rozhraní API. Tato hodnota není nastavena ve výchozím nastavení.

Informace o opravě hotfix

Společnost Microsoft má k dispozici podporovanou opravu hotfix. Tato oprava hotfix je však určena pouze problému popsanému v tomto článku. Tuto opravu hotfix instalujte pouze do systémů, ve kterých dochází k potížím popsaným v tomto článku. Tato oprava hotfix může být dále testována. Proto pokud nejste vážně ohrožen tímto problémem, doporučujeme počkat na další aktualizaci softwaru, která obsahuje tuto opravu hotfix.

Pokud je oprava hotfix k dispozici ke stažení, je v horní části tohoto článku znalostní báze Knowledge Base oddíl "Oprava Hotfix je dostupná ke stažení" . Pokud tato sekce není uvedena, obraťte se na Zákaznický servis a podporu společnosti Microsoft k získaní opravy hotfix.

Poznámka: Pokud nastanou další problémy nebo bude nutné další řešení potíží, bude možná třeba vytvořit další samostatný požadavek na služby. Běžná cena za technickou podporu se vztahuje k dodatečným otázkám podpory a k problémům, které se netýkají této konkrétní opravy hotfix. Úplný seznam telefonních čísel služeb zákazníkům společnosti Microsoft a podpoře nebo vytvořit zvláštní požadavek na službu naleznete na následujícím webu společnosti Microsoft:

http://support.microsoft.com/contactus/?ws=supportPoznámka: Ve formuláři „Oprava hotfix je dostupná ke stažení“ se zobrazují jazyky, pro které je oprava hotfix k dispozici. Pokud váš jazyk není zobrazen, to je protože oprava hotfix není k dispozici pro daný jazyk.

Předpoklady

Chcete-li nainstalovat tuto opravu hotfix, musí být v počítači spuštěn jeden z následujících operačních systémů:

  • Windows Vista Service Pack 1 (SP1)

  • Windows Vista Service Pack 2 (SP2)

  • Windows Server 2008

  • Windows Server 2008 Service Pack 2 (SP2)

Další informace o možnostech získání aktualizace Windows Vista service pack klepněte na následující číslo článku databáze Microsoft Knowledge Base:

935791 jak získat nejnovější aktualizaci service pack pro systém Windows Vista

Další informace o možnostech získání aktualizace Windows Server 2008 service pack klepněte na následující číslo článku databáze Microsoft Knowledge Base:

968849 jak získat nejnovější aktualizaci service pack pro systém Windows Server 2008

Požadavek na restartování

Po instalaci této opravy hotfix musíte restartovat počítač.

Informace o nahrazení opravy hotfix

Tato oprava hotfix nenahrazuje dříve vydanou opravu hotfix.

Informace o souborech

Globální verze této opravy hotfix nainstaluje soubory, jejichž atributy jsou uvedeny v následujících tabulkách. Kalendářní data a časy jednotlivých souborů jsou uvedeny v koordinovaném světovém čase (UTC). Kalendářní data a časy těchto souborů v místním počítači jsou zobrazeny dle vašeho místního času a také podle aktuálního letního času (DST). Navíc data a časy se mohou změnit při provádění některých operací se soubory.

Poznámky k informacím o souborech pro systém Windows Vista a Windows Server 2008

Důležité: Opravy hotfix pro systém Windows Vista a Windows Server 2008 opravy hotfix jsou součástí stejné balíčků. Pouze "Windows Vista" je však uveden na stránce žádost o opravu Hotfix. Chcete-li požádat o balíčku oprav hotfix, která se vztahuje k jedné nebo obou operačních systémů, vyberte opravu hotfix, která je uvedena v části "Windows Vista" na stránce. Vždy naleznete v části "Platí pro" v článcích k určení skutečného operačního systému, který se vztahuje na každou opravu hotfix.

  • Soubory týkající se konkrétního produktu, SR_Level (RTM, SPn) a služby (LDR, GDR) lze identifikovat porovnáním čísel verzí souborů podle následující tabulky.

    Verze

    Výrobek

    SR_Level

    Složka služby

    6.0.600
    1.
    22 xxx

    Systém Windows Vista a Windows Server 2008

    SP1

    LDR

    6.0.600
    2.
    22 xxx

    Systém Windows Vista a Windows Server 2008

    SP2

    LDR

  • Service Pack 1 je integrována do vydané verze systému Windows Server 2008. Proto se soubory verze RTM týkají pouze na systém Windows Vista. Soubory verze RTM mají číslo verze 6.0.0000. číslo verze xxxxxx .

  • Soubory MANIFEST (.manifest) a soubory MUM (.mum) instalované pro každé prostředí jsou uvedeny samostatně v části "Další souborů informace pro Windows Server 2008 a Windows Vista". Soubory MUM a MANIFEST soubory a soubory katalogu (CAT) přidružené zabezpečení, jsou velice důležité k uchování stavu aktualizované součásti. Soubory katalogu zabezpečení, pro něž nejsou uvedeny atributy, jsou podepsané digitálním podpisem společnosti Microsoft.

Pro všechny podporované verze x86 systému Windows Server 2008 a Windows Vista


Název souboru

Verze souboru

Velikost souboru

Datum

Čas

Platforma

Localspl.dll

6.0.6001.22598

637,952

06-Jan-2010

17:23

x86

Localspl.dll

6.0.6002.22303

624,128

06-Jan-2010

16:03

x86

Pro všechny podporované verze x64 systému Windows Server 2008 a Windows Vista


Název souboru

Verze souboru

Velikost souboru

Datum

Čas

Platforma

Localspl.dll

6.0.6001.22598

793,600

06-Jan-2010

16:47

x64

Localspl.dll

6.0.6002.22303

774,656

06-Jan-2010

16:07

x64

Localspl.dll

6.0.6001.22598

637,952

06-Jan-2010

17:23

x86

Localspl.dll

6.0.6002.22303

624,128

06-Jan-2010

16:03

x86

Pro všechny podporované verze IA-64 systému Windows Server 2008


Název souboru

Verze souboru

Velikost souboru

Datum

Čas

Platforma

Localspl.dll

6.0.6001.22598

1,625,088

06-Jan-2010

17:07

IA-64

Localspl.dll

6.0.6002.22303

1,625,088

06-Jan-2010

15:55

IA-64

Localspl.dll

6.0.6001.22598

637,952

06-Jan-2010

17:23

x86

Localspl.dll

6.0.6002.22303

624,128

06-Jan-2010

16:03

x86

Jak potíže obejít

Chcete-li vyřešit problém 2, nastavte hodnotu položky registru AllowUserManageForms na 0. Toto je globální nastavení, které zabraňuje používá vlastní formuláře.

Stav

Společnost Microsoft potvrdila, že se jedná o problém v produktech společnosti Microsoft, které jsou uvedeny v části "Platí pro".

Další informace

Pro další informace o terminologii používané v aktualizacích softwaru, klepněte na následující číslo článku k zobrazení článku v databázi Microsoft Knowledge Base:

824684 Popis standardní terminologie používané při popisu aktualizací softwaru společnosti Microsoft


Další informace o službě zařazování tisku naleznete následujícím webu Microsoft Developer Network (MSDN):

http://msdn.microsoft.com/en-us/library/aa371800(VS.85).aspx
Další informace o správě tisku v systému Windows Server 2008 naleznete na následujícím webu MSDN:

http://technet.microsoft.com/en-us/library/cc753109(WS.10).aspx

Další informace o souborech

Další informace o souborech pro systém Windows Vista a Windows Server 2008

Další soubory pro všechny podporované verze x86 systémů Windows Vista a Windows Server 2008


Název souboru

Verze souboru

Velikost souboru

Datum

Čas

Platforma

X86_microsoft-windows-p..ooler-core-localspl_31bf3856ad364e35_6.0.6001.22598_none_304bb562ac0d7372.manifest

Není k dispozici

14,442

06-Jan-2010

19:30

Není k dispozici

X86_microsoft-windows-p..ooler-core-localspl_31bf3856ad364e35_6.0.6002.22303_none_328e770aa8ef4b91.manifest

Není k dispozici

14,423

06-Jan-2010

19:08

Není k dispozici

Další soubory pro všechny podporované verze x64 systémů Windows Vista a Windows Server 2008


Název souboru

Verze souboru

Velikost souboru

Datum

Čas

Platforma

Amd64_microsoft-windows-p..ooler-core-localspl_31bf3856ad364e35_6.0.6001.22598_none_8c6a50e6646ae4a8.manifest

Není k dispozici

14,512

06-Jan-2010

19:13

Není k dispozici

Amd64_microsoft-windows-p..ooler-core-localspl_31bf3856ad364e35_6.0.6002.22303_none_8ead128e614cbcc7.manifest

Není k dispozici

14,493

06-Jan-2010

19:08

Není k dispozici

X86_microsoft-windows-p..ooler-core-localspl_31bf3856ad364e35_6.0.6001.22598_none_304bb562ac0d7372.manifest

Není k dispozici

14,442

06-Jan-2010

19:30

Není k dispozici

X86_microsoft-windows-p..ooler-core-localspl_31bf3856ad364e35_6.0.6002.22303_none_328e770aa8ef4b91.manifest

Není k dispozici

14,423

06-Jan-2010

19:08

Není k dispozici

Další soubory pro všechny podporované verze IA-64 systému Windows Server 2008


Název souboru

Verze souboru

Velikost souboru

Datum

Čas

Platforma

Ia64_microsoft-windows-p..ooler-core-localspl_31bf3856ad364e35_6.0.6001.22598_none_304d5958ac0b7c6e.manifest

Není k dispozici

14,458

06-Jan-2010

19:09

Není k dispozici

Ia64_microsoft-windows-p..ooler-core-localspl_31bf3856ad364e35_6.0.6002.22303_none_32901b00a8ed548d.manifest

Není k dispozici

14,458

06-Jan-2010

18:52

Není k dispozici

Tabulka aplikace OneNote contents.onetoc2

Není k dispozici

3,656

19-Jan-2010

06:16

Není k dispozici

X86_microsoft-windows-p..ooler-core-localspl_31bf3856ad364e35_6.0.6001.22598_none_304bb562ac0d7372.manifest

Není k dispozici

14,442

06-Jan-2010

19:30

Není k dispozici

X86_microsoft-windows-p..ooler-core-localspl_31bf3856ad364e35_6.0.6002.22303_none_328e770aa8ef4b91.manifest

Není k dispozici

14,423

06-Jan-2010

19:08

Není k dispozici

Potřebujete další pomoc?

Chcete další možnosti?

Prozkoumejte výhody předplatného, projděte si školicí kurzy, zjistěte, jak zabezpečit své zařízení a mnohem více.

Komunity vám pomohou klást otázky a odpovídat na ně, poskytovat zpětnou vazbu a vyslechnout odborníky s bohatými znalostmi.

Byly tyto informace užitečné?

Jak jste spokojeni s kvalitou jazyka?
Co ovlivnilo váš názor?
Po stisknutí tlačítka pro odeslání se vaše zpětná vazba použije k vylepšování produktů a služeb Microsoftu. Váš správce IT bude moci tato data shromažďovat. Prohlášení o zásadách ochrany osobních údajů.

Děkujeme vám za zpětnou vazbu.

×