Příznaky
Při pokusu o přístup ke složkám v sekundární poštovní schránku serveru Microsoft Exchange Server, který byl přidán do vaší profil aplikace Outlook Microsoft, může dojít k potížím výkonu náhodné. Například může zaznamenat následující příznaky:
-
Při zobrazení položky v sekundární poštovní schránku, nezobrazí nové položky nebo položky, které zřejmě chybí.
-
Stále zobrazí položky, které jste odstranili v sekundární poštovní schránku.
-
Pomalý výkon v aplikaci Outlook nebo náhodného zablokování.
-
Na serveru se systémem Microsoft Exchange Server je do protokolu aplikací zaznamenána událost podobná následující událost: Typ události: Chyba Zdroj události: MSExchangeIS Kategorie události: Obecné ID události: 9646 Popis: Zavření relace Mapi "/ o =organizace/ou =Skupiny pro správu/cn = Recipients/cn =příjemci" protože přesáhl maximální 500 objektů typu "objtFolder".
Kromě toho může najít chyby, které se podobají následující zprávy protokolu synchronizace ve složce Nezdařené synchronizace aplikace Outlook:
13:22:28 Synchronizer Version 12.0.6529
13:22:28 Synchronizing Mailbox 'TeamShared'
13:22:28 Synchronizing Hierarchy
13:22:28 Error Synchronizing Hierarchy for Mailbox 'TeamShared'
13:22:28 [80040305-54A-4DE-1900]
13:22:28 Your server administrator has limited the number of items you can open simultaneously. Try closing messages you have opened or removing attachments and images from unsent messages you are composing.
13:22:28 Microsoft Exchange Information Store
13:22:28 For more information on this failure, click the URL below:
13:22:28 http://www.microsoft.com/support/prodredirect/outlook2000_us.asp?err=80040305-54a-4de-1900
13:22:28 Error synchronizing folder
13:22:31 Synchronizing local changes in folder 'TeamShared - Level1'
13:22:31 Error synchronizing folder
13:22:31 [80040305-54A-4DE-421]
13:22:31 Your server administrator has limited the number of items you can open simultaneously. Try closing messages you have opened or removing attachments and images from unsent messages you are composing.
13:22:31 Microsoft Exchange Information Store
13:22:31 For more information on this failure, click the URL below:
13:22:31 http://www.microsoft.com/support/prodredirect/outlook2000_us.asp?err=80040305-54a-4de-421 When this issue occurred, the following synchronization error numbers have also been seen in synchronization messages in the Sync Issues folder:80040305-54A-4DE-822
80004005-501-0-1380
Poznámka: Je nutné vybrat modulu Seznam složek v navigačním podokně zobrazíte složky Nezdařené synchronizace poštovní schránky.
Příčina
Tomuto problému může dojít, pokud jsou splněny následující podmínky:
-
Sekundární poštovní schránku, která se pokoušíte získat přístup je přidán do vaší profil aplikace Outlook tak, aby se zobrazí v navigačním podokně. Poznámka: Sekundární poštovní schránky můžete přidat do svého profilu ručně pomocí karty Upřesnit v dialogovém okně Microsoft Exchange nebo automaticky pomocí funkce "AutoMapping" na serveru Exchange.
-
Tento sekundární poštovní schránka obsahuje mnoho složek.
-
Váš profil je nakonfigurován v režimu serveru Exchange s mezipamětí.
-
Výchozí možnost, chcete-li Stáhnout sdílené složky je povoleno ve vašem profilu.
K tomuto problému dochází, protože aplikace Outlook 2010 a novější verze místně do mezipaměti (v datovém souboru aplikace Outlook [OST]) všechny složky, ke kterým máte přístup sekundární poštovní schránku. Jedná se o změnu z předchozích verzí aplikace Outlook. Aplikace Outlook 2003 do mezipaměti všechny sdílené složky. Ve výchozím nastavení aplikace Outlook 2007 ukládá do mezipaměti pouze sdílené složky, které neobsahují e-mailu (například kalendář, kontakty a úkoly). Poznámka: V aplikaci Outlook 2007 tento problém je pravděpodobnější dojít, pokud máte následující data registru konfigurována na váš klient aplikace Outlook. Podklíč: HKEY_CURRENT_USER\Software\Microsoft\Office\12.0\Outlook\Cached režim nebo HKEY_CURRENT_USER\Software\Policies \Microsoft\Office\12.0\Outlook\Cached režimuHodnota DWORD: CacheOthersMail Hodnota: 1
Řešení
Pro aplikaci Outlook pro Office 365
Zrušení omezení 500 sdílených složek v aplikaci Outlook
Lepší synchronizace sdílených složek tak, aby aplikace Outlook již nedochází k omezení 500 sdílených složek aplikace Outlook by měly být schopny pojmout až 5000 sdílených složek. Nové funkční omezení se liší podle dostupných zdrojů a konfiguraci systému uživatele aplikace Outlook. Tyto změny byly vydány Office měsíční (Targeted) kanál s version1904 vydat měsíční kanálu Office ve verzi 1905 (sestavení 11629.20196) a později. A budou zahrnuty v pololetních kanál vydání pravidelných pololetních plánu (září 2019 poloviční roční kanálu (Targeted) a ledna 2020 k dalšímu uvolňování). Další informace naleznete v tématu zrušení 500 Limit složky v aplikaci Outlook.
Pro 2019 aplikace Outlook, aplikace Outlook 2016, 2013 aplikace Outlook, Outlook 2010 a Outlook 2007
Chcete-li vyřešit tento problém, použijte jednu z následujících metod. Důležité: Pečlivě postupujte podle pokynů v této části. Při nesprávné úpravě registru může dojít k vážným problémům. Před tím, než jej změníte, zálohujte registr pro případ obnovení pro případ, že dojde k problémům.
Metoda 1: Snížíte počet složek ve sdílené poštovní schránky
Nejlepším řešením tohoto problému je snížit počet e-mailových složek ve sdílené poštovní schránky, zvláště pokud poštovních schránek v prostředí Office 365. Další metody 2 a 3 tohoto článku radí při vypnutí ukládání do mezipaměti poštovní složky nebo všechny složky ve sdílené poštovní schránky. Tato řešení nefungují, ale je doporučeno zachovat mezipaměť povolena pro poštovní schránky Office 365 a poštovních schránek na pomalé sítě. Další informace naleznete v následujícím článku:
Doporučené postupy pro používání služeb Office 365 na pomalé sítě
Metoda 2: Zakážete ukládání do mezipaměti všechny sdílené složky
Outlook 2010 a novější verze Chcete-li zakázat ukládání do mezipaměti všechny sdílené složky v aplikaci Outlook 2010 a novější verze, postupujte takto:
-
Na kartě soubor klikněte na tlačítko Nastavení účtu v seznamu Nastavení účtu .
-
V dialogovém okně Nastavení účtu klepněte na kartu E-mail a potom poklepejte na účet Serveru Microsoft Exchange Server .
-
V dialogovém okně Nastavení účtu klepněte na tlačítko Další nastavení.
-
V dialogovém okně Microsoft Exchange klepněte na kartu Upřesnit .
-
Klepnutím zrušte zaškrtnutí políčka Stáhnout sdílené složky .
-
Klepněte dvakrát na tlačítko OK .
-
Klepněte na tlačítko Další, klepněte na tlačítko Dokončita potom klepněte na tlačítko Zavřít.
-
Restartujte aplikaci Outlook.
Aplikace Outlook 2007 Chcete-li zakázat ukládání do mezipaměti všechny sdílené složky v aplikaci Outlook 2007, postupujte takto:
-
V nabídce Nástroje klepněte na tlačítko Nastavení účtu.
-
V dialogovém okně Nastavení účtu klepněte na kartu E-mail a potom poklepejte na účet Serveru Microsoft Exchange Server .
-
V dialogovém okně Nastavení účtu klepněte na tlačítko Další nastavení.
-
V dialogovém okně Microsoft Exchange klepněte na kartu Upřesnit .
-
Klepnutím zrušte zaškrtnutí políčka Stáhnout sdílené složky .
-
Klepněte dvakrát na tlačítko OK .
-
Klepněte na tlačítko Další, klepněte na tlačítko Dokončita potom klepněte na tlačítko Zavřít.
-
Restartujte aplikaci Outlook.
Po provedení této změny, žádné sdílené složky v sekundární poštovní schránku bude k dispozici v aplikaci Outlook při práci v režimu offline. Však všechny složky v primární poštovní schránka bude nadále k dispozici při práci v režimu offline. Další informace o tom, jak zakázat stahování sdílených složek pomocí nastavení Zásady skupiny, klepněte na následující číslo článku naleznete v článku znalostní báze Microsoft Knowledge Base:
982697 ve výchozím nastavení, sdílené poštovní složky jsou staženy režimu s mezipamětí v aplikaci Outlook 2010 a Outlook 2013
Metoda 3: Změňte konfiguraci sekundární poštovní schránky serveru Exchange na druhý účet serveru Exchange ve vašem profilu
Outlook 2010 a novější verze pouze Pokud chcete do mezipaměti všechny složky v sekundární poštovní schránky serveru Exchange, postupujte takto Chcete-li změnit vaše profil aplikace Outlook tak, aby sekundární poštovní schránky je přidán jako druhý účet serveru Exchange. Poznámka: K provedení těchto kroků, musíte buď znát heslo pro účet sekundární poštovní schránku nebo musíte mít oprávnění Úplné poštovní schránky účtu pro sekundární poštovní schránku. Kontaktujte správce Exchange Server této informace nebo oprávnění.
-
Ujistěte se, že automapping je zakázáno pro sekundární poštovní schránku. Další informace naleznete v následujícím článku znalostní báze Microsoft Knowledge Base:
2646504 jak odebrat automapping pro sdílené poštovní schránky ve službách Office 365
-
Na kartě soubor klikněte na tlačítko Nastavení účtu v seznamu Nastavení účtu .
-
V dialogovém okně Nastavení účtu klepněte na kartu E-mail a potom poklepejte na účet Serveru Microsoft Exchange Server .
-
V dialogovém okně Nastavení účtu klepněte na tlačítko Další nastavení.
-
V dialogovém okně Microsoft Exchange klepněte na kartu Upřesnit .
-
Klepněte na kartu Upřesnit . V části poštovní schránky vyberte sekundární poštovní schránku a poté klepněte na tlačítko Odebrat.
-
Po zobrazení výzvy k potvrzení odebrání poštovní schránky a klepněte na tlačítko Ano .
-
Klepněte na tlačítko OK, klepněte na tlačítko Další, klepněte na tlačítko Dokončita potom klepněte na tlačítko Zavřít. Poznámka: Sekundární poštovní schránky serveru Exchange je v tomto okamžiku již přidružen vaše profil aplikace Outlook.
-
Ukončete aplikaci Outlook.
-
Otevřete položku pošty v Ovládacích panelech.
-
Vyberte požadovaný profil a potom klepněte na příkaz Vlastnosti.
-
Klepněte na příkaz účty elektronické pošty.
-
Na kartě E-mail v dialogovém okně Nastavení účtu klepněte na tlačítko Nový.
-
V části Zvolte služby v dialogovém okně Přidat nový účet klepněte na tlačítko E-mailový účeta potom klepněte na tlačítko Další. Pokud znáte heslo pro účet sekundární poštovní schránku, přejděte ke kroku 14. Pokud neznáte heslo pro účet sekundární poštovní schránku, ale váš účet má oprávnění Úplné poštovní schránky k této sekundární poštovní schránku, přejděte ke kroku 18.
-
V části Automatické nastavení účtu v dialogovém okně Přidat nový účet zadejte následující informace o účtu pro sekundární poštovní schránku a poté klepněte na tlačítko Další.
Jméno E-mailová adresa Heslo
-
Po účet byl úspěšně nakonfigurován, klepněte na tlačítko Dokončit.
-
Klepněte na tlačítko Zavřít, klepněte na tlačítko Zavříta potom klepněte na tlačítko OK.
-
Přejděte ke kroku 22.
-
V části Automatické nastavení účtu v dialogovém okně Přidat nový účet klepněte na tlačítko Konfigurovat ručně nastavení serveru nebo další typy serverua klepněte na tlačítko Další.
-
V části Zvolte služby v dialogovém okně Přidat nový účet klepněte na položku Microsoft Exchange nebo kompatibilní službaa potom klepněte na tlačítko Další.
-
V části Nastavení serveru v dialogovém okně Přidat nový účet zadejte následující informace pro sekundární poštovní schránku a poté klepněte na tlačítko Další.
Serveru (název serveru Exchange) Použít režim Cached Exchange (umožněno povolit sekundární poštovní schránku do mezipaměti místně v souboru OST) Uživatelské jméno
-
Klepněte na tlačítko Dokončit, klepněte na tlačítko Zavřít, klepněte na tlačítko Zavříta potom klepněte na tlačítko OK.
-
Spusťte Outlook.
Poznámka: Pokud váš účet nemá oprávnění Úplné poštovní schránky na sekundární poštovní schránku, budete vyzváni k zadání pověření účtu pro sekundární poštovní schránku. Následujících konkrétních problémů může dojít, pokud používáte aplikaci Outlook po provedení změn konfigurace, které jsou zadány v této metodě.
-
Nové e-mailové výstrahy jsou zobrazeny pro obě poštovní schránky serveru Exchange.
-
V druhé poštovní schránky serveru Exchange lze zobrazit zprávy označené jako soukromé, přestože účet první poštovní schránky serveru Exchange není nakonfigurován speciálně pro možnost pro zobrazení soukromých zpráv.
Další informace
Při přidávání dalších poštovních schránek pro vaše profil aplikace Outlook a povolit použití mezipaměti pro sdílené poštovní schránky aplikace Outlook jednotlivě zaregistruje každé složky v každé poštovní schránky uložené v mezipaměti. Každou z nich zaregistrovat složek počty směrem k omezení typu objtFolder na serveru se systémem Exchange Server. To je omezen na poštovní schránky.
Jak bylo uvedeno v 9646 události, který je uveden v části "Příznaky", je výchozí omezení pro objtFolder objekty na schránku 500.
Pokud mezipaměti sdílené poštovní schránky, který obsahuje více než 500 složek, tento limit bude vyčerpán a může docházet k problémům, které jsou uvedeny v části "Příznaky".
Velký počet oblíbených položek veřejné složky může navíc přispět k vyčerpání limitu objektu objtFolder . Další informace o chybách, ke kterým může dojít při synchronizaci počet veřejných složek naleznete v následujícím článku znalostní báze Microsoft Knowledge Base:
2968387 obdržíte chyby Nedostatek paměti při rozbalení poštovní schránky nebo veřejné složky v aplikaci Outlook
Další informace o maximální povolené sdílení prostředků serveru Microsoft Exchange Server 2007 naleznete v tématu uživatel využívá jejich maximální povolené sdílení serveru.
Další informace o Exchange Server 2010 poštovní schránky ukládat omezení relací, přejděte na následující weby společnosti Microsoft:
Za účelem určení počet složek a podsložek, které jsou v poštovní schránce nebo složky, spuštění rutiny Get-MailboxFolderStatistics.