Når du opretter en LOPSLAG- eller VOPSLAG-funktion, angiver du et celleområde, f.eks. D2:F39. Dette område kaldes argumentet table_array, og et argument er blot et stykke data, som en funktion skal bruge for at køre. I dette tilfælde søger funktionen i cellerne efter de data, du forsøger at finde.

Argumentet table_array er altid det andet argument i en LOPSLAG- eller VOPSLAG-funktion (det første er den værdi, du forsøger at finde), og funktionerne vil ikke fungere uden det.

Det første argument, den værdi, du vil finde, kan være en bestemt værdi, f.eks. "41" eller "jensen", eller det kan være en cellereference som f.eks. F2. Så det første argument kan se således ud:

=LOPSLAG(F2;...

Argumentet table_array følger altid opslagsværdien, således:

=LOPSLAG(F2,B4:D39, ...

Det celleområde, der er angivet i table_array, kan bruge relative eller absolutte cellereferencer. Hvis du vil kopiere din funktion, skal du bruge absolutte referencer, som dette:

=LOPSLAG(F2;$B$2:BD$39; ...

Cellerne i argumentet table_array findes også i et andet regneark i projektmappen. Hvis de gør det, medtager argumentet arknavnet, og syntaksen ser sådan ud:

=LOPSLAG(F2;Ark2!$C$14:E$42; ...

Sørg for at placere et udråbstegn efter arkets navn.

Til sidst (ug), skal du angive et tredje argument, kolonnen, der indeholder de værdier, du forsøger at finde. Dette kaldes opslagskolonnen. I vores første eksempel brugte vi celleområdet B4 til D39, der løber over tre kolonner. Lad os forestille os, at de værdier, du vil have vist, findes i kolonne D, den tredje kolonne i celleområdet, så det sidste argument er 3.

=LOPSLAG(F2,B4:D39,3)

Du kan bruge et valgfrit fjerde argument, enten Sand eller Falsk. Det meste af tiden skal du bruge Falsk.

Hvis du bruger Sand, eller lader det fjerde argument være tomt, returnerer funktionen et omtrentlig match til værdien i dit første argument. Så hvis du vil fortsætte eksemplet, og dit første argument er "jensen", og du bruger Sand, returnerer funktionen "Smith", "Smithberg" osv. Men hvis du bruger Falsk, returnerer funktionen kun "Smith", et nøjagtigt match, og det er det, de fleste ønsker.

Hvis du vil gøre det endnu mere vanskeligt at bruge Sand, hvis opslagskolonnen – den kolonne, du angiver i dit tredje argument – ikke sorteres i stigende rækkefølge (A til Å eller fra laveste til højeste tal), kan funktionen returnere det forkerte resultat. Du kan finde flere oplysninger under Slå værdier op med LOPSLAG og andre funktioner.

Du kan finde flere oplysninger om funktionerne LOPSLAG og VOPSLAG i:

Har du brug for mere hjælp?

Udvid dine færdigheder
Gå på opdagelse i kurser
Få nye funktioner først
Deltag i Microsoft insiders

Var disse oplysninger nyttige?

Hvor tilfreds er du med kvaliteten af oversættelsen?

Hvad påvirkede din oplevelse?

Har du mere feedback? (Valgfrit)

Tak for din feedback!

×