SUMPRODUKT, funktionen

Funktionen SUMPRODUKT returnerer summen af produkter i tilsvarende områder eller matrixer. Standardhandlingen er multiplikation, men addition, subtraktion og division er også muligt.

I dette eksempel bruger vi SUMPRODUKT til at returnere det samlede salg for en given vare og størrelse:

Eksempel på brug af funktionen SUMPRODUCT til at returnere det samlede salg, når der leveres med produktnavn, størrelse og individuelle salgsværdier for hver.

SUMPRODUKT matcher alle forekomster af element Y/størrelse M og summerer dem, så i dette eksempel er 21 plus 41 lig med 62.

Syntaks

For at bruge standardhandlingen (multiplikation):

=SUMPRODUKT(matrix1;[matrix2];[matrix3];...)

Syntaksen for funktionen SUMPRODUKT har følgende argumenter:

Argument

Beskrivelse

matrix1   

Påkrævet

Det første matrixargument, hvis komponenter du vil multiplicere og derefter addere.

[matrix2],[matrix3],...    

Valgfrit

Matrixargumenterne 2-55, hvis komponenter du vil multiplicere og derefter addere.

Sådan udfører du andre matematiske handlinger

Brug SUMPRODUKT som normalt, men erstat kommaerne, der adskiller matrixargumenterne med de aritmetiske operatorer, du ønsker (*, /, +, -). Når alle handlingerne er udført, summeres resultaterne som normalt.

Bemærk!: Hvis du bruger matematiske operatorer, kan du overveje at omslutke matrixargumenterne i parenteser og bruge parenteser til at gruppere matrixargumenterne for at styre rækkefølgen af matematiske handlinger.

Bemærkninger

  • Matrixargumenterne skal have samme dimensioner. Hvis de ikke gør det, returnerer SUMPRODUKT #VALUE! fejlværdien. =SUMPRODUKT(C2:C10,D2:D5) returnerer f.eks. en fejl, da intervallerne ikke har samme størrelse.

  • SUMPRODUCT behandler ikke-numeriske matrixposter, som om de var nuller.

  • For at opnå den bedste ydeevne bør SUMPRODUCT ikke bruges med fulde kolonnereferencer. Overvej =SUMPRODUKT(A:A,B:B), her multipliceres de 1.048.576 celler i kolonne A med 1.048.576 celler i kolonne B, før de lægges til. 

Eksempel 1

Eksempel på funktionen SUMPRODUKT, der bruges til at returnere summen af solgte varer, når der er angivet enhedsomkostninger og antal.

Hvis du vil oprette formlen ved hjælp af vores eksempelliste ovenfor, skal du skrive =SUMPRODUKT(C2:C5,D2:D5) og trykke på Enter. Hver celle i kolonne C ganges med den tilsvarende celle i samme række i kolonne D, og resultaterne lægges sammen. Det samlede beløb for indkøb er 78,97 USD.

Hvis du vil skrive en længere formel, der giver samme resultat, skal du skrive =C2*D2+C3*D3+C4*D4+C5*D5 og trykke på Enter. Når du har trykket på Enter, er resultatet det samme: DKK 78,97. Celle C2 ganges med D2, og resultatet lægges til resultatet af celle C3 gange celle D3 osv.

Eksempel 2

I følgende eksempel bruges SUMPRODUCT til at returnere det samlede nettosalg efter sælger, hvor vi har både samlet salg og udgifter efter agent. I dette tilfælde bruger vi en Excel-tabel, som brugerstrukturerede referencer i stedet for almindelige Excel-områder. Her kan du se, at der refereres til intervallerne Salg, Udgifter og Agent efter navn.

Eksempel på funktionen SUMPRODUCT til at returnere det samlede salg efter sælger, når det leveres med salg og udgifter for hver.

Formlen er: =SUMPRODUKT(((Tabel1[Salg])+(Tabel1[Udgifter]))*(Tabel1[Agent]=B8)), og den returnerer summen af alle salg og udgifter for agenten, der er angivet i celle B8.

Eksempel 3

I dette eksempel ønsker vi at returnere totalen for en bestemt vare, der er solgt af et bestemt område. I dette tilfælde hvor mange kirsebær sælgede Øst-området?

Eksamen ved brug af SUMPRODUKT til at returnere summen af elementer efter område. I dette tilfælde er antallet af kirsebær, der er solgt i området Øst.

Her er formlen: =SUMPRODUKT((B2:B9=B12)*(C2:C9=C12)*D2:D9). Den ganger først antallet af forekomster af Øst med antallet af matchende forekomster af kirsebær. Til sidst summerer den værdierne i de tilsvarende rækker i kolonnen Salg. For at se, hvordan Excel beregner dette, skal du markere formelcellen og derefter gå til Formler, >Evaluer formel > Evaluer.

Har du brug for mere hjælp?

Du kan altid spørge en ekspert i Excel Tech Community eller få support i Answers-forummet

Se også

Udføre betingede beregninger på celleområde

Sum baseret på flere kriterier med SUM.HVISER

Tælling baseret på flere kriterier med TÆL.HVISER

Gennemsnit baseret på flere kriterier med MIDDEL.HVISER

Har du brug for mere hjælp?

Udvid dine Office-færdigheder
Gå på opdagelse i kurser
Få nye funktioner først
Bliv Office Insider

Var disse oplysninger nyttige?

Tak for din feedback!

Tak for din feedback! Det lyder, som om det vil kunne hjælpe, hvis du bliver sat i forbindelse med en af vores Office-supportteknikere.

×