Zeilen und Spalten

Filtern nach eindeutigen Werten und Entfernen von doppelten Werten

Filtern nach eindeutigen Werten und Entfernen von doppelten Werten

Ihr Browser unterstützt kein Video.

In Excel gibt es mehrere Möglichkeiten, nach eindeutigen Werten zu filtern oder doppelte Werte zu entfernen:

  • Wenn Sie nach eindeutigen Werten filtern möchten, klicken > auf & Filter > Erweitert.
    Die Gruppe "Sortieren und Filtern" auf der Registerkarte "Daten"

  • Wenn Sie doppelte Werte entfernen möchten, klicken > datentools auf > Duplikate entfernen.
    Duplikate entfernen

  • Verwenden Sie zum Hervorheben eindeutiger oder doppelter Werte den Befehl Bedingte Formatierung in der Gruppe Formatvorlageauf der Registerkarte Start.

Das Filtern nach eindeutigen Werten und das Entfernen doppelter Werte sind zwei ähnliche Aufgaben, da das Ziel darin besteht, eine Liste eindeutiger Werte zu präsentieren. Es gibt jedoch einen kritischen Unterschied: Wenn Sie nach eindeutigen Werten filtern, werden die doppelten Werte nur vorübergehend ausgeblendet. Das Entfernen doppelter Werte bedeutet jedoch, dass Sie doppelte Werte dauerhaft löschen.

Ein doppelter Wert ist ein Wert, bei dem alle Werte in mindestens einer Zeile mit allen Werten in einer anderen Zeile identisch sind. Ein Vergleich doppelter Werte hängt davon ab, was in der Zelle angezeigt wird– nicht vom zugrunde liegenden Wert, der in der Zelle gespeichert ist. Wenn Sie z. B. denselben Datumswert in verschiedenen Zellen haben, einer mit "08.03.2006" und der andere mit "8. März 2006", sind die Werte eindeutig.

Überprüfen Sie, bevor Sie Duplikate entfernen: Bevor Sie doppelte Werte entfernen, sollten Sie zuerst versuchen, nach eindeutigen Werten nach eindeutigen Werten zu filtern oder sie bedingt zu formatieren, um zu bestätigen, dass Sie die von Ihnen erwarteten Ergebnisse erzielen.

Führen Sie die folgenden Schritte aus:

  1. Wählen Sie den Zellbereich aus, oder stellen Sie sicher, dass sich die aktive Zelle in einer Tabelle befindet.

  2. Klicken Sie > Auf Erweitert (in der Gruppe & Filtern).

    Die Gruppe "Sortieren und Filtern" auf der Registerkarte "Daten"

  3. Gehen Sie im Popupfeld Erweiterter Filter wie folgt vor:

So filtern Sie den Zellbereich oder die Tabelle an Ort und Stelle:

  • Klicken Sie auf Die Liste an Ort und Stelle filtern.

So kopieren Sie die Ergebnisse des Filters an eine andere Position:

  • Klicken Sie auf An einen anderen Speicherort kopieren.

  • Geben Sie im Feld Kopieren in einen Zellbezug ein.

  • Alternativ können Sie auf Dialogfeld reduzieren Schaltflächensymbol , um das Popupfenster vorübergehend auszublenden, wählen Sie eine Zelle auf dem Arbeitsblatt aus, und klicken Sie dann auf Erweitern Schaltflächensymbol .

  • Aktivieren Sie nur einmalige Datensätze,und klicken Sie dann auf OK.

Die eindeutigen Werte aus dem Bereich werden an die neue Position kopiert.

Wenn Sie doppelte Werte entfernen, wirkt sich der einzige Effekt auf die Werte im Zellbereich oder in der Tabelle aus. Andere Werte außerhalb des Zellbereichs oder der Tabelle werden nicht geändert oder verschieben.  Wenn Duplikate entfernt werden, wird das erste Vorkommen des Werts in der Liste beibehalten, aber andere identische Werte werden gelöscht. 

Da Sie Daten dauerhaft löschen, sollten Sie den ursprünglichen Zellbereich oder die ursprüngliche Tabelle in ein anderes Arbeitsblatt oder eine andere Arbeitsmappe kopieren, bevor Sie doppelte Werte entfernen.

Führen Sie die folgenden Schritte aus:

  1. Wählen Sie den Zellbereich aus, oder stellen Sie sicher, dass sich die aktive Zelle in einer Tabelle befindet.

  2. Klicken Sie auf der Registerkarte Daten auf Duplikate entfernen (in der Gruppe Datentools).

    Duplikate entfernen
  3. Führen Sie eine oder mehrere der folgenden Aktionen aus:

    • Wählen Sie unterSpalten eine oder mehrere Spalten aus.

    • Um schnell alle Spalten auszuwählen, klicken Sie auf Alle auswählen.

    • Klicken Sie auf Alle aufheben, um schnell alle Spalten zu löschen.

      Wenn der Zellbereich oder die Tabelle viele Spalten enthält und Sie nur einige Spalten auswählen möchten, können Sie auf Alle aufheben klicken und dann unter Spalten diese Spalten auswählen.

      Hinweis: Daten werden aus allen Spalten entfernt, auch wenn Sie in diesem Schritt nicht alle Spalten auswählen. Wenn Sie z. B. Spalte1 und Spalte2 auswählen, aber nicht Spalte3, ist der "Schlüssel", der zum Suchen von Duplikaten verwendet wird, der Wert von BEIDE Spalte1 & Spalte2.  Wenn in diesen Spalten ein Duplikat gefunden wird, wird die gesamte Zeile entfernt, einschließlich anderer Spalten in der Tabelle oder dem Bereich.

  4. Klicken Sie auf OK,und es wird eine Meldung angezeigt, die angibt, wie viele doppelte Werte entfernt wurden oder wie viele eindeutige Werte noch vorhanden sind. Klicken Sie auf OK, um diese Nachricht zu schließen.

  5. Rückgängig machen, indem Sie auf Rückgängig klicken (oder STRG+Z auf der Tastatur drücken).

Sie können keine doppelten Werte aus Gliederungsdaten entfernen, die umrissen sind oder Teilsummen enthalten. Um Duplikate zu entfernen, müssen Sie sowohl die Gliederung als auch die Teilsummen entfernen. Weitere Informationen finden Sie unter Gliederung einer Datenliste in einem Arbeitsblatt und Entfernen von Teilsummen.

Hinweis: Sie können Felder im Bereich Werte eines PivotTable-Berichts nicht bedingt nach eindeutigen oder doppelten Werten formatieren.

Schnellformatierung

Führen Sie die folgenden Schritte aus:

  1. Wählen Sie eine oder mehrere Zellen in einem Bereich, einer Tabelle oder einem PivotTable-Bericht aus.

  2. Klicken Sie auf der Registerkarte Start in der Gruppe Formatvorlage auf den kleinen Pfeil für Bedingte Formatierung,und klicken Sie dann auf Regeln für Zellen hervorheben,und wählen Sie Doppelte Werte aus.
    Doppelte Werte

  3. Geben Sie die Werte ein, die Sie verwenden möchten, und wählen Sie dann ein Format aus.

Erweiterte Formatierung

Führen Sie die folgenden Schritte aus:

  1. Wählen Sie eine oder mehrere Zellen in einem Bereich, einer Tabelle oder einem PivotTable-Bericht aus.

  2. Klicken Sie auf der Registerkarte Start in der Gruppe Formatvorlagen auf den Pfeil für Bedingte Formatierung,und klicken Sie dann auf Regeln verwalten, um das Popupfenster Manager für Regeln für bedingte Formatierung anzuzeigen.
    Menü "Bedingte Formatierung" mit hervorgehobener Option "Regeln verwalten"

  3. Führen Sie eine der folgenden Aktionen aus:

    • Zum Hinzufügen eines bedingten Formats klicken Sie auf Neue Regel, um das Popupfenster Neue Formatierungsregel anzuzeigen.

    • Um ein bedingtes Format zu ändern, stellen Sie zunächst sicher, dass das entsprechende Arbeitsblatt oder die entsprechende Tabelle in den Formatierungsregeln für liste anzeigen ausgewählt wurde. Wählen Sie bei Bedarf einen anderen Zellbereich aus, indem Sie im Popupfenster Schaltflächensymbol auf Schaltfläche Reduzieren klicken. Wählen Sie einen neuen Zellbereich auf dem Arbeitsblatt aus, und erweitern Sie dann das Popupfenster erneut Schaltflächensymbol . Wählen Sie die Regel aus, und klicken Sie dann auf Regel bearbeiten, um das Popupfenster Formatierungsregel bearbeiten anzuzeigen.

  4. Klicken Sie unter Regeltyp auswählen auf Nur eindeutige oder doppelte Werte formatieren.

  5. Wählen Sie in der Liste Alle formatieren unter Regelbeschreibung bearbeitenentweder eindeutig oderduplizieren aus.

  6. Klicken Sie auf Format, um das Popupfenster Zellen formatieren anzuzeigen.

  7. Wählen Sie das Zahlen-, Schriftart-, Rahmen- oder Füllformat aus, das Sie anwenden möchten, wenn der Zellenwert die Bedingung erfüllt, und klicken Sie dann auf OK. Sie können mehrere Formate auswählen. Die ausgewählten Formate werden im Bereich Vorschau angezeigt.

In Excel für das Web können Sie doppelte Werte entfernen.

Entfernen von doppelten Werten

Wenn Sie doppelte Werte entfernen, wirkt sich der einzige Effekt auf die Werte im Zellbereich oder in der Tabelle aus. Andere Werte außerhalb des Zellbereichs oder der Tabelle werden nicht geändert oder verschieben. Wenn Duplikate entfernt werden, wird das erste Vorkommen des Werts in der Liste beibehalten, aber andere identische Werte werden gelöscht.

Wichtig: Sie können immer auf Rückgängig klicken, um Ihre Daten zurück zu erhalten, nachdem Sie die Duplikate entfernt haben. Bevor Sie doppelte Werte entfernen, sollten Sie den ursprünglichen Zellbereich oder die ursprüngliche Tabelle in ein anderes Arbeitsblatt oder eine andere Arbeitsmappe kopieren.

Führen Sie die folgenden Schritte aus:

  1. Wählen Sie den Zellbereich aus, oder stellen Sie sicher, dass sich die aktive Zelle in einer Tabelle befindet.

  2. Klicken Sie auf der Registerkarte Daten auf Duplikate entfernen.

  3. Deaktivieren Sie im Dialogfeld Duplikate entfernen die Auswahl aller Spalten, in denen Sie keine doppelten Werte entfernen möchten.

    Hinweis: Daten werden aus allen Spalten entfernt, auch wenn Sie in diesem Schritt nicht alle Spalten auswählen. Wenn Sie z. B. Spalte1 und Spalte2 auswählen, aber nicht Spalte3, ist der "Schlüssel", der zum Suchen von Duplikaten verwendet wird, der Wert von BEIDE Spalte1 & Spalte2.  Wenn ein Duplikat in Spalte1 und Spalte2 gefunden wird, wird die gesamte Zeile entfernt, einschließlich der Daten aus Spalte3.

  4. Klicken Sie auf OK,und es wird eine Meldung angezeigt, die angibt, wie viele doppelte Werte entfernt wurden. Klicken Sie auf OK, um diese Nachricht zu schließen.

Hinweis: Wenn Sie Ihre Daten zurück erhalten möchten, klicken Sie einfach auf Rückgängig (oder drücken Sie STRG+Z auf der Tastatur).

Benötigen Sie weitere Hilfe?

Sie können jederzeit einen Experten in der Excel Tech Community fragen oder Unterstützung in der Answers Community erhalten.

Siehe auch

Zählen eindeutiger Werte unter Duplikaten

Benötigen Sie weitere Hilfe?

Ihre Office-Fähigkeiten erweitern
Schulungen erkunden
Neue Funktionen als Erster erhalten
Office Insider werden

War diese Information hilfreich?

Vielen Dank für Ihr Feedback. Es klingt, als ob es hilfreich sein könnte, Sie mit einem unserer Office-Supportmitarbeiter zu verbinden.

×