Verwenden Sie Power Query, um mehrere Dateien mit demselben Schema, das in einem einzigen Ordner gespeichert ist, in einer Tabelle zu kombinieren. Beispielsweise soll jeder Monat Budgetarbeitsmappen aus mehreren Abteilungen kombiniert werden, in denen die Spalten identisch sind, die Anzahl der Zeilen und Werte in jeder Arbeitsmappe jedoch unterschiedlich ist. Nachdem Sie die Daten eingerichtet haben, können Sie wie bei jeder einzelnen importierten Datenquelle zusätzliche Transformationen anwenden und dann die Daten aktualisieren, um die Ergebnisse für jeden Monat zu sehen.  

Eine konzeptionelle Übersicht über das Kombinieren von Ordnerdateien

Hinweis    In diesem Thema wird gezeigt, wie Sie Dateien aus einem Ordner kombinieren. Sie können auch Dateien kombinieren, die in SharePoint, Azure Blob Storage und Azure Data Lake Storage. Der Vorgang ist ähnlich.

Einfach halten:

  • Stellen Sie sicher, dass alle zu kombinierende Dateien ohne überflüssige Dateien in einem dedizierten Ordner enthalten sind. Andernfalls werden alle Dateien im Ordner und alle von Ihnen ausgewählten Unterordner in die zu kombinierenden Daten eingeschlossen.

  • Jede Datei sollte über das gleiche Schema mit einheitlichen Spaltenüberschriften, Datentypen und der Anzahl von Spalten verfügen. Die Spalten müssen sich nicht in derselben Reihenfolge wie der Abgleich durch Spaltennamen beschriften.

  • Vermeiden Sie nach Möglichkeit nicht verknüpfte Datenobjekte für Datenquellen, die mehrere Datenobjekte enthalten können, z. B. eine JSON-Datei, eine Excel-Arbeitsmappe oder eine Access-Datenbank.

Jede dieser Dateien folgt einem einfachen Muster, d. h. nur einer Tabelle mit Daten in jeder Datei.

  1. Wählen Sie Daten > Daten > Aus Datei > Aus Ordner aus. Das Dialogfeld Durchsuchen wird angezeigt.

  2. Suchen Sie den Ordner, der die zu kombinierenden Dateien enthält.

  3. Eine Liste der Dateien im Ordner wird im Dialogfeld Ordnerpfad <Ordnerpfad> angezeigt. Vergewissern Sie sich, dass alle von Ihnen erstellten Dateien aufgelistet sind.

    Beispieldialogfeld für den Textimport

  4. Wählen Sie unten im Dialogfeld einen der Befehle aus, z. B. Kombinieren> & Laden. Im Abschnitt Informationen zu all diesen Befehlen werden weitere Befehle erläutert.

  5. Wenn Sie einen der Befehle Kombinieren auswählen, wird das Dialogfeld Dateien kombinieren angezeigt. Wenn Sie die Dateieinstellungen ändern möchten, wählen Sie jede Datei im Feld Beispieldatei aus, legen Sie den Dateiherkunft, das Trennzeichen und die Datentyperkennung nach Bedarf vor. Sie können auch das Kontrollkästchen Dateien mit Fehlern überspringen am unteren Rand des Dialogfelds aktivieren oder löschen.

  6. Wählen Sie OK aus.

Ergebnis

Power Query erstellt automatisch Abfragen, um die Daten aus jeder Datei in einem Arbeitsblatt zu konsolidieren. Die erstellten Abfrageschritte und Spalten hängen davon ab, welchen Befehl Sie auswählen. Weitere Informationen finden Sie im Abschnitt Informationen zu all diesen Abfragen.

  1. Wählen Sie Daten > Daten > Aus Datei > Aus Ordner aus. Das Dialogfeld Durchsuchen wird angezeigt.

  2. Suchen Sie den Ordner, der die zu kombinierenden Dateien enthält.

  3. Eine Liste der Dateien im Ordner wird im Dialogfeld Ordnerpfad <Ordnerpfad> angezeigt. Vergewissern Sie sich, dass alle von Ihnen erstellten Dateien aufgelistet sind.

  4. Wählen Sie unten im Dialogfeld einen der Befehle aus, z. B. Kombinieren> & Transformieren. Im Abschnitt Informationen zu all diesen Befehlen werden weitere Befehle erläutert.

    Der Power Query-Editor wird angezeigt.

  5. Die Spalte Wert ist eine strukturierte Listenspalte. Wählen Sie das Symbol Symbol 'Spalte erweitern' aus, und wählen Sie dann Zu neuen Zeilen erweitern aus. 

    Erweitern einer JSON-Liste

  6. Die Spalte Wert ist jetzt eine strukturierte Datensatzspalte. Wählen Sie das Symbol Symbol 'Spalte erweitern' aus. Ein Dropdown-Dialogfeld wird angezeigt.

    Erweitern eines JSON-Eintrags

  7. Lassen Sie alle Spalten markiert. Möglicherweise möchten Sie das Kontrollkästchen Ursprünglichen Spaltennamen als Präfix verwenden löschen. Wählen Sie OK aus.

  8. Markieren Sie alle Spalten, die Datenwerte enthalten. Wählen Sie Start,den Pfeil neben Spalten entfernenund dann Andere Spalten entfernen aus.

  9. Wählen Sie Start> schließen & Laden aus.

Ergebnis

Power Query erstellt automatisch Abfragen, um die Daten aus jeder Datei in einem Arbeitsblatt zu konsolidieren. Die erstellten Abfrageschritte und Spalten hängen davon ab, welchen Befehl Sie auswählen. Weitere Informationen finden Sie im Abschnitt Informationen zu all diesen Abfragen.

Jede dieser Datenquellen kann mehr als ein Objekt zum Importieren haben. Eine Excel Arbeitsmappe kann mehrere Arbeitsblätter, Excel Tabellen oder benannte Bereiche enthalten. Eine Access-Datenbank kann mehrere Tabellen und Abfragen enthalten. 

  1. Wählen Sie Daten > Daten > Aus Datei > Aus Ordner aus. Das Dialogfeld Durchsuchen wird angezeigt.

  2. Suchen Sie den Ordner, der die zu kombinierenden Dateien enthält.

  3. Eine Liste der Dateien im Ordner wird im Dialogfeld Ordnerpfad <Ordnerpfad> angezeigt. Vergewissern Sie sich, dass alle von Ihnen erstellten Dateien aufgelistet sind.

  4. Wählen Sie unten im Dialogfeld einen der Befehle aus, z. B. Kombinieren> & Laden. Im Abschnitt Informationen zu all diesen Befehlen werden weitere Befehle erläutert.

  5. Im Dialogfeld Dateien kombinieren:

    • Wählen Sie im Feld Beispieldatei eine Datei aus, die als Beispieldaten zum Erstellen der Abfragen verwendet werden soll. Sie können entweder kein Objekt oder nur ein Objekt auswählen. Sie können jedoch nicht mehr als eine Option auswählen.

    • Wenn Sie viele Objekte haben, verwenden Sie das Suchfeld, um ein Objekt oder die Anzeigeoptionen zusammen mit der Schaltfläche Aktualisieren zu suchen, um die Liste zu filtern.

    • Aktivieren oder aktivieren Sie das Kontrollkästchen Dateien mit Fehlern überspringen am unteren Rand des Dialogfelds.

  6. Wählen Sie OK aus.

Ergebnis

Power Query erstellt automatisch eine Abfrage, um die Daten aus jeder Datei in einem Arbeitsblatt zu konsolidieren. Die erstellten Abfrageschritte und Spalten hängen davon ab, welchen Befehl Sie auswählen. Weitere Informationen finden Sie im Abschnitt Informationen zu all diesen Abfragen.

Für mehr Flexibilität können Sie Dateien explizit im Power Query-Editor mithilfe des Befehls Dateien kombinieren kombinieren. Angenommen, der Quellordner verfügt über eine Mischung von Dateitypen und Unterordnern, und Sie möchten bestimmte Dateien mit demselben Dateityp und Schema, aber nicht mit anderen Dateien, an die Sie sich als Ziel nehmen möchten. Dadurch können Sie die Leistung verbessern und Ihre Transformationen vereinfachen.

  1. Wählen Sie Daten> Daten > Aus Datei > Ordner aus. Das Dialogfeld Durchsuchen wird angezeigt.

  2. Suchen Sie den Ordner, der die zu kombinierenden Dateien enthält, und wählen Sie dann Öffnen aus.

  3. Eine Liste aller Dateien in den Ordnern und Unterordnern wird im< Ordnerpfad >angezeigt. Vergewissern Sie sich, dass alle von Ihnen erstellten Dateien aufgelistet sind.

  4. Wählen Sie unten Daten transformieren aus. Der Power Query-Editor wird geöffnet und zeigt alle Dateien im Ordner und in allen Unterordnern an.

  5. Zum Auswählen der von Ihnen ausgewählten Dateien filtern Sie Spalten, z. B. Erweiterung oder Ordnerpfad.

  6. Wenn Sie die Dateien zu einer einzigen Tabelle kombinieren möchten, wählen Sie die Spalte Inhalt aus, die jede Binärdatei enthält (normalerweise die erste Spalte), und wählen Sie dann Start > Dateien kombinieren aus. Das Dialogfeld Dateien kombinieren wird angezeigt.

  7. Power Query analysiert eine Beispieldatei (standardmäßig die erste Datei in der Liste), um den richtigen Verbinder zu verwenden und übereinstimmende Spalten zu identifizieren.

    Wenn Sie eine andere Datei für die Beispieldatei verwenden möchten, wählen Sie sie in der Dropdownliste Beispieldatei aus.

  8. Wählen Sie optional unten Dateien mit Fehlern überspringen aus, um diese Dateien aus dem Ergebnis auszuschließen.

  9. Wählen Sie OK aus.

Ergebnis

Power Query erstellt automatisch eine Abfrage, um die Daten aus jeder Datei in einem Arbeitsblatt zu konsolidieren. Die erstellten Abfrageschritte und Spalten hängen davon ab, welchen Befehl Sie auswählen. Weitere Informationen finden Sie im Abschnitt Informationen zu all diesen Abfragen.

Es gibt mehrere Befehle, die Sie auswählen können, und jeder Befehl hat einen anderen Zweck.

  • Kombinieren und Transformieren von Daten    Wenn Sie alle Dateien mit einer Abfrage kombinieren und dann den Power Query-Editor starten möchten, wählen Sie Kombinieren> Daten kombinieren und transformieren aus.

  • Kombinieren und Laden   Wenn Sie das Dialogfeld Beispieldatei anzeigen möchten, erstellen Sie eine Abfrage, und laden Sie sie dann in ein Arbeitsblatt, und wählen Sie kombinieren >Und laden aus.

  • Kombinieren und Laden in   Wenn Sie das Dialogfeld Beispieldatei anzeigen möchten, erstellen Sie eine Abfrage, und zeigen Sie dann das Dialogfeld Importieren an, und wählen Sie Kombinieren > und Laden in aus.

  • Laden    Wenn Sie eine Abfrage in einem Schritt erstellen und dann in ein Arbeitsblatt laden möchten, wählen Sie Laden> Laden aus.

  • Laden in   Wenn Sie eine Abfrage in einem Schritt erstellen und dann das Dialogfeld Importieren anzeigen möchten, wählen Sie Laden > In laden aus.

  • Transformieren von DatenWenn Sie eine Abfrage in einem Schritt erstellen und dann den Power Query-Editor starten möchten, wählen Sie Daten transformieren aus.

Wenn Sie jedoch Dateien kombinieren, werden im Bereich Abfragen unter der Gruppe "Hilfsabfragen" mehrere unterstützende Abfragen erstellt.

Eine Liste der im Bereich "Abfragen" erstellten Abfragen

  • Power Query erstellt eine "Beispieldatei"-Abfrage basierend auf der Beispielabfrage.

  • Eine Abfrage der Funktion "Transformationsdatei" verwendet die Abfrage "Parameter1", um jede Datei (oder Binärdatei) als Eingabe für die Abfrage "Beispieldatei" anzugeben. Diese Abfrage erstellt auch die Spalte Inhalt, die den Dateiinhalt enthält, und erweitert automatisch die strukturierte Spalte Datensatz, um den Ergebnissen die Spaltendaten hinzuzufügen. Die Abfragen "Transformationsdatei" und "Beispieldatei" sind verknüpft, sodass Änderungen an der Abfrage "Beispieldatei" in der Abfrage "Transformieren einer Datei" widersspiegelt werden.

  • Die Abfrage mit den endgültigen Ergebnissen befindet sich in der Gruppe "Andere Abfragen". Standardmäßig ist die Datei nach dem Ordner benannt, aus dem Sie die Dateien importiert haben.

Klicken Sie zur weiteren Untersuchung mit der rechten Maustaste auf jede Abfrage, und wählen Sie Bearbeiten aus, um die einzelnen Abfrageschritte zu untersuchen und zu sehen, wie die Abfragen zusammen funktionieren.

Um mit dem Kombinieren mehrerer Dateien zu beginnen, müssen Sie zunächst sicherstellen, dass sich alle zu kombinierenden Dateien in einem einzigen Dateiordner befinden.

Hinweis: Unterstützt werden Excel-, Text-, CSV-, JSON-, XML- und Access-Dateien.

  1. Klicken Sie auf die Registerkarte Power Query und dann auf Aus > Aus Ordner.

    Optionen von Power Query > Aus > aus Ordnern
  2. Klicken Sie auf die Schaltfläche Durchsuchen, um nach Ihrem Ordner zu suchen.

    Es wird eine Liste der Dateien im Ordner angezeigt. Wählen Sie die Option Bearbeiten aus, um den Abfrage-Editor zu öffnen. In diesem Fall haben wir 4 Excel-Arbeitsmappen geladen.

    Dialogfeld "Binärdateien kombinieren" mit den zu kombinierenden Dateien
  3. Nachdem Sie überprüft haben, dass alle gewünschten Dateien aufgeführt sind, klicken Sie in der Spalte Inhalt auf die Schaltfläche Binärdateien kombinieren.

    Drücken Sie in der Spalte "Inhalt" der Abfrage oder im Power Query-Menüband im Abschnitt "Kombinieren" auf die Schaltfläche "Binärdateien kombinieren".
  4. Jede Datei wird analysiert, und das richtige Dateiformat (z. B. Text, Excel oder JSON) wird bestimmt. In diesem Fall wird eine Liste der Arbeitsblätter aus der ersten Excel-Arbeitsmappe angezeigt. Wählen Sie das Arbeitsblatt aus, das Sie verwenden möchten, und klicken Sie auf OK.

    Dialogfeld "Binärdateien kombinieren" mit verfügbaren Excel-Arbeitsblättern zur Auswahl des primären Konsolidierungsziels
  5. Durch den Transformationsprozess beim Kombinieren der Binärdateien wird automatisch eine Abfrage erstellt, um die Daten der einzelnen Dateien zu konsolidieren und eine Vorschau anzuzeigen. Wenn Sie mit dem Ergebnis zufrieden sind, klicken Sie auf Schließen und Laden.

    Dialogfeld "Binärdateien kombinieren". Drücken Sie schließen & laden, um die Ergebnisse zu akzeptieren und in Excel.

    Durch den Kombinationsprozess der Binärdateien werden die aufgelisteten Arbeitsblätter in einem einzigen Arbeitsblatt konsolidiert.

  6. Wenn sich die ursprünglichen Datendateien ändern, können Sie die importierten Daten jederzeit aktualisieren. Klicken Sie auf eine beliebige Stelle im Datenbereich, und wechseln Sie dann zu Abfragetools, > aktualisieren. Darüber hinaus können Sie problemlos zusätzliche Transformations- oder Extraktionsschritte anwenden, indem Sie die automatisch erstellte Beispielabfrage ändern, ohne sich Gedanken über das Ändern oder Erstellen zusätzlicher Funktionsabfrageschritte machen zu müssen. alle Änderungen an der Beispielabfrage werden automatisch in der verknüpften Funktionsabfrage generiert.

Bekannte Probleme

Beim Laden der Prozedur "Binärdateien kombinieren" in Excel wird möglicherweise folgende Fehlermeldung angezeigt:

Fehlermeldung beim Kombinieren von Binärdateien. Dies ist ein bekanntes Problem, um das wir uns kümmern.

Wenn Sie die Fehlermeldung(en) schließen, indem Sie auf OK klicken, wird der Prozess Binärdateien kombinieren abgeschlossen, und Ihr Daten werden trotz des Fehlers ordnungsgemäß geladen. Wir arbeiten daran, den Fehler zu beheben.

Siehe auch

Hilfe zu Power Query für Excel

Anfügen von Abfragen

Übersicht über "Dateien kombinieren" (docs.com)

Kombinieren von CSV-Dateien in Power Query (docs.com)

Benötigen Sie weitere Hilfe?

Ihre Office-Fähigkeiten erweitern
Schulungen erkunden
Neue Funktionen als Erster erhalten
Microsoft Insider beitreten

War diese Information hilfreich?

Wie zufrieden sind Sie mit der Übersetzungsqualität?

Was hat Ihre Erfahrung beeinflusst?

Haben Sie weiteres Feedback? (Optional)

Vielen Dank für Ihr Feedback!

×