Korrigieren eines Fehlerwerts vom Typ fehler in der Funktion ZÄHLENWENN/ZÄHLENWENNS

In diesem Thema werden die häufigeren Ursachen der #VALUE! in den Funktionen ZÄHLENWENN und ZÄHLENWENNS zurück.

Problem: Die Formel verweist auf Zellen in einer geschlossenen Arbeitsmappe

ZählenWENN/ZÄHLENWENNS-Funktionen, die auf eine Zelle oder einen Bereich in einer geschlossenen Arbeitsmappe verweisen, führen zu einem #VALUE! angezeigt.

Hinweis: Dies ist ein bekanntes Problem bei mehreren anderen Excel-Funktionen, z. B. SUMMEWENN, SUMMEWENNS, ANZAHLBLANK, um nur einige zu nennen. Die Funktionen SUMMEWENN, ZÄHLENWENN und ANZAHLBLANK geben #VALUE! zurück .

Lösung: Öffnen Sie die verknüpfte Arbeitsmappe, die in der Formel angegeben ist, und drücken Sie F9, um die Formel zu aktualisieren.

Sie können dieses Problem auch beheben, indem Sie die Funktionen SUMME und WENN zusammen in einer Matrixformel verwenden. Die Funktionen SUMMEWENN, ZÄHLENWENN und ANZAHLBLANK geben #VALUE! zurück .

Problem: Die Zeichenfolge ist länger als 255 Zeichen.

Lösung: Kürzen Sie die Zeichenfolge, falls möglich. Wenn Sie sie nicht kürzen können, verwenden Sie die Funktion VERKETTEN oder den &-Operator (kaufmännisches Und-Zeichen), um den Wert in mehrere Zeichenfolgen zu unterteilen. Beispiel:

  • =ZÄHLENWENN(B2:B12;"lange Zeichenfolge"&"weitere lange Zeichenfolge")

Haben Sie eine Frage zu einer bestimmten Funktion?

Posten Sie eine Frage im Excel-Communityforum

Helfen Sie uns, Excel zu verbessern

Haben Sie Vorschläge, wie wir die kommende Version von Excel verbessern könnten? Wenn ja, lesen Sie die Themen unter Excel User Voice.

Siehe auch

Korrigieren sie #VALUE! #BUSY!

ZÄHLENWENN

ZÄHLENWENNS

WENN-Funktion – Geschachtelte Formeln und das Vermeiden von Fallgruben

Schauen Sie sich ein Video zu erweiterten WENN-Funktionen an.

Übersicht über Formeln in Excel

Vermeiden defekter Formeln

Ermitteln von Fehlern in Formeln

Alle Funktionen in Excel (alphabetisch)

Alle Excel-Funktionen (nach Kategorie)

Benötigen Sie weitere Hilfe?

Ihre Office-Fähigkeiten erweitern
Schulungen erkunden
Neue Funktionen als Erster erhalten
Office Insider werden

War diese Information hilfreich?

Vielen Dank für Ihr Feedback!

Vielen Dank für Ihr Feedback. Es klingt, als ob es hilfreich sein könnte, Sie mit einem unserer Office-Supportmitarbeiter zu verbinden.

×