Korrigieren eines #REF! #BLOCKIERT!

Der Fehler #BEZUG! wird angezeigt, wenn eine Formel auf eine Zelle verweist, die nicht gültig ist. Häufigste Ursache hierfür ist, dass Zellen, auf die aus einer Formel verwiesen wird, gelöscht oder durch andere Daten ersetzt wurden.

Beispiel: #REF! Fehler aufgrund des Löschens einer Spalte

Im folgenden Beispiel wird die Formel =SUMME(B2;C2;D2) in Spalte E verwendet.

Eine Formel, die explizite Zellbezüge wie =SUMME(B2;C2;D2) verwendet, kann zu einer #REF! zurück, wenn eine Spalte gelöscht wird.

Würden Sie Spalte B, C oder D löschen, würde dies zu einer #REF! -Fehlermeldung zurück. In diesem Fall wird Spalte C (Umsatz 2007) gelöscht, und die Formel lautet jetzt =SUMME(B2;#REF!;C2). Wenn Sie explizite Zellbezüge wie diese verwenden (in denen Sie auf jede Zelle einzeln, durch Kommas getrennt) verweisen und eine Zeile oder Spalte löschen, auf die verwiesen wird, kann Excel diese nicht auflösen, sodass der Wert zurückgegeben #REF! -Fehlermeldung zurück. Dies ist der Hauptgrund, warum die Verwendung expliziter Zellbezüge in Funktionen nicht empfohlen wird.

Beispiel für #REF! Fehler durch Löschen einer Spalte.

Lösung

  • Wenn Sie Zeilen oder Spalten versehentlich gelöscht haben, können Sie sofort auf der Symbolleiste für den Schnellzugriff auf die Schaltfläche "Rückgängig" klicken (oder STRG+Z drücken), um die Zeilen oder Spalten wiederherzustellen.

  • Passen Sie die Formel so an, dass in ihr ein Bereichsbezug anstelle einzelner Zellen verwendet wird, etwa =SUMME(B2:D2). Jetzt können Sie eine beliebige Spalte im Bereich der Summe löschen, und Excel passt die Formel automatisch an. Sie können auch =SUMME(B2:B5) für eine Zeilensumme verwenden.

Beispiel: SVERWEIS mit falschen Bereichsbezügen

Im folgenden Beispiel gibt =SVERWEIS(A8;A2:D5;5;FALSCH) einen Fehler #REF! zurück, da nach einem Wert gesucht wird, der aus Spalte 5 zurückgegeben werden soll. Der Bezugsbereich ist jedoch A:D (nur 4 Spalten).

Beispiel für eine SVERWEIS-Formel mit einem falschen Bereich  Die Formel ist =SVERWEIS(A8;A2:D5;5;FALSCH).  Es gibt keine fünfte Spalte im SVERWEIS-Bereich, sodass 5 einen Fehler #REF! -Fehlermeldung zurück.

Lösung

Passen Sie den Bereich an, sodass er größer ist, oder verringern Sie den Spaltenverweiswert entsprechend dem Bezugsbereich. =SVERWEIS(A8;A2:E5;5;FALSCH) ist ein gültiger Bezugsbereich ebenso wie =SVERWEIS(A8;A2:D55;4;FALSCH).

Beispiel: INDEX mit falschem Zeilen- oder Spaltenbezug

In diesem Beispiel gibt die Formel =INDEX(B2:E5;5;5) ein #REF! zurück, da der INDEX-Bereich 4 Zeilen mal 4 Spalten umfasst, die Formel jedoch fragt, was sich in der 5. Zeile und 5. Spalte befindet.

Beispiel einer INDEX-Formel mit einem ungültigen Bereichsbezug.  Formel ist =INDEX(B2:E5;5;5), aber der Bereich hat nur 4 Zeilen mal 4 Spalten.

Lösung

Passen Sie die Zeilen- oder Spaltenbezüge so an, dass sie im INDEX-Verweisbereich liegen. =INDEX(B2:E5;4;4) würde ein gültiges Ergebnis zurückgegeben.

Beispiel: Bezugnehmen auf eine geschlossene Arbeitsmappe mit INDIREKT

Im folgenden Beispiel wird in einer INDIREKT-Funktion auf eine Arbeitsmappe Bezug genommen, die geschlossen ist. Dadurch wird ein #BEZUG!-Fehler verursacht.

Beispiel für einen #REF! fehler aufgrund der INDIREKT-Indirekten, die auf eine geschlossene Arbeitsmappe verweisen.

Lösung

Öffnen Sie die Arbeitsmappe, auf die verwiesen wird. Der gleiche Fehler tritt auf, wenn Sie auf eine geschlossene Arbeitsmappe mit einer dynamischen Arrayfunktion verweisen.

OLE-Probleme

Wenn Sie eine OLE-Verknüpfung (Object Linking and Embedding) verwendet haben, die eine Verbindung #REF! zurück, und starten Sie dann das Programm, das über den Link aufruft.

Note: OLE ist eine Technologie, die Sie verwenden können, um Informationen zwischen Programmen gemeinsam zu nutzen.

DDE-Probleme

Wenn Sie ein DDE-Thema (Dynamic Data Exchange) verwendet haben, das einen dynamischen #REF! fehler, überprüfen Sie zunächst, ob Sie auf das richtige Thema verweisen. Wenn Sie immer noch eine E-Mail #REF! aus, überprüfen Sie das Trust Center-Einstellungen auf externe Inhalte, wie unter Blockieren oder Aufheben der Blockierung externer Inhalte in Office beschrieben.

Hinweis: Dynamic Data Exchange (DDE)ist ein eingeführtes Protokoll für den Austausch von Daten zwischen Microsoft Windows-basierten Programmen.

Makroprobleme

Wenn ein Makro eine Funktion auf dem Arbeitsblatt ein gibt, die sich auf eine Zelle über der Funktion bezieht, und die Zelle, die die Funktion enthält, sich in Zeile 1 befindet, gibt die Funktion #REF! da sich über Zeile 1 keine Zellen befinden. Überprüfen Sie die -Funktion, um zu sehen, ob sich ein Argument auf eine Zelle oder einen Zellbereich bezieht, die nicht gültig ist. Dies erfordert möglicherweise die Bearbeitung des Makros im Visual Basic-Editor (VBE), um diese Situation zu berücksichtigen.

Benötigen Sie weitere Hilfe?

Sie können jederzeit einen Experten in der Excel Tech Community fragen oder Unterstützung in der Answers Community erhalten.

Siehe auch

Übersicht über Formeln in Excel

Vermeiden defekter Formeln

Ermitteln von Fehlern in Formeln

Excel-Funktionen (alphabetisch)

Excel-Funktionen (nach Kategorie)

Benötigen Sie weitere Hilfe?

Ihre Office-Fähigkeiten erweitern
Schulungen erkunden
Neue Funktionen als Erster erhalten
Microsoft Office Insidern beitreten

War diese Information hilfreich?

Wie zufrieden sind Sie mit der Sprachqualität?
Was hat Ihre Erfahrung beeinflusst?

Vielen Dank für Ihr Feedback!

×