Mit Microsoft anmelden
Melden Sie sich an, oder erstellen Sie ein Konto.
Hallo,
Wählen Sie ein anderes Konto aus.
Sie haben mehrere Konten.
Wählen Sie das Konto aus, mit dem Sie sich anmelden möchten.
Korrigieren eines #REF! Fehler

Der Fehler #REF! zeigt an, wenn eine Formel auf eine ungültige Zelle verweist. Häufigste Ursache hierfür ist, dass Zellen, auf die aus einer Formel verwiesen wird, gelöscht oder durch andere Daten ersetzt wurden.

Im folgenden Beispiel wird die Formel =SUMME(B2;C2;D2) in Spalte E verwendet.

Eine Formel mit expliziten Zellbezügen wie =SUMME(B2;C2;D2) kann eine #REF! Fehler, wenn eine Spalte gelöscht wird.

Wenn Sie Spalte B, C oder D löschen würden, würde dies zu einer #REF! Wenn die von Ihnen angegebene Position vor dem ersten oder nach dem letzten Element im Feld liegt, führt die Formel zu einem Fehler des Typs #BEZUG!. In diesem Fall löschen wir Spalte C (2007 Sales), und die Formel lautet jetzt =SUMME(B2;#REF!;C2). Wenn Sie explizite Zellbezüge wie diesen verwenden (wobei Sie auf jede Zelle einzeln verweisen, getrennt durch ein Komma) und eine Zeile oder Spalte löschen, auf die verwiesen wird, kann Excel diese nicht auflösen, sodass die #REF zurückgegeben wird! Wenn die von Ihnen angegebene Position vor dem ersten oder nach dem letzten Element im Feld liegt, führt die Formel zu einem Fehler des Typs #BEZUG!. Dies ist der Hauptgrund, warum die Verwendung expliziter Zellbezüge in Funktionen nicht empfohlen wird.

Beispiel für die #REF! Fehler durch Löschen einer Spalte.

Lösung

  • Wenn Sie Zeilen oder Spalten versehentlich gelöscht haben, können Sie sofort auf der Symbolleiste für den Schnellzugriff auf die Schaltfläche "Rückgängig" klicken (oder STRG+Z drücken), um die Zeilen oder Spalten wiederherzustellen.

  • Passen Sie die Formel so an, dass in ihr ein Bereichsbezug anstelle einzelner Zellen verwendet wird, etwa =SUMME(B2:D2). Jetzt können Sie eine beliebige Spalte im Bereich der Summe löschen, und Excel passt die Formel automatisch an. Sie können auch =SUMME(B2:B5) für eine Zeilensumme verwenden.

Im folgenden Beispiel gibt =SVERWEIS(A8;A2:D5;5;FALSE) eine #REF! fehler, da nach einem Wert gesucht wird, der aus Spalte 5 zurückgegeben werden soll, aber der Verweisbereich A:D ist, was nur 4 Spalten umfasst.

Beispiel für eine SVERWEIS-Formel mit einem falschen Bereich.  Formel ist =SLOOKU(A8;A2:D5;5;FALSE).  Es gibt keine fünfte Spalte im SVERWEIS-Bereich, sodass 5 eine #REF! Wenn die von Ihnen angegebene Position vor dem ersten oder nach dem letzten Element im Feld liegt, führt die Formel zu einem Fehler des Typs #BEZUG!.

Lösung

Passen Sie den Bereich an, sodass er größer ist, oder verringern Sie den Spaltenverweiswert entsprechend dem Bezugsbereich. =SVERWEIS(A8;A2:E5;5;FALSCH) ist ein gültiger Bezugsbereich ebenso wie =SVERWEIS(A8;A2:D55;4;FALSCH).

In diesem Beispiel gibt die Formel =INDEX(B2:E5;5;5) eine #REF! fehler, da der INDEX-Bereich 4 Zeilen mal 4 Spalten umfasst, aber die Formel fragt, was sich in der 5. Zeile und 5. Spalte befindet.

Beispiel einer INDEX-Formel mit einem ungültigen Bereichsbezug.  Formel ist =INDEX(B2:E5;5;5), aber der Bereich hat nur 4 Zeilen mal 4 Spalten.

Lösung

Passen Sie die Zeilen- oder Spaltenbezüge so an, dass sie im INDEX-Verweisbereich liegen. =INDEX(B2:E5;4;4) würde ein gültiges Ergebnis zurückgegeben.

Im folgenden Beispiel wird in einer INDIREKT-Funktion auf eine Arbeitsmappe Bezug genommen, die geschlossen ist. Dadurch wird ein #BEZUG!-Fehler verursacht.

Beispiel für eine #REF! Fehler, der durch indirekten Verweis auf eine geschlossene Arbeitsmappe verursacht wird.

Lösung

Öffnen Sie die Arbeitsmappe, auf die verwiesen wird. Der gleiche Fehler tritt auf, wenn Sie auf eine geschlossene Arbeitsmappe mit einer dynamischen Arrayfunktion verweisen.

Strukturierte Verweise auf Tabellen- und Spaltennamen in verknüpften Arbeitsmappen werden nicht unterstützt.

Berechnete Verweise auf verknüpfte Arbeitsmappen werden nicht unterstützt.

Das Verschieben oder Löschen von Zellen führte zu einem ungültigen Zellbezug, oder die Funktion gibt einen Verweisfehler zurück.

Wenn Sie einen OLE-Link (Object Linking and Embedding) verwendet haben, der eine #REF! fehler, und starten Sie dann das Programm, das der Link aufruft.

Hinweis: OLE ist eine Technologie, die Sie verwenden können, um Informationen zwischen Programmen gemeinsam zu nutzen.

Wenn Sie ein DDE-Thema (Dynamic Data Exchange) verwendet haben, das eine #REF! fehler, überprüfen Sie zunächst, ob Sie auf das richtige Thema verweisen. Wenn Sie immer noch eine #REF erhalten! fehler, überprüfen Sie Ihre Einstellungen im Trust Center auf externe Inhalte, wie unter Blockieren oder Aufheben der Blockierung externer Inhalte in Microsoft 365-Dokumenten beschrieben.

Hinweis: Dynamic Data Exchange (DDE)ist ein etabliertes Protokoll für den Datenaustausch zwischen Microsoft Windows-basierten Programmen.

Makroprobleme

Wenn ein Makro in eine Funktion auf dem Arbeitsblatt eintritt, die auf eine Zelle über der Funktion verweist, und die Zelle, die die Funktion enthält, in Zeile 1 befindet, gibt die Funktion #REF! da sich über Zeile 1 keine Zellen befinden. Überprüfen Sie die Funktion, um festzustellen, ob sich ein Argument auf eine zelle oder einen bereich von ungültigen Zellen bezieht. Dies kann eine Bearbeitung des Makros im Visual Basic-Editor (VBE) erfordern, um diese Situation zu berücksichtigen.

Benötigen Sie weitere Hilfe?

Erhalten Von Live- und kostenlosen Antworten auf Excel

Sie können jederzeit einen Experten in der Excel Tech Community fragen oder Unterstützung in der Answers Community erhalten.

Siehe auch

Übersicht über Formeln in Excel

Vermeiden defekter Formeln

Ermitteln von Fehlern in Formeln

Excel-Funktionen (alphabetisch)

Excel-Funktionen (nach Kategorie)

Benötigen Sie weitere Hilfe?

Ihre Office-Fähigkeiten erweitern
Schulungen erkunden
Neue Funktionen als Erster erhalten
Microsoft Office Insidern beitreten

War diese Information hilfreich?

Wie zufrieden sind Sie mit der Sprachqualität?
Was hat Ihre Erfahrung beeinflusst?

Vielen Dank für Ihr Feedback!

×