SVERWEIS (Funktion)

Tipp: Versuchen Sie, die neue XVERWEIS-Funktion zu verwenden, eine verbesserte Version von SVERWEIS, die in jede Richtung funktioniert und standardmäßig genaue Übereinstimmungen zurückgibt, wodurch die Verwendung einfacher und bequemer als beim Vorgänger ist.

Verwenden Sie SVERWEIS, wenn Sie Dinge in einer Tabelle oder einem Bereich nach Zeile suchen müssen. Suchen Sie z. B. einen Preis für ein Fahrzeugteil nach der Teilenummer, oder suchen Sie einen Mitarbeiternamen basierend auf der Mitarbeiter-ID.

Tipp: Weitere Hilfe zu SVERWEIS finden Sie in diesen YouTube-Videos von Microsoft Creators!

In ihrer einfachsten Form besagt die Funktion SVERWEIS Folgendes:

=SVERWEIS(Was Sie suchen möchten, wo sie suchen möchten, die Spaltennummer im Bereich, die den wert enthält, den Sie zurückgeben möchten, gibt eine Ungefähre oder genaue Übereinstimmung zurück – angegeben als 1/WAHR oder 0/FALSCH).

Ihr Browser unterstützt kein Video.

Tipp: Das Geheimnis von SVERWEIS besteht in der Struktur ihrer Daten, sodass der nachgeschaute Wert (Obst) links vom Rückgabewert (Betrag) liegt, den Sie suchen möchten.

Verwenden Sie die Funktion SVERWEIS zum Nachschlagen eines Werts in einer Tabelle.

Syntax

SVERWEIS(Suchkriterium; Matrix; Spaltenindex; [Bereich_Verweis])

Beispiel:

  • =SVERWEIS(A2;A10:C20;2;WAHR)

  • =SVERWEIS("Eitner";B2:E7;2;FALSCH)

  • =SVERWEIS(A2;'Clientdetails'! A:F,3;FALSCH)

Argumentname

Beschreibung

Suchkriterium    (erforderlich)

Der Wert, nach dem Sie suchen möchten. Der Wert, den Sie nachschauen möchten, muss sich in der ersten Spalte des Zellbereichs enthalten, den Sie im Argument table_array angeben.

Wenn tabellenarray z. B. die Zellen B2:D7 umfasst, muss lookup_value Spalte B angezeigt werden.

Das Suchkriterium kann ein Wert oder ein Bezug auf eine Zelle sein.

Matrix    (erforderlich)

Der Zellbereich, in dem SVERWEIS nach dem Suchkriterium und dem Rückgabewert sucht. Sie können einen benannten Bereich oder eine Tabelle verwenden, und Sie können Namen im Argument anstelle von Zellbezügen verwenden. 

Die erste Spalte im Zellbereich muss die lookup_value. Der Zellbereich muss auch den Rückgabewert enthalten, den Sie suchen möchten.

Informationen zum Markieren von Bereichen auf einem Arbeitsblatt.

Spaltenindex    (erforderlich)

Die Spaltennummer (beginnend mit 1 für die linke Spalte table_array ),die den Rückgabewert enthält.

Bereich_Verweis    (optional)

Ein Wahrheitswert, der angibt, ob SVERWEIS eine ungefähre Entsprechung oder eine genaue Entsprechung suchen soll:

  • Ungefähre Übereinstimmung – 1/WAHR geht davon aus, dass die erste Spalte in der Tabelle numerisch oder alphabetisch sortiert ist und dann nach dem nächstgelegenen Wert sucht. Wenn Sie keine Angabe machen, ist dies ist die Standardmethode. Beispiel: =SVERWEIS(90;A1:B100;2;WAHR).

  • Genaue Übereinstimmung – 0/FALSCH sucht nach dem genauen Wert in der ersten Spalte. Beispiel: =SVERWEIS("Smith";A1:B100;2;FALSCH).

Erste Schritte

Es gibt vier Arten von Informationen, die Sie zum Erstellen der SVERWEIS-Syntax benötigen:

  1. Den Wert (Suchkriterium), den Sie nachschlagen möchten. Er wird auch als "Nachschlagewert" bezeichnet.

  2. Den Bereich, in dem sich der Nachschlagewert befindet. Denken Sie daran, dass der Nachschlagewert immer in der ersten Spalte des Bereichs stehen sollte, damit SVERWEIS ordnungsgemäß funktioniert. Wenn Ihr Nachschlagewert z. B. in Zelle C2 steht, sollte Ihr Bereich mit "C" beginnen.

  3. Die Spaltennummer in dem Bereich, der den Rückgabewert enthält. Wenn Sie beispielsweise B2:D11 als Bereich angeben, sollten Sie B als erste Spalte, C als zweite Spalte und so weiter zählen.

  4. Optional können Sie WAHR angeben, wenn Sie eine ungefähre Übereinstimmung, oder FALSCH angeben, wenn Sie eine genaue Übereinstimmung des Rückgabewerts haben möchten. Wenn Sie nichts angeben, lautet der Standardwert immer WAHR oder ist eine ungefähre Übereinstimmung.

Stellen Sie jetzt alle vorstehenden Informationen folgendermaßen zusammen:

=SVERWEIS(Suchwert, Bereich, der den Nachschlagewert enthält, die Spaltennummer im Bereich, der den Rückgabewert enthält, Ungefähre Übereinstimmung (WAHR) oder Genaue Übereinstimmung (FALSCH)).

Beispiele

Hier sind einige Beispiele für SVERWEIS:

Beispiel 1

SVERWEIS Beispiel 1

Beispiel 2

SVERWEIS Beispiel 2

Beispiel 3

SVERWEIS Beispiel 3

Beispiel 4

SVERWEIS Beispiel 4

Beispiel 5

SVERWEIS Beispiel 5

Sie können SVERWEIS verwenden, um mehrere Tabellen in einer Tabelle zu kombinieren, solange eine der Tabellen Felder enthält, die mit allen anderen gemeinsam sind. Dies kann besonders hilfreich sein, wenn Sie eine Arbeitsmappe für Personen freigeben müssen, die über ältere Versionen von Excel verfügen, die Datenfeatures mit mehreren Tabellen als Datenquellen nicht unterstützen. Indem Sie die Quellen in einer Tabelle kombinieren und die Datenquelle des Datenfeatures in die neue Tabelle ändern, kann das Datenfeature in älteren Excel-Versionen verwendet werden (vorausgesetzt, das Datenfeature selbst wird von der älteren Version unterstützt).

Ein Arbeitsblatt mit Spalten, die SVERWEIS verwenden, um Daten aus anderen Tabellen zu erhalten

Hier enthalten die Spalten A-F und H Werte oder Formeln, die nur Werte auf dem Arbeitsblatt verwenden, und die restlichen Spalten verwenden SVERWEIS und die Werte der Spalte A (Clientcode) und Spalte B (Attorney), um Daten aus anderen Tabellen zu erhalten.

  1. Kopieren Sie die Tabelle mit den allgemeinen Feldern auf ein neues Arbeitsblatt, und geben Sie ihr einen Namen.

  2. Klicken Sie auf > Datentools>, um das Dialogfeld Beziehungen verwalten zu öffnen.

    Dialogfeld "Beziehungen verwalten"
  3. Beachten Sie für jede aufgelistete Beziehung Folgendes:

    • Das Feld, das die Tabellen verknüpft (in Klammern im Dialogfeld aufgelistet). Dies ist die lookup_value für Ihre SVERWEIS-Formel.

    • Der Name der verknüpften Nachschlagetabelle. Dies ist table_array in Ihrer SVERWEIS-Formel.

    • Das Feld (Spalte) in der Tabelle "Verwandte Nachschlagetabelle", das die daten enthält, die Sie in der neuen Spalte wünschen. Diese Informationen werden im Dialogfeld Beziehungen verwalten nicht angezeigt. Sie müssen in der Tabelle "Verwandte Nachschlagetabelle" nachschauen, um zu sehen, welches Feld Sie abrufen möchten. Sie möchten die Spaltennummer (A=1) notieren – dies ist die col_index_num in Ihrer Formel.

  4. Wenn Sie der neuen Tabelle ein Feld hinzufügen möchten, geben Sie ihre SVERWEIS-Formel in die erste leere Spalte ein, indem Sie die Informationen verwenden, die Sie in Schritt 3 gesammelt haben.

    In unserem Beispiel verwendet Spalte G Attorney (lookup_value),um die Rechnungssatzdaten aus der vierten Spalte (col_index_num = 4) aus der Arbeitsblatttabelle "Anwälte" zu erhalten, tblAttorneys (table_array), mit der Formel =SVERWEIS([@Attorney];tbl_Attorneys;4;FALSCH).

    Die Formel kann auch einen Zellbezug und einen Bereichsbezug verwenden. In unserem Beispiel wäre es =SVERWEIS(A2;'Anwälte'! A:D,4;FALSE).

  5. Fahren Sie mit dem Hinzufügen von Feldern fort, bis Sie über alle benötigten Felder verfügen. Wenn Sie versuchen, eine Arbeitsmappe mit Datenfeatures vorzubereiten, die mehrere Tabellen verwenden, ändern Sie die Datenquelle des Datenfeatures in die neue Tabelle.

Problem

Ursache

Falscher Wert zurückgegeben

Wenn Bereich_Verweis als WAHR oder gar nicht angegeben ist, muss die erste Spalte alphabetisch oder numerisch sortiert sein. Ist die erste Spalte nicht sortiert, kann es sich beim Rückgabewert um einen unerwarteten Wert handeln. Sortieren Sie entweder die erste Spalte, oder verwenden Sie FALSCH für eine genaue Entsprechung.

#NV in der Zelle

  • Wenn Bereich_Verweis als WAHR angegeben ist und der Wert im Suchkriterium kleiner als der kleinste Wert in der ersten Spalte der Matrix ist, wird der Fehlerwert "#NV" zurückgegeben.

  • Wenn Bereich_Verweis FALSCH ist, zeigt der Fehlerwert "#N/A" an, dass kein exakter Wert gefunden wurde.

Weitere Informationen zum Auflösen von #NV-Fehlern in SVERWEIS finden Sie unter Korrigieren eines #NV-Fehlers in der SVERWEIS-Funktion.

#BEZUG! in der Zelle

Wenn col_index_num größer als die Anzahl der Spalten in Tabellenarrayist, erhalten Sie die #REF! Fehlerwert.

Weitere Informationen zum Auflösen von #REF! Fehler in SVERWEIS finden Sie unter Korrigieren eines Fehlers #REF!.

#WERT!- in der Zelle

Wenn die table_array kleiner als 1 ist, erhalten Sie die #VALUE! Fehlerwert.

Weitere Informationen zum Auflösen von #VALUE! Fehler in SVERWEIS finden Sie unter Korrigieren eines #VALUE!-Fehlers in der Funktion SVERWEIS..

#NAME? in der Zelle

Der #NAME?- Fehlerwert bedeutet in der Regel, dass der Formel Anführungszeichen fehlen. Wenn Sie den Namen einer Person nachschauen möchten, stellen Sie sicher, dass Sie in der Formel Anführungszeichen um den Namen verwenden. Geben Sie beispielsweise den Namen als "Fontana" in =SVERWEIS("Fontana";B2:E7;2;FALSCH) ein.

Weitere Informationen finden Sie unter Korrigieren eines Fehlers #NAME!.

#ÜBERLAUF! in der Zelle

Dieser spezielle #SPILL!-Fehler bedeutet in der Regel, dass die Formel auf implizite Schnittmengen für den Nachschlagewert und die Verwendung einer ganzen Spalte als Bezug angewiesen ist. Beispiel: =SVERWEIS(A:A,A:C;2;FALSCH). Sie können das Problem beheben, indem Sie den Nachschlagebezug mit dem @-Operator wie hier verankert haben: =SVERWEIS(@A:A,A:C;2;FALSCH). Alternativ können Sie die herkömmliche SVERWEIS-Methode verwenden und auf eine einzelne Zelle anstelle einer ganzen Spalte verweisen: =SVERWEIS(A2,A:C;2;FALSCH).

Aktion

Grund

Verwenden Sie absolute Bezüge für Bereich_Verweis.

Bei Verwendung absoluter Bezüge können Sie eine Formel nach unten ausfüllen, sodass immer auf genau den gleichen Nachschlagebereich verwiesen wird.

Informationen zur Verwendung von absoluten Zellbezügen.

Speichern Sie keine Zahlen oder Datumswerten als Text.

Bei der Suche nach Zahlen oder Datumswerten müssen Sie sicherstellen, dass die Daten in der ersten Spalte der Matrix nicht als Textwerte gespeichert sind. Andernfalls gibt SVERWEIS möglicherweise einen falschen oder unerwarteten Wert zurück.

Sortieren Sie die erste Spalte.

Sortieren Sie die erste Spalte der Matrix, bevor Sie SVERWEIS verwenden, wenn Bereich_Verweis WAHR ist.

Verwenden Sie Platzhalterzeichen.

Wenn range_lookup falsch und lookup_value Text ist, können Sie die Platzhalterzeichen (Fragezeichen (?) und Sternchen (*) inlookup_value. Ein Fragezeichen ersetzt ein einzelnes Zeichen. Ein Sternchen ersetzt eine beliebige Zeichenfolge. Wenn Sie nach einem Fragezeichen oder Sternchen suchen möchten, geben Sie vor dem Zeichen eine Tilde (~) ein.

Beispielsweise sucht =SVERWEIS("Fontan?";B2:E7;2;FALSCH) nach allen Instanzen von Fontana mit einem letzten Buchstaben, der variieren kann.

Stellen Sie sicher, dass Ihre Daten keine fehlerhaften Zeichen enthalten.

Stellen Sie beim Durchsuchen von Textwerten in der ersten Spalte sicher, dass die Daten in der ersten Spalte keine führenden Leerzeichen, nachgestellten Leerzeichen, inkonsistente Verwendung von geraden ( ' oder " ) und geschweiften ( ' oder ") Anführungszeichen oder nicht druckenden Zeichen enthalten. In diesen Fällen gibt SVERWEIS möglicherweise einen unerwarteten Wert zurück.

Um genaue Ergebnisse zu erhalten, können Sie die Funktionen SÄUBERN und GLÄTTEN verwenden, um alle schließenden Leerzeichen nach Tabellenwerten in einer Zelle zu entfernen.

Benötigen Sie weitere Hilfe?

Sie können jederzeit einen Experten in der Excel Tech Community fragen, Unterstützung in der Answers Community erhalten oder aber ein neues Feature oder eine Verbesserung auf Excel User Voice vorschlagen.

Siehe auch

Kurzübersichtskarte: SVERWEIS-Aktualisierung
Kurzübersichtskarte: Tipps zur SVERWEIS-Problembehandlung
YouTube: SVERWEIS-Videos von Microsoft Creators
Korrigieren eines Fehlers #VALUE! in der Funktion SVERWEIS
Korrigieren eines Fehlers #N/A in der Funktion SVERWEIS
Übersicht über Formeln in Excel
Vermeiden defekter Formeln
Erkennen von Fehlern in Formeln
Excel-Funktionen (alphabetisch)
Excel-Funktionen (nach Kategorie)
SVERWEIS (kostenlose Vorschau)

Benötigen Sie weitere Hilfe?

Ihre Office-Fähigkeiten erweitern
Schulungen erkunden
Neue Funktionen als Erster erhalten
Office Insider werden

War diese Information hilfreich?

Vielen Dank für Ihr Feedback!

Vielen Dank für Ihr Feedback. Es klingt, als ob es hilfreich sein könnte, Sie mit einem unserer Office-Supportmitarbeiter zu verbinden.

×