Wenn Sie eine Matrixformel eingeben,verwenden Sie meistens einen Zellbereich auf dem Arbeitsblatt, müssen dies aber nicht selbst. Sie können auch Arraykonstante, Werte verwenden, die Sie einfach in geschweifte Klammern in die Formelleiste eingeben: {}. Anschließend können Sie der Konstante einen Namen geben, damit sie einfacher wieder verwendet werden kann.

Sie können Inkonstante in Matrixformeln oder selbst verwenden.

  1. Geben Sie in der Matrixformel eine öffnende geschweifte Klammer, die von Ihnen angezeigten Werte und eine schließende geschweifte Klammer ein. Hier ein Beispiel: =SUMME(A1:E1*{1.2.3.4.5})

    Die Konstante befindet sich innerhalb der geschweiften Klammern ({)}, und ja, Sie geben diese geschweiften Klammern manuell ein.

  2. Geben Sie den Rest der Formel ein, und drücken Sie STRG+UMSCHALT+EINGABETASTE.

    Die Formel sieht ähnlich wie {=SUMME(A1:E1*{1.2.3.4.5})}aus, und die Ergebnisse sehen wie hier aus:


    Eine Matrixkonstante, die in einer SUMMEN-Formel geschachtelt ist

    Die Formel multipliziert A1 mit 1 und B1 mit 2 usw., damit Sie nicht mehr 1,2,3,4,5 in Zellen auf dem Arbeitsblatt einfügen müssen.

Verwenden einer Konstante zum Eingeben von Werten in eine Spalte

Wenn Sie Werte in eine einzelne Spalte eingeben möchten, z. B. 3 Zellen in Spalte C, gehen Sie wie folgt vor:

  1. Wählen Sie die Zellen aus, die verwendet werden sollen.

  2. Geben Sie ein Gleichheitszeichen und die Konstante ein. Trennen Sie die Werte in der Konstante durch Semikolons, nicht durch Kommas. Wenn Sie Text eingeben, setzen Sie ihn in doppelte Anführungszeichen. Beispiel: ={"Quartal 1";" Quarter2";" Quartal 3"}

  3. Drücken Sie STRG+UMSCHALT+EINGABETASTE. Die Konstante sieht wie hier aus:

    Ein vertikale Matrixkonstane, in der Text verwendet wird

    Dies ist eine eindimensionale vertikale Konstante.

Verwenden einer Konstante zum Eingeben von Werten in eine Zeile

Wenn Sie schnell Werte in eine einzelne Zeile eingeben möchten, z. B. die Zellen F1, G1 und H1, gehen Sie wie folgt vor:

  1. Wählen Sie die Zellen aus, die verwendet werden sollen.

  2. Geben Sie ein Gleichheitszeichen und die Konstante ein. Dieses Mal trennen Sie die Werte jedoch durch Kommas und nicht durch Semikolons. Beispiel: ={1.2.3.4.5}

  3. Drücken Sie STRG+UMSCHALT+EINGABETASTE. Dann sieht die Konstante wie hier aus:

    Eine eindimensionale horizontale Matrixkonstante

    Dies ist eine eindimensionale horizontale Konstante.

Verwenden einer Konstante zum Eingeben von Werten in mehrere Spalten und Zeilen

  1. Markieren Sie die Zellen, die Sie wünschen.

    Stellen Sie sicher, dass die Anzahl der Zeilen und Spalten, die Sie auswählen, der Anzahl der Werte in Ihrer Konstante entspricht. Wenn die Konstante beispielsweise Daten in vier Spalten und drei Zeilen schreibt, markieren Sie diese Anzahl von Spalten und Zeilen.

  2. Geben Sie ein Gleichheitszeichen und die Konstante ein. Trennen Sie in diesem Fall die Werte in jeder Zeile durch Kommas, und verwenden Sie ein Semikolon am Ende jeder Zeile. Zum Beispiel:

    ={1.2.3.4;5.6.7.8;9.10.11.12}

  3. Drücken Sie STRG+UMSCHALT+EINGABETASTE, und:

    Eine zweidimensionale Matrixkonstante

    Dies ist eine zweidimensionale Konstante, da sie Spalten und Zeilen ausfüllt. Wenn Sie sich fragen, können Sie keine dreidimensionale Konstante erstellen, d. h., Sie können keine Konstante in eine andere schachteln.

Verwenden einer Konstante in einer Formel

Nachdem Sie nun mit Arraykonstante vertraut sind, ist hier ein funktionierendes Beispiel.

  • Geben Sie diese Formel in eine beliebige leere Zelle ein (oder kopieren sie, und fügen Sie sie ein), und drücken Sie dann STRG+UMSCHALT+EINGABETASTE:

    =SUMME(A1:E1*{1.2.3.4.5})

    In der Zelle A3 wird der Wert 85 angezeigt.

    Was ist geschehen? Sie haben den Wert in A1 mit 1, den Wert in Zelle B2 mit 2 multipliziert und so weiter, und dann hat die Funktion SUMME diese Ergebnisse addiert. Sie können die Formel auch als =SUMME(A1*1;B1*2;C1*3;D1*4;E1*5) eingeben.

Wenn Sie möchten, können Sie beide Wertegruppen als Arraykonstante eingeben:

=SUMME({3.4.5.6.7}*{1.2.3.4.5})

Um dies auszuprobieren, kopieren Sie die Formel, markieren Sie eine leere Zelle, fügen Sie sie in die Formelleiste ein, und drücken Sie dann STRG+UMSCHALT+EINGABETASTE. Sie sehen dasselbe Ergebnis.

Hinweise: Suchen Sie nach den folgenden Problemen, wenn die Konstanten nicht funktionieren:

  • Achten Sie darauf, die Werte durch das richtige Zeichen zu trennen. Wenn Sie ein Komma oder Semikolon weglassen oder an der falschen Stelle platzieren, sieht die Arraykonstante möglicherweise nicht richtig aus, oder es wird eine Warnmeldung angezeigt.

  • Möglicherweise haben Sie einen Zellbereich ausgewählt, der nicht der Anzahl der Elemente in Ihrer Konstante entspricht. Wenn Sie beispielsweise eine Spalte mit sechs Zellen zur Verwendung mit einer Fünf-Zellen-Konstante auswählen, wird #N/A-Fehler in der leeren Zelle angezeigt. Wenn Sie nicht genügend Zellen auswählen, lassen Excel die Werte aus, für die es keine entsprechende Zelle gibt.

  • Weitere Informationen zu Matrixformeln finden Sie unter:

Seitenanfang

Benötigen Sie weitere Hilfe?

Ihre Office-Fähigkeiten erweitern
Schulungen erkunden
Neue Funktionen als Erster erhalten
Microsoft Office Insidern beitreten

War diese Information hilfreich?

Wie zufrieden sind Sie mit der Sprachqualität?
Was hat Ihre Erfahrung beeinflusst?

Vielen Dank für Ihr Feedback!

×