Symptome
Wenn Sie eine Transaktionsreplikation einrichten und ein Transaktionsabonnement aus einer Sicherung in Microsoft SQL Server 2012 oder SQL Server 2014 initialisieren. Während der ersten Synchronisierung schlägt der Verteilungs-Agent fehl, und Sie erhalten die folgenden Fehler:
Hinweis
Herstellen einer Verbindung mit dem Abonnenten
Wird initialisiert
Es sind keine replizierten Transaktionen verfügbar.
42000 Could not found stored procedure 'sp_MSins_'. 2812
42000 Could not found stored procedure 'sp_MSins_'. 2812
Ursache
Dieses Problem wird durch einen unterschiedlichen Zeitablauf zwischen der anfänglichen Ausführung des Protokolllese-Agents und des Verteilungs-Agents verursacht. Wenn auf dem Herausgeber viele Transaktionsänderungen vorgenommen werden, kommt es zu einer Verzögerung beim Generieren und Hinzufügen der benutzerdefinierten Skripts für gespeicherte Prozeduren zu MSRepl_commands in der Verteilungsdatenbank. Wenn der Verteilungs-Agent gestartet wird und bereits einen Roundtrip zur Verteilungsdatenbank durchgeführt hat, bevor diese Befehle hinzugefügt werden, verschiebt er den Transaktionszeitstempel nach vorne und meldet "Keine replizierten Transaktionen verfügbar". Spätere Synchronisierungsversuche durch den Verteilungs-Agent können die Befehle zum Erstellen benutzerdefinierter gespeicherter Prozeduren nicht erkennen und schlagen mit den im Abschnitt "Problembeschreibung" genannten Fehlern fehl.
Lösung
Das Problem wurde erstmals im folgenden kumulativen Update von SQL Server behoben.
Kumulatives Update 1 für SQL Server 2014 /de-de/help/2931693
Kumulatives Update 9 für SQL Server 2012 SP1 /en-us/help/2931078
Informationen zu kumulativen Updates für SQL Server
Jedes neue kumulative Update für SQL Server enthält alle Hotfixes und Sicherheitsfixes, die im vorherigen kumulativen Update enthalten waren. Sehen Sie sich die neuesten kumulativen Updates für SQL Server an:
Status
Microsoft hat bestätigt, dass dies ein Problem bei den Microsoft-Produkten ist, die im Abschnitt „Gilt für“ aufgeführt sind.