Symptome
Angenommen, Sie haben mindestens eine Entität in Master Data Services (MDS) für Microsoft SQL Server 2012 oder SQL Server 2014 gelöscht. Wenn Sie versuchen, die Modellsicherheit für einige Gruppen oder Benutzer in MDS zu bearbeiten, wird die folgende Fehlermeldung angezeigt:
Hinweis
Ein unbekannter Fehler ist aufgetreten.
Hinweis Wenn Sie die MDS-Ablaufverfolgungsprotokollierung aktivieren und den Fehler reproduzieren, wird die folgende Fehlermeldung im Ablaufverfolgungsprotokoll gefunden:
Hinweis
Ein Element mit demselben Schlüssel wurde bereits hinzugefügt.
Ursache
Das Problem tritt auf, weil die Sicherheit auf Attributebene, die zur gelöschten Entität gehört, nicht entsprechend entfernt wird.
Lösung
Das Problem wurde erstmals im folgenden kumulativen Update von SQL Server behoben.
Kumulatives Update 1 für SQL Server 2014 SP1 /en-us/help/3067839
Kumulatives Update 6 für SQL Server 2014 /en-us/help/3031047
Kumulatives Update 4 für SQL Server 2012 SP2 /en-us/help/3007556
Kumulatives Update 13 für SQL Server 2012 SP1 /en-us/help/3002044
Informationen zu kumulativen Updates für SQL Server
Jedes neue kumulative Update für SQL Server enthält alle Hotfixes und Sicherheitsfixes, die im vorherigen kumulativen Update enthalten waren. Sehen Sie sich die neuesten kumulativen Updates für SQL Server an:
- Neuestes kumulatives Update für SQL Server 2014 SP1
- Neuestes kumulative Update für SQL Server 2014
- Neuestes kumulative Update für SQL Server 2012 SP2
- Neuestes kumulatives Update für SQL Server 2012 SP1
Problemumgehung
Um dieses Problem zu umgehen, entfernen Sie die entsprechende Sicherheit auf Attributebene, oder löschen Sie die Attribute, auf die in der Gruppensicherheit verwiesen wird. Löschen Sie dann das Objekt.
Status
Microsoft hat bestätigt, dass dies ein Problem bei den Microsoft-Produkten ist, die im Abschnitt „Gilt für“ aufgeführt sind.