KB4038634 – Kumulatives Update 1 für SQL Server 2017

Erscheinungsdatum: Montag, 24. Oktober 2017
Version: 14.0.3006.16

Zusammenfassung

Dieser Artikel beschreibt das kumulative Update-Paket 1 (CU1) für Microsoft SQL Server 2017. Dieses Update enthält 71 Korrekturen, die nach der Veröffentlichung von SQL Server 2017 RTM veröffentlicht wurden, und aktualisiert Komponenten in den folgenden Builds:

  • SQL Server – Produktversion: 14.0.3006.16, Dateiversion: 2017.140.3006.16
  • Analysis Services – Produktversion: 14.0.1.439, Dateiversion: 2017.140.1.439

Bekannte Probleme bei diesem Update

In diesem kumulativen Update sind keine Probleme bekannt.

Verbesserungen und Fehlerbehebungen im Update

Eine herunterladbare Excel-Arbeitsmappe, die eine Zusammenfassungsliste der Builds zusammen mit dem aktuellen Supportlebenszyklus enthält, ist verfügbar. Die Excel-Datei enthält ebenfalls detaillierte Korrekturlisten für SQL Server 2019 und SQL Server 2017. Wählen Sie diese Option aus, um diese Excel-Datei jetzt herunterzuladen.

Hinweis

Auf einzelne Einträge in der folgenden Tabelle kann direkt über ein Lesezeichen verwiesen werden. Wenn Sie eine Fehlerreferenz-ID in der Tabelle auswählen, wird der URL ein Lesezeichen-Tag hinzugefügt, indem Sie das Format "#NNNNNNNN" verwenden. Sie können diese URL dann für andere Personen freigeben, damit sie direkt zum gewünschten Fix in der Tabelle springen können.

Sie finden weitere Informationen zu den behobenen Fehlern und den Verbesserungen, welche in diesem kumulativen Update enthalten sind, in den folgenden Knowledge Base-Artikeln.

Fehlerreferenz Beschreibung Fixierungsbereich Komponente Plattform
10682349 BEHEBUNG: SSAS stürzt ab, wenn Sie in SQL Server 2017 und SQL Server 2016 (KB4024023) auf VMP-Dateien zugreifen Analysis Services Analysis Services Alle
10682367 BEHEBUNG: SSAS stürzt ab, wenn Sie eine DAX- oder MDX-Abfrage in SSAS im tabellarischen Modus (KB4032543) ausführen Analysis Services Analysis Services Alle
10687745 FIX: Dimensionssicherheit wird von Power BI Desktop in SQL Server Analysis Services ignoriert (mehrdimensionales Modell) (KB4018908) Analysis Services Analysis Services Alle
10687757 BEHEBUNG: SSAS stürzt ab, wenn Sie eine MDX-Abfrage ausführen, die auf ein berechnetes Element verweist, das ein untergeordnetes Mitglied einer anderen Hierarchie ist (KB4022753) Analysis Services Analysis Services Alle
10687784 BEHEBUNG: Das Sicherheitsbulletin MS16-136 unterbricht den SSRS-Datenquellentyp in PowerPivot in SQL Server 2017 und SQL Server 2016 (KB4025402) Analysis Services Analysis Services Alle
10868739 BEHEBUNG: SSAS stürzt ab, wenn Sie eine SSAS-Datenbank oder einen SSAS-Cube in SQL Server 2014 oder 2017 (KB4039509) verarbeiten Analysis Services Analysis Services Windows
10868754 FIX: Beim Ausführen von Prozessaktualisierungsvorgängen in SSAS (KB4033789) kann ein Speicherverlust auftreten Analysis Services Analysis Services Windows
10868777 BEHEBUNG: SQL Server 2016 oder 2017 können Analysis Services in einer bestimmten Situation abstürzen (KB3208545) Analysis Services Analysis Services Windows
10965958 FIX: Ein unerwarteter Ausnahmefehler tritt auf, wenn eine XINTZ-Kennzahl zu viele Datensätze in SSAS 2016 oder 2017 (KB4034789) verarbeitet Analysis Services Analysis Services Windows
10965991 UPDATE: Fehler "Mehrdeutige Pfade" beim Bereitstellen der tabellarischen Modelldatenbank für Analysis Services in SQL Server 2016 oder 2017 (KB4040085) Analysis Services Analysis Services Windows
10682338 FIX: Falsche MDX-Abfrageergebnisse, wenn eine tabellenübergreifende Verknüpfung für ein Tabellenhierarchiemitglied in SSAS (KB4022594) ausgeführt wird Analysis Services Analysis Services Alle
10682343 BEHEBUNG: SSAS stürzt ab, wenn ein Measure hinzugefügt wird, das auf Nullwerte in Power BI verweist (KB4021994) Analysis Services Analysis Services Alle
10682356 FIX: SSAS stürzt ab, wenn eine numerisch berechnete Spalte ihr Kodierungsschema während der ProcessRecalc Phase ändern muss (KB3212541) Analysis Services Analysis Services Alle
10868755 FIX: Beim Exportieren eines Reporting Services Berichts in PDF in SQL Server 2017 (KB4040512) tritt ein Fehler auf Analysis Services Reporting Services Alle
10965982 BEHEBUNG: Speicherspitze in LSASS.EXE beim Aktivieren des Standardauthentifizierungsmodus in SSRS 2016 oder 2017 (KB4039124) Analysis Services Reporting Services Windows
10965994 FIX: Fehler beim Exportieren eines SSRS-Berichts auf einem iOS-Gerät in SQL Server 2016 oder 2017 (KB4043478) Analysis Services Reporting Services Windows
10965998 FIX: Horizontale Bildlaufleiste fehlt auf der Abonnementseite im Webportal von SSRS 2016 oder 2017 (KB4039126) Analysis Services Reporting Services Windows
10965999 FIX: "Der Ordner ... Fehlermeldung "nicht vorhanden" beim Löschen eines Ordners im Webportal des SQL Server 2017 Reporting Service (KB4039125) Analysis Services Reporting Services Windows
10966008 FIX: Das Berichts-Viewer-Webpart lässt keine vollständige vertikale Bildlaufleiste zu, nachdem Sie eine bestimmte Webparthöhe (KB4039058) festgelegt haben Analysis Services Reporting Services Windows
10729322 FIX: Reporting Services "SortExpression" wird verursachtrsComparisonError, wenn ein NULL Wert in einer Spalte vorhanden ist, der als "DataTimeOffset" (KB4017827) festgelegt ist Analysis Services Reporting Services Windows
10868736 FIX: Fehler beim Exportieren einer DQS-Wissensdatenbank, die Domänen im DQS-Client in SQL Server 2014 oder 2017 enthält (KB4022483) Dienst für Datenqualität Import-Export Windows
10966015 FIX: SSIS-Pakete, die deutsche Umlaute enthalten, schlagen nach der inkrementellen Paketbereitstellung im SQL Server 2016 oder 2017 (KB4038590) bei der Ausführung fehl Integration Services Tools Windows
10867556 FIX: Excel stürzt ab, wenn Sie eine Arbeitsmappe als PDF-Datei mit dem Adobe Acrobat PDFMaker-Add-In speichern, wenn das MDS-Add-In für Excel in SQL Server ebenfalls installiert ist (KB4022895) Master Data Services Client Windows
10687776 UPDATE: Das Erweitern des Ordners "Entitäten" auf der Seite "Gruppen verwalten" dauert in MDS von SQL Server 2017 und MDS von SQL Server 2016 (KB4023865) sehr lange. Master Data Services Server Alle
10682313 FIX: Das Laden von Daten aus Stagingtabellen dauert wesentlich länger, wenn die rekursive Hierarchie in Master Data Services verwendet wird (KB4043103) Master Data Services Server Alle
10986691 FIX: Ein unerwarteter Fehler tritt auf, wenn Sie die DReplay-Funktion verwenden, um eine erfasste Ablaufverfolgung in SQL Server 2017 (KB4045678) wiederzugeben SQL Server-Clienttools Tools für Datenbankleistung Windows
10270905 FIX: Backup der Verfügbarkeitsdatenbank über VSS-basierte Anwendung kann in SQL Server fehlschlagen (KB4040108) SQL Server-Engine Sicherungswiederherstellung Alle
10868723 FIX: SQL Server Managed Backup löscht keine alten Backups, bei denen der Aufbewahrungszeitraum in SQL Server 2014 oder 2017 (KB4038882) überschritten wurde. SQL Server-Engine Sicherungswiederherstellung Windows
10868726 FIX: Managed Backup schlägt zeitweise aufgrund eines SQLVDI-Fehlers in SQL Server 2014 oder 2017 fehl (KB4039511) SQL Server-Engine Sicherungswiederherstellung Windows
10868733 FIX: Managed Backup auf Microsoft Azure wird nach umfangreicher Datenbanksicherung in SQL Server 2014 oder 2017 (KB4040376) beendet SQL Server-Engine Sicherungswiederherstellung Windows
10966001 FIX: Einschränkungsverletzungsfehler, der von der Funktion managed_backup.fn_available_backups nach der Installation des kumulativen Updates 2 für SQL Server 2016 SP1 (KB4040531) zurückgegeben wird SQL Server-Engine Sicherungswiederherstellung Windows
10966019 FIX: SQL Server verwalteten Sicherungen führen in SQL Server 2016 oder 2017 (KB4040535) keine geplante Protokollsicherung aus SQL Server-Engine Sicherungswiederherstellung Windows
10965952 Update zur Verbesserung der Leistung für die dynamischen Columnstore-Verwaltungsansichten "column_store_row_groups" und "dm_db_column_store_row_group_physical_stats" in SQL Server 2016 oder 2017 (KB4024860) SQL Server-Engine Column Stores Alle
10936099 Update, damit SQL Server 2017 Express Edition als Zeuge in einer Datenbankspiegelungssitzung (KB4045687) fungieren kann SQL Server-Engine Hochverfügbarkeit und Notfallwiederherstellung Windows
10921835 FIX: Arbeitsspeicherbeschädigung tritt bei Verfügbarkeitsgruppen-Failovers für DTC-Transaktionen im SQL Server 2017 (KB4046065) auf SQL Server-Engine Hochverfügbarkeit und Notfallwiederherstellung Windows
10936097 BEHEBUNG: SQL Server 2017 meldet, dass alle Transaktionen abgeschlossen werden, obwohl bei einigen Transaktionen beim Ausführen des Commits Fehler auftreten (KB4046066) SQL Server-Engine Hochverfügbarkeit und Notfallwiederherstellung Windows
10965980 FIX: Failover der Datenbankspiegelung schlägt mit Fehler 3456 in SQL Server 2016 oder 2017 (KB4042251) fehl SQL Server-Engine Hochverfügbarkeit und Notfallwiederherstellung Windows
10965988 FIX: Automatisches Seeding in Verfügbarkeitsgruppen verursacht im SQL Server 2016 oder 2017 (KB4040519) zufällig den Fehler 41169 SQL Server-Engine Hochverfügbarkeit und Notfallwiederherstellung Alle
10936183 FIX: Leistungsabfall bei Verwendung von In-Memory OLTP mit Always On Verfügbarkeitsgruppen in SQL Server 2016 oder 2017 (KB4039868) SQL Server-Engine In-Memory-OLTP Windows
10936185 FIX: Falsches Verhalten bei der Verwendung von speicheroptimierten Tabellen mit "where exists"-Anweisung in SQL Server 2016 oder 2017 (KB4039776) SQL Server-Engine In-Memory-OLTP Windows
10985578 FIX: Fehler beim Übergeben einer speicheroptimierten Tabelle in eine Inline-Tabellenwertfunktion, wenn diese von einer gespeicherten Prozedur in SQL Server 2017 (KB4045329) aufgerufen wird SQL Server-Engine In-Memory-OLTP Windows
11000432 FIX: Ein Assertionsfehler tritt innerhalb von Minuten oder Stunden nach dem Erstellen einer Momentaufnahme Sicherung für eine Datenbank auf, die speicheroptimierte Tabellen in SQL Server 2017 enthält (KB4046099) SQL Server-Engine In-Memory-OLTP Windows
10749795 FIX: Portabilität und Leistung unterscheiden sich zwischen Windows- und Linux Scheduler-Zuordnungen in SQL Server 2017 (KB4043455) SQL Server-Engine Linux Linux
11080104 FIX: Sommerzeitänderungen der Zeitzone von São Paulo werden nicht durch SQL Server 2017 am Linux (KB4052938) bestimmt SQL Server-Engine Linux Linux
10966010 FIX: Protokollkettenbruch in der Tabelle "managed_backup.fn_available_backups" in SQL Server 2016 oder 2017 (KB4040530) SQL Server-Engine Verwaltungsdienste Windows
10936563 FIX: EXCEPTION_ACCESS_VIOLATION Fehler beim Ausführen der sys.sp_MScdc_capture_job gespeicherten Prozedur in SQL Server (KB4039089) SQL Server-Engine Metadaten Alle
10938809 FIX: Beim Erstellen einer neuen Datenbank in SQL Server 2017 (KB4044009) tritt eine Deadlock-Bedingung auf SQL Server-Engine Metadaten Windows
10070694 FIX: Abfragen für externe PolyBase-Tabellen geben doppelte Zeilen in SQL Server 2017 und SQL Server 2016 (KB4019840) zurück SQL Server-Engine PolyBase Alle
10965984 FIX: Zugriffsverletzung tritt auf, wenn ein DDL-Trigger durch den Befehl CREATE EXTERNAL TABLE in SQL Server 2016 oder 2017 (KB4039966) ausgelöst wird SQL Server-Engine PolyBase Windows
10965968 FIX: Gibt falsche Ergebnisse zurück, wenn die berechnete Spalte abgefragt wird, nachdem der in KB 3213683 beschriebene Hotfix installiert und TF 176 in SQL Server 2016 oder 2017 (KB4040533) aktiviert wurde. SQL Server-Engine Programmier-barkeit Alle
10966016 FIX: Das SSIS-Paket wird nicht gestartet, wenn es von einer gespeicherten CLR-Prozedur ausgeführt wird, deren Benutzer nicht über SYSADMIN-Berechtigungen (KB4039736) verfügt SQL Server-Engine Programmier-barkeit Windows
10867554 FIX: Remote-instance von SQL Server stürzt ab, wenn eine gespeicherte Prozedur ausgeführt wird, die eine unvollständige Datendatei massenweise in eine temporäre Tabelle (KB4043459) lädt SQL Server-Engine Programmier-barkeit Windows
10966009 BEHEBUNG: EXCEPTION_ACCESS_VIOLATION für Abfragen mit sys.dm_os_memory_objects-Anweisung in SQL Server 2016 oder 2017 (KB4038113) SQL Server-Engine Abfrageausführung Windows
9704947 Verbesserung: Den CREATE- und UPDATE-STATISTIK-Anweisungen wurde ein neues Schlüsselwort (keyword) hinzugefügt, um die Samplingrate für zukünftige Statistikaktualisierungen in SQL Server (KB4039284) beizubehalten SQL Server-Engine Abfrageoptimierer Alle
10889338 FIX: Ein Divide-by-Zero-Fehler tritt auf, wenn eine parallele Abfrage im seriellen Modus in SQL Server 2017 (KB4042885) ausgeführt werden muss SQL Server-Engine Abfrageoptimierer Windows
11003299 BEHEBUNG: FORCE_LAST_GOOD_PLAN Empfehlung bleibt bei der ersten Überprüfung in SQL Server 2017 (KB4046055) im Status "Verifizierung" hängen SQL Server-Engine Abfragespeicher Windows
11003402 FIX: Automatische Optimierungseinstellungen können in ModelDB in SQL Server 2017 (KB4046022) nicht konfiguriert werden SQL Server-Engine Abfragespeicher Windows
10691456 FIX: Artikel zur Ausführung gespeicherter Prozeduren kann nicht aus der P2P-Veröffentlichung in SQL Server (KB4023926) gelöscht werden SQL Server-Engine Replikation Windows
10691460 FIX: "Change Data Capture" kann nicht deaktiviert werden, wenn eine Spalte durch das Feature "Always Encrypted" in SQL Server (KB4034376) verschlüsselt ist. SQL Server-Engine Replikation Alle
10978904 FIX: Änderungsnachverfolgung SQL Server 2014 und 2017 (KB4043624) schlägt die manuelle Bereinigung mit dem Fehler "Tabelle nicht vorhanden" fehl SQL Server-Engine Replikation Alle
10687780 FIX: Eine Datenmaske für eine Gleitkommaspalte wird in SQL Server 2017 und SQL Server 2016 (KB4023995) nicht angewendet. SQL Server-Engine Sicherheitsinfrastruktur Alle
10867553 FIX: SUSER_SNAME Funktion gibt unterschiedliche Ergebnisse zwischen SQL Server 2014 und SQL Server 2016 oder 2017 zurück (KB4025020) SQL Server-Engine Sicherheitsinfrastruktur Windows
10982548 FIX: Die Ausführung schlägt fehl, wenn eine SQL-CLR-Funktion Transact-SQL-Anweisungen über Identitätswechselaufrufe in SQL Server 2017 (KB4046918) aufruft. SQL Server-Engine Sicherheitsinfrastruktur Alle
10868749 FIX: Zugriffsverletzung für die Abfrage räumlicher Datentypen über verknüpften Server in SQL Server 2014 oder 2017 (KB4040401) SQL Server-Engine SQL-Betriebssystem Windows
11008122 Update ermöglicht die neuen dynamischen Verwaltungsansichten und -funktionen in SQL Server 2017 (KB4046638) SQL Server-Engine Speicherverwaltung Windows
10870647 BEHEBUNG: Eine Partition der partitionierten Tabelle konnte nicht abgeschnitten werden, wenn sie einen erweiterten oder XML-Index in SQL Server 2016 oder 2017 enthielt (KB4024622) SQL Server-Engine Table Index Partition Windows
10998915 FIX: DML-Anweisungen, die kaskadierende Vorgänge verwenden, schlagen in SQL Server 2017 fehl (KB4046744) SQL Server-Engine Zeitlich Windows
10865727 FIX: Assertionsfehler tritt auf dem sekundären Replikat auf, wenn Sie eine ausgesetzte Verfügbarkeitsdatenbank in SQL Server 2016 oder 2017 (KB4024393) fortsetzen SQL Server-Engine Transaktionsdienste Windows
10936411 FIX: Indirekte Prüfpunkte in der tempdb-Datenbank verursachen in SQL Server 2016 oder 2017 (KB4040276) den Fehler "Planer ohne Ergebnis" SQL Server-Engine Transaktionsdienste Windows
10868768 FIX: Zugriffsverletzung tritt auf, wenn Sie sp_xml_preparedocument zum Öffnen von XML-Dokumenten in SQL Server 2014 oder 2017 (KB4039510) verwenden SQL Server-Engine XML Windows
10998673 FIX: SQL Server 2017 kann nicht installiert werden, wenn instance Name/ID/Installationspfad Multibyte-Zeichen (KB4046044) enthält SQL-Setup Bereitstellungsplattform Windows

Abrufen oder Herunterladen dieses oder des neuesten kumulativen Updatepakets

Abrufen oder Herunterladen des neuesten kumulativen Updatepakets für Windows (empfohlen)

Das folgende Update steht im Microsoft Download Center zur Verfügung:

Laden Sie jetzt das aktuelle kumulative Updatepaket für SQL Server 2017 herunter

Falls die Downloadseite nicht angezeigt wird, wenden Sie sich an den Microsoft-Kundendienst und -Support, um das kumulative Updatepaket zu erhalten.

Abrufen oder Herunterladen dieses kumulativen Updatepakets für Windows aus dem Microsoft Update-Katalog

Hinweis

Nachdem weitere kumulative Updates für SQL Server 2017 veröffentlicht wurden, können Sie diese und alle folgenden CUs im Windows Update-Katalog finden und herunterladen. Microsoft empfiehlt aber jeweils die Installation des aktuellen kumulativen Updates.

Das folgende Update ist im Microsoft Update-Katalog verfügbar:

Kumulatives Updatepaket für SQL Server 2017 CU1 jetzt herunterladen

Abrufen oder Herunterladen des neuesten kumulativen Updatepakets für Linux

Um SQL Server 2017 unter Linux auf die neueste CU zu aktualisieren, müssen Sie zunächst das Repository für das kumulative Update konfigurieren. Aktualisieren Sie dann Ihre SQL Server-Pakete mithilfe des entsprechenden plattformspezifischen Updatebefehls.

Installationsanweisungen und direkte Links zu den CU-Paket-Downloads finden Sie in den SQL Server 2017 Release Notes.

Dateiinformationen

Dateihashinformationen

Sie können den Download überprüfen, indem Sie den Hash der SQLServer2017-KB4038634-x64.exe Datei berechnen, indem Sie den folgenden Befehl verwenden:

certutil -hashfile SQLServer2017-KB4038634-x64.exe SHA256

Dateiname SHA256-Hash
SQLServer2017-KB4038634-x64.exe C1187BF68AC07294D8242C4126F021D3BEEF561F86931A8229B3D4AE86993A73
Informationen zur Datei mit dem kumulativen Updatepaket

Die englische Version dieses Pakets weist die in der nachstehenden Tabelle aufgelisteten Dateiattribute (oder nachfolgende Dateiattribute) auf. Datums- und Uhrzeitangaben für diese Dateien sind in der "Universal Time Coordinated" (UTC) angegeben. Wenn Sie die Dateiinformationen anzeigen, werden diese in die Ortszeit umgewandelt. Den Unterschied zwischen UTC- und Ortszeit können Sie in der Systemsteuerung unter Datum und Uhrzeit mithilfe der Angaben auf der Registerkarte Zeitzone ermitteln.

x64-basierte Versionen

SQL Server 2017 Analysis Services

Dateiname Dateiversion Dateigröße Datum Uhrzeit Plattform
Microsoft.analysisservices.server.core.dll 14.0.1.439 1380512 01-Okt-17 2,206 x86
Microsoft.data.mashup.dll 2.49.4831.201 174816 01-Okt-17 20:52 x86
Microsoft.data.mashup.oledb.dll 2.49.4831.201 36576 01-Okt-17 20:52 x86
Microsoft.data.mashup.preview.dll 2.49.4831.201 48864 01-Okt-17 20:52 x86
Microsoft.data.mashup.providercommon.dll 2.49.4831.201 105184 01-Okt-17 20:52 x86
Microsoft.hostintegration.connectors.dll 2.49.4831.201 5167328 01-Okt-17 20:52 x86
Microsoft.mashup.container.exe 2.49.4831.201 26336 01-Okt-17 20:52 x64
Microsoft.mashup.container.netfx40.exe 2.49.4831.201 26848 01-Okt-17 20:52 x64
Microsoft.mashup.container.netfx45.exe 2.49.4831.201 26848 19-Okt-17 12:13 x64
Microsoft.mashup.eventsource.dll 2.49.4831.201 159456 01-Okt-17 20:52 x86
Microsoft.mashup.oauth.dll 2.49.4831.201 82656 01-Okt-17 20:52 x86
Microsoft.mashup.oledbprovider.dll 2.49.4831.201 67296 19-Okt-17 12:13 x86
Microsoft.mashup.shims.dll 2.49.4831.201 25824 01-Okt-17 20:52 x86
Microsoft.mashup.storage.xmlserializers.dll 1,000 151264 01-Okt-17 20:52 x86
Microsoft.mashupengine.dll 2.49.4831.201 13032160 01-Okt-17 20:52 x86
Microsoft.powerbi.adomdclient.dll 14.0.1.484 1044672 01-Okt-17 20:52 x86
msmdlocal.dll 2017.140.1.439 40357024 01-Okt-17 2,206 x86
msmdlocal.dll 2017.140.1.439 59898528 19-Okt-17 1,222 x64
Msmdpump.dll 2017.140.1.439 8544416 19-Okt-17 1,222 x64
Msmdsrv.exe 2017.140.1.439 60589352 01-Okt-17 22:07 x64
msmgdsrv.dll 2017.140.1.439 8208544 01-Okt-17 22:07 x64
msmgdsrv.dll 2017.140.1.439 7310496 19-Okt-17 1,215 x86
Powerbiextensions.dll 2.49.4831.201 5316832 01-Okt-17 20:52 x64
Sql_as_keyfile.dll 2017.140.3006.16 100512 19-Okt-17 19:12 x64
Sqlboot.dll 2017.140.3006.16 194720 19-Okt-17 11:08 x64
Sqlceip.exe 14.0.3006.16 249504 19-Okt-17 1,218 x86

SQL Server 2017-Datenbankdienste – Common Core

Dateiname Dateiversion Dateigröße Datum Uhrzeit Plattform
Microsoft.analysisservices.adomdclient.dll 14.0.1.439 1088672 01-Okt-17 22:04 x86
Microsoft.analysisservices.adomdclient.dll 14.0.1.439 1088672 01-Okt-17 2,206 x86
Microsoft.analysisservices.core.dll 14.0.1.439 1380648 01-Okt-17 22:04 x86
Microsoft.analysisservices.xmla.dll 14.0.1.439 741536 01-Okt-17 22:04 x86
Microsoft.analysisservices.xmla.dll 14.0.1.439 741536 01-Okt-17 2,206 x86
Pbsvcacctsync.dll 2017.140.3006.16 66720 19-Okt-17 19:12 x86
Pbsvcacctsync.dll 2017.140.3006.16 80544 19-Okt-17 1,222 x64
Sql_common_core_keyfile.dll 2017.140.3006.16 100512 19-Okt-17 19:12 x64
Sqlftacct.dll 2017.140.3006.16 53920 19-Okt-17 09:11 x86
Sqlftacct.dll 2017.140.3006.16 61088 19-Okt-17 1,222 x64
Sqlmgmprovider.dll 2017.140.3006.16 371864 19-Okt-17 1,215 x86
Sqlmgmprovider.dll 2017.140.3006.16 414880 19-Okt-17 12:21 x64

SQL Server 2017-Datenbankdienste – Core Instance

Dateiname Dateiversion Dateigröße Datum Uhrzeit Plattform
Datacollectorcontroller.dll 2017.140.3006.16 224928 19-Okt-17 11:08 x64
Fssres.dll 2017.140.3006.16 88224 19-Okt-17 12:21 x64
Hadrres.dll 2017.140.3006.16 186528 19-Okt-17 12:21 x64
Hkcompile.dll 2017.140.3006.16 1421472 19-Okt-17 11:08 x64
Hkengine.dll 2017.140.3006.16 5858464 19-Okt-17 11:08 x64
Hkruntime.dll 2017.140.3006.16 161952 19-Okt-17 12:21 x64
Microsoft.analysisservices.applocal.xmla.dll 14.0.1.439 740136 19-Okt-17 1,220 x86
Microsoft.sqlautoadmin.autobackupagent.dll 14.0.3006.16 237216 19-Okt-17 1,220 x86
Microsoft.sqlautoadmin.sqlautoadmin.dll 14.0.3006.16 79520 19-Okt-17 12:09 x86
Microsoft.sqlserver.xevent.linq.dll 2017.140.3006.16 303776 19-Okt-17 11:02 x64
Qds.dll 2017.140.3006.16 1164448 19-Okt-17 14:38 x64
Sqagtres.dll 2017.140.3006.16 72864 19-Okt-17 1,222 x64
Sql_engine_core_inst_keyfile.dll 2017.140.3006.16 100512 19-Okt-17 19:12 x64
Sqlaccess.dll 2017.140.3006.16 474784 19-Okt-17 11:08 x64
Sqlagent.exe 2017.140.3006.16 578720 19-Okt-17 12:21 x64
Sqlagentctr140.dll 2017.140.3006.16 60576 19-Okt-17 11:08 x64
Sqlagentctr140.dll 2017.140.3006.16 51872 19-Okt-17 1,215 x86
Sqlboot.dll 2017.140.3006.16 194720 19-Okt-17 11:08 x64
Sqlceip.exe 14.0.3006.16 249504 19-Okt-17 1,218 x86
Sqlcmdss.dll 2017.140.3006.16 71840 19-Okt-17 12:21 x64
Sqldk.dll 2017.140.3006.16 2789024 19-Okt-17 14:38 x64
Sqlevn70.rll 2017.140.3006.16 3288224 19-Okt-17 11:00 x64
Sqlevn70.rll 2017.140.3006.16 3587232 19-Okt-17 11:00 x64
Sqlevn70.rll 2017.140.3006.16 1441440 19-Okt-17 11:00 x64
Sqlevn70.rll 2017.140.3006.16 2084512 19-Okt-17 11:00 x64
Sqlevn70.rll 2017.140.3006.16 3205792 19-Okt-17 11:01 x64
Sqlevn70.rll 2017.140.3006.16 3329696 19-Okt-17 11:01 x64
Sqlevn70.rll 2017.140.3006.16 3769504 19-Okt-17 11:01 x64
Sqlevn70.rll 2017.140.3006.16 3907232 19-Okt-17 11:01 x64
Sqlevn70.rll 2017.140.3006.16 3904160 19-Okt-17 11:02 x64
Sqlevn70.rll 2017.140.3006.16 2031264 19-Okt-17 11:02 x64
Sqlevn70.rll 2017.140.3006.16 4015264 19-Okt-17 11:02 x64
Sqlevn70.rll 2017.140.3006.16 3472032 19-Okt-17 1,103 x64
Sqlevn70.rll 2017.140.3006.16 3776672 19-Okt-17 1,103 x64
Sqlevn70.rll 2017.140.3006.16 3358368 19-Okt-17 1,103 x64
Sqlevn70.rll 2017.140.3006.16 3282592 19-Okt-17 11:04 x64
Sqlevn70.rll 2017.140.3006.16 3625632 19-Okt-17 11:04 x64
Sqlevn70.rll 2017.140.3006.16 3393184 19-Okt-17 11:04 x64
Sqlevn70.rll 2017.140.3006.16 3579032 19-Okt-17 11:04 x64
Sqlevn70.rll 2017.140.3006.16 3666592 19-Okt-17 1,105 x64
Sqlevn70.rll 2017.140.3006.16 1494176 19-Okt-17 1,105 x64
Sqlevn70.rll 2017.140.3006.16 3810976 19-Okt-17 11:06 x64
Sqlevn70.rll 2017.140.3006.16 3775136 19-Okt-17 11:07 x64
Sqllang.dll 2017.140.3006.16 41170080 19-Okt-17 14:57 x64
Sqlmin.dll 2017.140.3006.16 40221344 19-Okt-17 1,450 x64
Sqlolapss.dll 2017.140.3006.16 106656 19-Okt-17 11:08 x64
Sqlos.dll 2017.140.3006.16 26272 19-Okt-17 1,103 x64
Sqlpowershellss.dll 2017.140.3006.16 66720 19-Okt-17 12:21 x64
Sqlrepss.dll 2017.140.3006.16 63136 19-Okt-17 12:21 x64
Sqlscm.dll 2017.140.3006.16 69280 19-Okt-17 11:08 x64
Sqlscriptdowngrade.dll 2017.140.3006.16 27800 19-Okt-17 11:08 x64
Sqlscriptupgrade.dll 2017.140.3006.16 5871264 19-Okt-17 09:52 x64
Sqlservr.exe 2017.140.3006.16 485024 19-Okt-17 14:38 x64
Sqlsvc.dll 2017.140.3006.16 160416 19-Okt-17 12:21 x64
Sqltses.dll 2017.140.3006.16 9536160 19-Okt-17 14:38 x64
Sqsrvres.dll 2017.140.3006.16 259744 19-Okt-17 1,222 x64
Svl.dll 2017.140.3006.16 153760 19-Okt-17 1,222 x64
Xpadsi.exe 2017.140.3006.16 88224 19-Okt-17 12:21 x64
Xplog70.dll 2017.140.3006.16 74400 19-Okt-17 1,222 x64
Xpsqlbot.dll 2017.140.3006.16 32416 19-Okt-17 1,222 x64
Xpstar.dll 2017.140.3006.16 436384 19-Okt-17 12:21 x64

SQL Server 2017-Datenbankdienste – Core Shared

Dateiname Dateiversion Dateigröße Datum Uhrzeit Plattform
Dts.dll 2017.140.3006.16 2996896 19-Okt-17 19:12 x64
Dtsconn.dll 2017.140.3006.16 495264 19-Okt-17 19:12 x64
Dtshost.exe 2017.140.3006.16 103072 19-Okt-17 12:21 x64
Dtspipeline.dll 2017.140.3006.16 1264288 19-Okt-17 19:12 x64
Dtutil.exe 2017.140.3006.16 145568 19-Okt-17 19:12 x64
Microsoft.analysisservices.applocal.core.dll 14.0.1.439 1381536 01-Okt-17 2,206 x86
Msxmlsql.dll 2017.140.3006.16 1450656 19-Okt-17 11:08 x64
Sql_engine_core_shared_keyfile.dll 2017.140.3006.16 100512 19-Okt-17 19:12 x64
Sqlscm.dll 2017.140.3006.16 59544 19-Okt-17 11:01 x86
Sqlscm.dll 2017.140.3006.16 69280 19-Okt-17 11:08 x64
Sqlsvc.dll 2017.140.3006.16 133280 19-Okt-17 11:01 x86
Sqlsvc.dll 2017.140.3006.16 160416 19-Okt-17 12:21 x64

SQL Server 2017 sql_extensibility

Dateiname Dateiversion Dateigröße Datum Uhrzeit Plattform
Launchpad.exe 2017.140.3006.16 1121440 19-Okt-17 12:21 x64
Sql_extensibility_keyfile.dll 2017.140.3006.16 100512 19-Okt-17 19:12 x64
Sqlsatellite.dll 2017.140.3006.16 918688 19-Okt-17 1,222 x64

SQL Server 2017 Full-Text Engine

Dateiname Dateiversion Dateigröße Datum Uhrzeit Plattform
Fd.dll 2017.140.3006.16 665760 19-Okt-17 11:08 x64
Fdhost.exe 2017.140.3006.16 113312 19-Okt-17 12:21 x64
Fdlauncher.exe 2017.140.3006.16 61600 19-Okt-17 11:08 x64
Sql_fulltext_keyfile.dll 2017.140.3006.16 100512 19-Okt-17 19:12 x64
Sqlft140ph.dll 2017.140.3006.16 66208 19-Okt-17 11:08 x64

SQL Server 2017 sql_inst_mr

Dateiname Dateiversion Dateigröße Datum Uhrzeit Plattform
Imrdll.dll 14.0.3006.16 23712 19-Okt-17 11:08 x86
Sql_inst_mr_keyfile.dll 2017.140.3006.16 100512 19-Okt-17 19:12 x64

SQL Server 2017 Integration Services

Dateiname Dateiversion Dateigröße Datum Uhrzeit Plattform
Attunity.sqlserver.cdccontroltask.dll 5.0.0.70 75248 15. September 17 06:38 x86
Attunity.sqlserver.cdcsplit.dll 5.0.0.70 36336 15. September 17 06:38 x86
Attunity.sqlserver.cdcsrc.dll 5.0.0.70 76272 19-Okt-17 1,210 x86
Dts.dll 2017.140.3006.16 2548384 19-Okt-17 11:01 x86
Dts.dll 2017.140.3006.16 2996896 19-Okt-17 19:12 x64
Dtsconn.dll 2017.140.3006.16 397984 19-Okt-17 11:01 x86
Dtsconn.dll 2017.140.3006.16 495264 19-Okt-17 19:12 x64
Dtshost.exe 2017.140.3006.16 88224 19-Okt-17 1,215 x86
Dtshost.exe 2017.140.3006.16 103072 19-Okt-17 12:21 x64
Dtspipeline.dll 2017.140.3006.16 1057440 19-Okt-17 1,210 x86
Dtspipeline.dll 2017.140.3006.16 1264288 19-Okt-17 19:12 x64
Dtutil.exe 2017.140.3006.16 125088 19-Okt-17 11:01 x86
Dtutil.exe 2017.140.3006.16 145568 19-Okt-17 19:12 x64
Isdeploymentwizard.exe 14.0.3006.16 477344 19-Okt-17 12:58 x86
Isdeploymentwizard.exe 14.0.3006.16 476832 19-Okt-17 1,308 x64
Microsoft.analysisservices.applocal.core.dll 14.0.1.439 1381536 01-Okt-17 22:04 x86
Microsoft.analysisservices.applocal.core.dll 14.0.1.439 1381536 01-Okt-17 2,206 x86
Microsoft.sqlserver.integrationservices.isserverdbupgrade.dll 14.0.3006.16 493728 19-Okt-17 09:51 x86
Microsoft.sqlserver.integrationservices.isserverdbupgrade.dll 14.0.3006.16 493728 19-Okt-17 11:08 x86
Microsoft.sqlserver.integrationservices.server.dll 14.0.3006.16 83616 19-Okt-17 1,215 x86
Microsoft.sqlserver.integrationservices.server.dll 14.0.3006.16 83616 19-Okt-17 1,220 x86
Microsoft.sqlserver.integrationservices.wizard.common.dll 14.0.3006.16 415392 19-Okt-17 12:42 x86
Microsoft.sqlserver.integrationservices.wizard.common.dll 14.0.3006.16 415392 19-Okt-17 1,259 x86
Msdtssrvr.exe 14.0.3006.16 219808 19-Okt-17 12:21 x64
Sql_is_keyfile.dll 2017.140.3006.16 100512 19-Okt-17 19:12 x64
Sqlceip.exe 14.0.3006.16 249504 19-Okt-17 1,218 x86

SQL Server 2017 sql_polybase_core_inst

Dateiname Dateiversion Dateigröße Datum Uhrzeit Plattform
Sqlevn70.rll 2017.140.3006.16 1494176 19-Okt-17 1,105 x64
Sqlevn70.rll 2017.140.3006.16 3904160 19-Okt-17 11:02 x64
Sqlevn70.rll 2017.140.3006.16 3205792 19-Okt-17 11:01 x64
Sqlevn70.rll 2017.140.3006.16 3907232 19-Okt-17 11:01 x64
Sqlevn70.rll 2017.140.3006.16 3810976 19-Okt-17 11:06 x64
Sqlevn70.rll 2017.140.3006.16 2084512 19-Okt-17 11:00 x64
Sqlevn70.rll 2017.140.3006.16 2031264 19-Okt-17 11:02 x64
Sqlevn70.rll 2017.140.3006.16 3579032 19-Okt-17 11:04 x64
Sqlevn70.rll 2017.140.3006.16 3587232 19-Okt-17 11:00 x64
Sqlevn70.rll 2017.140.3006.16 1441440 19-Okt-17 11:00 x64
Sqlevn70.rll 2017.140.3006.16 3775136 19-Okt-17 11:07 x64

SQL Server 2017 sql_shared_mr

Dateiname Dateiversion Dateigröße Datum Uhrzeit Plattform
Smrdll.dll 14.0.3006.16 23712 19-Okt-17 11:08 x86
Sql_engine_core_shared_keyfile.dll 2017.140.3006.16 100512 19-Okt-17 19:12 x64

SQL Server 2017 sql_tools_extensions

Dateiname Dateiversion Dateigröße Datum Uhrzeit Plattform
Dts.dll 2017.140.3006.16 2548384 19-Okt-17 11:01 x86
Dts.dll 2017.140.3006.16 2996896 19-Okt-17 19:12 x64
Dtsconn.dll 2017.140.3006.16 397984 19-Okt-17 11:01 x86
Dtsconn.dll 2017.140.3006.16 495264 19-Okt-17 19:12 x64
Dtshost.exe 2017.140.3006.16 88224 19-Okt-17 1,215 x86
Dtshost.exe 2017.140.3006.16 103072 19-Okt-17 12:21 x64
Dtspipeline.dll 2017.140.3006.16 1057440 19-Okt-17 1,210 x86
Dtspipeline.dll 2017.140.3006.16 1264288 19-Okt-17 19:12 x64
Dtutil.exe 2017.140.3006.16 125088 19-Okt-17 11:01 x86
Dtutil.exe 2017.140.3006.16 145568 19-Okt-17 19:12 x64
Microsoft.sqlserver.astasksui.dll 14.0.3006.16 184480 19-Okt-17 1,308 x86
Microsoft.sqlserver.chainer.infrastructure.dll 14.0.3006.16 406688 19-Okt-17 11:01 x86
Microsoft.sqlserver.chainer.infrastructure.dll 14.0.3006.16 406688 19-Okt-17 1,220 x86
Microsoft.sqlserver.configuration.sco.dll 14.0.3006.16 2093216 19-Okt-17 1,215 x86
Microsoft.sqlserver.configuration.sco.dll 14.0.3006.16 2093216 19-Okt-17 1,220 x86
msmgdsrv.dll 2017.140.1.439 7310496 19-Okt-17 1,215 x86
Sql_tools_extensions_keyfile.dll 2017.140.3006.16 100512 19-Okt-17 19:12 x64
Sqlscm.dll 2017.140.3006.16 59544 19-Okt-17 11:01 x86
Sqlscm.dll 2017.140.3006.16 69280 19-Okt-17 11:08 x64
Sqlsvc.dll 2017.140.3006.16 133280 19-Okt-17 11:01 x86
Sqlsvc.dll 2017.140.3006.16 160416 19-Okt-17 12:21 x64

Hinweise zu diesem Update

Voraussetzungen

Zum Anwenden dieses kumulativen Updatepakets müssen Sie SQL Server 2017 ausführen.

Informationen zum Neustart

Sie müssen den Computer nach der Installation dieses kumulativen Updatepakets unter Umständen neu starten.

Registrierungsinformationen

Sie müssen keine Änderungen an der Registrierung vornehmen, um einen der Hotfixes aus diesem Paket zu verwenden.

Wichtige Hinweise

Dieser Artikel enthält außerdem wichtige Informationen zu folgenden Situationen:

  • Herzschrittmacher: In Distributionen, die die neueste verfügbare Version von Herzschrittmacher verwenden, wird eine Verhaltensänderung vorgenommen. Es werden Methoden zur Risikominderung bereitgestellt.

  • Abfragespeicher: Sie müssen dieses Skript ausführen, wenn Sie den Abfragespeicher verwenden und zuvor Microsoft SQL Server 2017 Kumulatives Update 2 (CU2) installiert haben.

Buildversion von Analysis Services CU

Ab Microsoft SQL Server 2017 stimmen die Buildversionsnummer der Analysis Services und die Buildversionsnummer der SQL Server-Datenbank-Engine nicht überein. Weitere Informationen finden Sie unter „Überprüfen der Build-Version des kumulativen Updates für Analysis Services“.

Kumulative Updates (CU)

Kumulative Updates (CUs) stehen auch im Microsoft Download Center zur Verfügung.

Im Download Center ist jeweils nur das aktuelle CU verfügbar, das für SQL Server 2017 veröffentlicht wurde.

CU-Pakete für Linux sind verfügbar unter https://packages.microsoft.com.

  • Jedes neue CU enthält alle Korrekturen, die im vorherigen CU für die installierte Version von SQL Server enthalten waren.
  • SQL Server-CUs sind auf derselben Ebene wie Dienstpakete zertifiziert und sollten mit demselben Maß an Vertrauen installiert werden.
  • Wir empfehlen die kontinuierliche, proaktive Installation von CUs, sobald diese verfügbar sind, gemäß den folgenden Richtlinien:
    • Aus den Verlaufsdaten lässt sich ablesen, dass eine erhebliche Anzahl von Supportfällen Probleme betrifft, die in einem veröffentlichten CU bereits behoben wurden.
    • CUs können auch über Hotfixes hinaus Mehrwert bieten. Beispiele hierfür sind Updates in Bezug auf die Unterstützbarkeit, Verwaltbarkeit und Zuverlässigkeit.
  • Wir empfehlen, SQL Server-CUs zu testen, bevor Sie sie in Produktionsumgebungen bereitstellen.
Pacemaker-Hinweis

WICHTIG

Alle Distributionen (einschließlich RHEL 7.3 und 7.4), die das neueste verfügbare Pacemaker-Paket 1.1.18-11.el7 verwenden, führen eine Verhaltensänderung für die start-failure-is-fatal Clustereinstellung ein, wenn ihr Wert ist false. Diese Änderung wirkt sich auf den Failoverworkflow aus. Wenn ein primäres Replikat ausfällt, wird erwartet, dass vom Cluster ein Failover zu einem der verfügbaren sekundären Replikate erfolgt. Stattdessen werden Benutzer feststellen, dass der Cluster versucht, das fehlerhafte primäre Replikat zu starten. Wenn dieses primäre Replikat nicht online geschaltet wird (aufgrund eines permanenten Ausfalls), kommt es nie zu einem Failover des Clusters zu einem anderen verfügbaren sekundären Replikat.

Dieses Problem betrifft alle SQL Server-Versionen, unabhängig von der Version des kumulativenUpdates, auf der sie sich befinden.

Um das Problem zu umgehen, wenden Sie eine der folgenden Methoden an:

Methode 1

Führen Sie die folgenden Schritte aus:

  1. Entfernen Sie die Außerkraftsetzung start-failure-is-fatal aus dem vorhandenen Cluster.

    # RHEL, Ubuntu pcs property unset start-failure-is-fatal # or pcs property set start-failure-is-fatal=true # SLES crm configure property start-failure-is-fatal=true

  2. Verringern Sie den cluster-recheck-interval Wert.

    # RHEL, Ubuntu pcs property set cluster-recheck-interval=<Xmin> # SLES crm configure property cluster-recheck-interval=<Xmin>

  3. Fügen Sie die failure-timeout Meta-Eigenschaft jeder AG-Ressource hinzu.

    # RHEL, Ubuntu pcs resource update ag1 meta failure-timeout=60s # SLES crm configure edit ag1 # Fügen Sie im Texteditor nach allen Parametern und vor allen "op" "meta failure-timeout=60s" hinzu.

    Hinweis

    Ersetzen Sie in diesem Code den Wert für <Xmin> entsprechend. Wenn ein Replikat ausfällt, versucht der Cluster, das Replikat in einem Intervall neu zu starten, das durch den Wert und den failure-timeoutcluster-recheck-interval Wert gebunden ist. Wenn beispielsweise failure-timeout auf 60 Sekunden und cluster-recheck-interval 120 Sekunden festgelegt ist, wird der Neustart in einem Intervall versucht, das größer als 60 Sekunden, aber weniger als 120 Sekunden ist. Es wird empfohlen, failure-timeout einen Wert festzulegen, der 60scluster-recheck-interval größer als 60 Sekunden ist. Es wird empfohlen, nicht auf einen kleinen Wert festzulegen cluster-recheck-interval . Weitere Informationen finden Sie in der Pacemaker-Dokumentation. Sie können sich auch an den Systemanbieter wenden.

Methode 2

Zurücksetzen auf Pacemaker-Version 1.1.16.

Hinweis zum Abfragespeicher

WICHTIG

Sie müssen dieses Skript ausführen, wenn Sie den Abfragespeicher verwenden und vom kumulativen Update 2 von SQL Server 2017 (CU2) direkt auf SQL Server 2017 kumulatives Update 3 (CU3) oder ein beliebiges kumulatives Update neueren aktualisieren. Sie müssen dieses Skript nicht ausführen, wenn Sie zuvor das kumulative Update 3 für SQL Server 2017 (CU3) oder ein kumulatives Update für SQL Server 2017 installiert haben.

SET NOCOUNT ON;
DROP TABLE IF EXISTS #tmpUserDBs;

SELECT [database_id], 0 AS [IsDone]
INTO #tmpUserDBs
FROM master.sys.databases
WHERE [database_id] > 4
 AND [state] = 0 -- must be ONLINE
 AND is_read_only = 0 -- cannot be READ_ONLY
 AND [database_id] NOT IN (SELECT dr.database_id FROM sys.dm_hadr_database_replica_states dr -- Except all local Always On secondary replicas
  INNER JOIN sys.dm_hadr_availability_replica_states rs ON dr.group_id = rs.group_id
  INNER JOIN sys.databases d ON dr.database_id = d.database_id
  WHERE rs.role = 2 -- Is Secondary
   AND dr.is_local = 1
   AND rs.is_local = 1)

DECLARE @userDB sysname;

WHILE (SELECT COUNT([database_id]) FROM #tmpUserDBs WHERE [IsDone] = 0) > 0
BEGIN
 SELECT TOP 1 @userDB = DB_NAME([database_id]) FROM #tmpUserDBs WHERE [IsDone] = 0

 -- PRINT 'Working on database ' + @userDB

 EXEC ('USE [' + @userDB + '];
DECLARE @clearPlan bigint, @clearQry bigint;
IF EXISTS (SELECT [actual_state] FROM sys.database_query_store_options WHERE [actual_state] IN (1,2))
BEGIN
 IF EXISTS (SELECT plan_id FROM sys.query_store_plan WHERE engine_version = ''14.0.3008.27'')
 BEGIN
  DROP TABLE IF EXISTS #tmpclearPlans;

  SELECT plan_id, query_id, 0 AS [IsDone]
  INTO #tmpclearPlans
  FROM sys.query_store_plan WHERE engine_version = ''14.0.3008.27''

  WHILE (SELECT COUNT(plan_id) FROM #tmpclearPlans WHERE [IsDone] = 0) > 0
  BEGIN
   SELECT TOP 1 @clearPlan = plan_id, @clearQry = query_id FROM #tmpclearPlans WHERE [IsDone] = 0
   EXECUTE sys.sp_query_store_unforce_plan @clearQry, @clearPlan;
   EXECUTE sys.sp_query_store_remove_plan @clearPlan;

   UPDATE #tmpclearPlans
   SET [IsDone] = 1
   WHERE plan_id = @clearPlan AND query_id = @clearQry
  END;

  PRINT ''- Cleared possibly affected plans in database [' + @userDB + ']''
 END
 ELSE
 BEGIN
  PRINT ''- No affected plans in database [' + @userDB + ']''
 END
END
ELSE
BEGIN
 PRINT ''- Query Store not enabled in database [' + @userDB + ']''
END')
  UPDATE #tmpUserDBs
  SET [IsDone] = 1
  WHERE [database_id] = DB_ID(@userDB)
END
Bereitstellung in Hybridumgebungen

Wenn Sie ein Update in einer Hybridumgebung (z. B. Always On, Replikation, Cluster und Spiegelung) bereitstellen, empfehlen wir, vor der Bereitstellung des Updates die folgenden Artikel zu lesen:

Sprachunterstützung

Kumulative SQL Server-Updates sind derzeit mehrsprachig verfügbar. Daher ist dieses CU-Paket nicht sprachspezifisch. Es gilt für alle unterstützten Sprachen.

Komponenten (Features) aktualisiert

Ein CU-Paket enthält alle verfügbaren Updates für alle Komponenten (Features) von SQL Server 2017. Mit dem kumulativen Updatepaket werden jedoch nur die Komponenten aktualisiert, die derzeit auf der von Ihnen für die Wartung ausgewählten SQL Server-Instanz installiert sind. Wenn ein SQL Server-Feature (z. B. Analysis Services) der Instanz hinzugefügt wird, nachdem dieses CU angewendet wurde, müssen Sie dieses CU erneut anwenden, um das neue Feature auf den Stand dieses CU zu aktualisieren.

Support für dieses Update

Falls weitere Probleme auftreten oder eine Problembehandlung erforderlich ist, müssen Sie unter Umständen eine Serviceanfrage erstellen. Für zusätzliche Supportanfragen und -belange, die nicht für dieses spezielle kumulative Updatepaket geeignet sind, fallen die üblichen Supportgebühren an. Eine vollständige Liste der Telefonnummern des Microsoft-Kundendiensts und -Supports oder zum Erstellen einer separaten Serviceanfrage finden Sie auf der Microsoft-Supportwebsite.

Deinstallieren dieses Updates

Deinstallieren dieses Updates unter Windows
  1. Öffnen Sie in der Systemsteuerung das Element Programme und Features und wählen Sie dann Installierte Updates anzeigen aus.
  2. Suchen Sie nach dem Eintrag für dieses kumulative Updatepaket unter SQL Server 2017.
  3. Halten Sie den Eintrag gedrückt, oder klicken Sie mit der rechten Maustaste darauf, und wählen Sie Deinstallieren.
Deinstallieren dieses Updates unter Linux

Zum Deinstallieren dieses CU in Linux müssen Sie das Paket auf die vorherige Version zurücksetzen. Weitere Informationen zum Zurücksetzen der Installation finden Sie unter Zurücksetzen von SQL Server.

Informationen zum Haftungsausschluss von Drittanbietern

Die in diesem Artikel genannten Fremdanbieterprodukte stammen von Herstellern, die von Microsoft unabhängig sind. Microsoft gewährt keine implizite oder sonstige Garantie in Bezug auf die Leistung oder Zuverlässigkeit dieser Produkte.

Referenzmaterial