Mit Microsoft anmelden
Melden Sie sich an, oder erstellen Sie ein Konto.
Hallo,
Wählen Sie ein anderes Konto aus.
Sie haben mehrere Konten.
Wählen Sie das Konto aus, mit dem Sie sich anmelden möchten.

Weitere Informationen

Der erweiterte Filter bietet Ihnen die Flexibilität, Ihre Datensätze an eine andere Position auf demselben Arbeitsblatt oder einem anderen Arbeitsblatt in der Arbeitsmappe zu extrahieren. Sie ermöglicht auch die Verwendung einer "ODER"-Anweisung in Ihren Filtern. (Beispiel: Welcher Umsatz unter 400 $ "ODER" größer als 600 $ war). Der AutoFilter von Excel filtert dinge an Ort und Stelle und ermöglicht ihnen keine komplexen Filter. Um die Grundlagen der erweiterten Filterung zu erlernen, führen Sie die folgenden Schritte aus:



Schritt 1: Einrichten der Datenbank


Erweiterter Filter verwendet das Konzept einer Datenbank. Eine Datenbank ist als Eine Zeile mit Beschriftungen mit Datenspalten unterhalb jeder dieser Bezeichnungen festgelegt. Jede Spalte enthält Daten eines bestimmten Typs wie ein Datum, eine Zahl oder text. Hier sind einige Regeln zum Einrichten Ihrer Datenbank:

  1. Die erste Zeile der Datenbank sollte nur aus Bezeichnungen bestehen. Durch fett formatierte Beschriftungen können Sie daran erinnert werden, dass sie nicht Teil Ihrer Daten sind.

  2. Unter den einzelnen Bezeichnungen sind die Daten angegeben, die von der Bezeichnung beschrieben werden.

    Hinweis: Stellen Sie sicher, dass keine leeren Zeilen in der Datenbank vorhanden sind.

  3. Stellen Sie sicher, dass leere Zellen um die gesamte Datenbank herum vorhanden sind (der Rand der Seite wird als leere Zelle betrachtet). Siehe Bild.



Schritt 2: Einrichten des Kriterienbereichs


Der Kriterienbereich ist nur eine weitere Möglichkeit, "Was möchten Sie filtern (Suchen) nach?" zu sagen. Sie legen die Regeln für die Daten fest, die nach dem Anwenden des Filters sichtbar bleiben. Sie können so viele oder so wenige Regeln wie nötig verwenden. Wir werden Sie mithilfe dieser kleinen Datenbank durch den Filterprozess durchblättern:Hinweis: Stellen Sie sicher, dass AutoFilter deaktiviert ist, und es gibt immer eine leere Zeile und Spalte, die Ihre Datenbank von jedem anderen Text auf der Tabelle



trennt. Andernfalls ist der erweiterte Filter der Meinung, dass er Teil der Datenbank ist.


Einrichten eines Kriterienbereichbereichs

  1. Kopieren Sie die Beschriftungszeile, und fügen Sie sie an eine andere Stelle auf dem Arbeitsblatt ein. Siehe Bild.



  2. Es gibt keinen festgelegten Ort, sondern stellen Sie einfach sicher, dass genügend Platz vorhanden ist, damit jeder text, den Sie eingeben, nicht in einer Zeile oder Spalte enthalten ist, die mit der Datenbank verbunden ist.


Schritt 3: Verwenden Ihrer Filter.


In "Erweiterte Filterung" wenden Sie Regeln an, die alles außer dem, was Sie suchen, ausblenden. Sie funktioniert wie eine sehr detaillierte Suche, wenn Sie mit der Verwendung der Regeln beginnen.

Filtern mit einer Regel



Zuerst müssen Sie ihren Kriterienbereich festlegen. Für dieses Beispiel verwenden wir den Kriterienbereich von "Welche Aufträge waren kleiner als 450 $?".

Die folgenden Symbole können in Ihren Filtern verwendet werden:

  • < kleiner als

  • <= kleiner oder gleich

  • >= größer als oder gleich

  • <> nicht gleich


  1. Geben <450 ein (Das $-Zeichen ist nicht nötig.) unter Summe im Abschnitt Kriterienbereich.

  2. Klicken Sie in eine beliebige Zelle in der Datenbank.Siehe Bild.



  3. Wechseln Sie zu: Die Registerkarte Daten > & Filter > Erweitert.

  4. Klicken Sie im geöffneten Dialogfeld Erweiterter Filter in das Feld Kriterienbereich. Siehe Bild.



  5. Wechseln Sie zurück zum Arbeitsblatt, klicken Sie im gerade erstellten Bereich Kriterienbereich auf Summe, und ziehen Sie die Maus über die von Ihnen eingegebene Regel (<450). Das Dialogfeld Erweiterter Filter wird ausgeblendet, und das Dialogfeld Erweiterte Filter – Kriterien wird angezeigt. Siehe Bild.



  6. Wenn Sie die Maustaste loslassen, sollte eine gepunktete Linie um beide Zellen herum angezeigt werden, und das Dialogfeld Erweiterter Filterdialog wird wieder angezeigt. Klicken Sie auf OK.

  7. Die Datenbankansicht wird sofort so geändert, dass nur die Zeilen angezeigt werden, in denen die Summe kleiner als 450 $ ist.Siehe Bild.



  8. Um die gesamte Datenbank erneut anzeigen oder einen anderen Filterprozess ausführen zu können, müssen Sie die Ansicht des letzten Filters löschen. Kehren Sie unter der Registerkarte & zum Filter sortieren zurück, und klicken Sie auf Löschen. Die Datenbank wird wieder in der ursprünglichen Ansicht angezeigt.Siehe Bild.



 

Filtern mit einer "AND"-Anweisung.



Zuerst müssen Sie ihren Kriterienbereich festlegen. Für dieses Beispiel verwenden wir den Kriterienbereich von "Welche Aufträge haben Sid "UND" Fred, die weniger als 450 $ waren?".

Die folgenden Symbole können in Ihren Filtern verwendet werden:

  • < kleiner als

  • <= kleiner oder gleich

  • >= größer als oder gleich

  • <> nicht gleich


  1. Geben Sie Fred und Sid in separaten Zeilen unter Kunde und <450 unter Summe für Fred und Sid ein (das $-Zeichen ist nicht nötig.) im Abschnitt Kriterienbereich. Denken Sie daran, eine leere Zeile und Spalte um ihre Datenbank zu behalten.

  2. Klicken Sie mit der linken Maustaste in eine beliebige Zelle in der Datenbank. Siehe Bild.



  3. Wechseln Sie zu: Die Registerkarte Daten > & Filter > Erweitert.

  4. Klicken Sie im geöffneten Feld Erweiterter Filterdialog in das Feld Kriterienbereich. Siehe Bild.



  5. Wechseln Sie zurück zur Datenbank, klicken Sie im Bereich Kriterienbereich, den Sie gerade erstellt haben, auf Kunde, und ziehen Sie die Maus, um alle von Ihnen eingegebenen Regeln zu decken. Das Dialogfeld Erweiterter Filter wird ausgeblendet, und das Dialogfeld Erweiterte Filter – Kriterien wird angezeigt. Siehe Bild.



  6. Wenn Sie die Maustaste loslassen, sollte eine gepunktete Linie um die Regeln herum angezeigt werden, und das Dialogfeld Erweiterter Filter wird wieder angezeigt. Klicken Sie auf OK.

  7. Die Datenbankansicht wird sofort so geändert, dass nur die Zeilen angezeigt werden, in denen Fred "AND" Sids Summe kleiner als 450 $ ist. Siehe Bild.



  8. Um die gesamte Datenbank erneut anzeigen oder einen anderen Filterprozess ausführen zu können, müssen Sie die Ansicht des letzten Filters löschen. Kehren Sie unter der Registerkarte & zum Filter sortieren zurück, und klicken Sie auf Löschen. Die Datenbank wird wieder in der ursprünglichen Ansicht angezeigt. Siehe Bild.



 

Filtern mithilfe einer "UND" und einer "ODER"-Anweisung.


Zuerst müssen Sie ihren Kriterienbereich festlegen. Für dieses Beispiel verwenden wir den Kriterienbereich von "Welche Bestellungen waren größer als 400 $ "UND" kleiner als 560 $, "ODER" größer als 1000 $?".

Die folgenden Symbole können in Ihren Filtern verwendet werden:

  • < kleiner als

  • <= kleiner oder gleich

  • >= größer als oder gleich

  • <> nicht gleich

Lassen Sie uns die Frage auseinanderziehen, um zu verstehen, wie der Kriterienbereich erstellt wird.

  1. Wir möchten herausfinden, welche Bestellungen größer als 400 $ UND weniger als 560 $ waren. Fügen Sie dazu eine weitere Spaltenbeschriftung mit demselben Titel wie die Spaltenbeschriftung "UND" hinzu. In diesem Fall fügen wir eine weitere Total-Bezeichnung hinzu.Siehe Bild.



  2. Geben Sie ihren Kriterienbereich ein, indem Sie die Anforderungen "UND" und die Anforderungen "ODER" unten verwenden. Setzen >400 unter die erste Spalte Summe und <560 unter der neuen Spalte Summe. Fügen Sie nun die ANFORDERUNG ODER hinzu, indem >1000 unter die erste Spalte Summe setzen. Die Abbildung zeigt, wie Ihr Kriterienbereich nach dem Erstellen des Kriterienbereichs aussehen sollte. Klicken Sie auf eine beliebige Stelle in der Datenbank.Siehe Bild.



  3. Wechseln Sie zu: Die Registerkarte Daten > & Filter > Erweitert.

  4. Klicken Sie im geöffneten Dialogfeld Erweiterter Filter in das Feld Kriterienbereich. Siehe Bild.



  5. Wechseln Sie zurück zur Datenbank, klicken Sie im Bereich Kriterienbereich, den Sie gerade erstellt haben, auf Summe, und ziehen Sie die Maus, um alle von Ihnen eingegebenen Regeln zu bedecken. Das Dialogfeld Erweiterter Filter wird ausgeblendet, und es wird ein Dialogfeld Filter – Kriterien angezeigt. Siehe Bild.



  6. Wenn Sie die Maustaste loslassen, sollte eine gepunktete Linie um die Regeln herum angezeigt werden, und das Dialogfeld Erweiterter Filter wird wieder angezeigt. Klicken Sie auf OK.

  7. Die Datenbankansicht wird sofort so geändert, dass nur die Zeilen angezeigt werden, in denen die Summe größer als 400 $ und kleiner als 560 $ oder größer als 1000 $ ist. Siehe Bild.



  8. Um die gesamte Datenbank erneut anzeigen oder einen anderen Filterprozess ausführen zu können, müssen Sie die Ansicht des letzten Filters löschen. Kehren Sie unter der Registerkarte & zum Filter sortieren zurück, und klicken Sie auf Löschen. Die Datenbank wird wieder in der ursprünglichen Ansicht angezeigt.Siehe Bild.





Schritt 4: Einrichten des Extract Range (The Basics).



Wenn Sie den Extraktionsbereich verwenden, ist dies identisch mit der Aussage: "Ich möchte, dass die gefilterten Daten an einem anderen Speicherort angezeigt werden". Sie können die Spalten angeben, die Sie extrahieren möchten. Wenn Sie ALLE Spalten extrahieren möchten, können Sie den Extrahierenbereich leer lassen.

Das Filtern erfolgt auf die gleiche Weise wie im Abschnitt "Verwenden ihrer Filter". In Schritt 6 werden die zusätzlichen Schritte zum Anzeigen der gefilterten Ergebnisse an einem anderen Speicherort ins Spiel kommen. Für dieses Beispiel verwenden wir den Kriterienbereich von: "Welche Bestellungen waren über 400 $".

  1. Geben >400 ein (Das $-Zeichen ist nicht nötig.) unter Summe im Abschnitt Kriterienbereich. Siehe Bild.




  2. in einer beliebigen Zelle in der Datenbank zu lecken.

  3. Wechseln Sie zu: Die Registerkarte Daten > & Filter > Erweitert.

  4. Klicken Sie im geöffneten Dialogfeld Erweiterter Filter in das Feld Kriterienbereich. Siehe Bild.



  5. Wechseln Sie zurück zur Datenbank, klicken Sie im gerade erstellten Bereich Kriterienbereich auf Summe, und ziehen Sie mit der Maus über die von Ihnen eingegebene Regel (<450). Das Dialogfeld Erweiterter Filter wird ausgeblendet, und es wird ein Dialogfeld Erweiterter Filter – Kriterien angezeigt. Siehe Bild.




  6. Wenn Sie die Maustaste loslassen, sollte eine gepunktete Linie um beide Zellen herum angezeigt werden, und das Dialogfeld Erweiterter Filter wird wieder angezeigt. Klicken Sie im Abschnitt Aktion auf die Schaltfläche An einen anderen Speicherort kopieren. Siehe Bild.



  7. Klicken Sie im Dialogfeld Erweiterter Filter auf die Schaltfläche Kopieren nach: . Siehe Bild.


     

  8. Das Dialogfeld Erweiterter Filter wird geschlossen, und das Dialogfeld Erweiterter Filter – Kopieren nach: wird geöffnet. Klicken Sie in die Zelle, in der die gefilterte Ausgabe angezeigt werden soll, und klicken Sie auf die Schaltfläche Erweiterter Filter – Kopieren nach: . Siehe Bild.



  9. Wenn das Dialogfeld Erweiterter Filter zurückgegeben wird, klicken Sie auf OK. Die Datensätze, die Ihrem Kriterienbereich entsprechen, werden dann ab der von Ihnen angegebenen Zelle angezeigt. Siehe Bild.



Weitere Informationen zum Filtern nach einem anderen Arbeitsblatt finden Sie unter: Supportartikel KB-909527, der auch für Excel 2010 gilt.



Weitere Informationen zur erweiterten Filterung finden Sie unter:Filtern mithilfe erweiterter Kriterien Weitere Informationen zu Kriterienbereichen finden Sie unter: Beispiele für komplexe Kriterien Sie können auch Hilfe aus der Microsoft Community online erhalten, nach weiteren Informationen zum



Microsoft-Support oder zur Windows-Hilfe und Zur Funktionsweise suchen oder weitere Informationen zu Optionen für den unterstützten Support erhalten.

Benötigen Sie weitere Hilfe?

Ihre Office-Fähigkeiten erweitern
Schulungen erkunden
Neue Funktionen als Erster erhalten
Microsoft Insider beitreten

War diese Information hilfreich?

Wie zufrieden sind Sie mit der Sprachqualität?
Was hat Ihre Erfahrung beeinflusst?

Vielen Dank für Ihr Feedback!

×