MSExchangeIS stops responding and returns "System.NullReferenceExceptions" multiple times per day

Applies To
Exchange Server 2019

Symptoms

The Microsoft Exchange Information Store (MSExchangeIS) service occasionally stops responding, and the following Event ID 1002 entry is logged:

Unhandled exception (System.NullReferenceException: Object reference not set to an instance of an object.

   at Microsoft.Exchange.Server.Storage.LogicalDataModel.SearchFolder.BaseViewOperatorDefinition(Context context, Mailbox mailbox, IList`1 columnsToFetch, SearchCriteria criteria, Nullable`1 associated)

   at Microsoft.Exchange.Server.Storage.LogicalDataModel.SearchFolder.<DoSearchPopulation>d__210.MoveNext()

   at Microsoft.Exchange.Protocols.MAPI.MapiViewMessage.<CreateMaterializedRestrictionAndPopulate>d__138.MoveNext()

   at Microsoft.Exchange.Server.Storage.MapiDisp.MailboxTaskQueue.RunTaskStep(MailboxTaskContext mailboxTaskContext, QueueItem

Cause

The MSExchangeIS process stops responding because of an unhandled System.NullReferenceExceptions exception that's generated multiple times per day.

Resolution

To fix this issue, install the following cumulative update:

Cumulative Update 14 for Exchange Server 2019 or a later cumulative update for Exchange Server 2019