Symptoms
After you install the Microsoft Exchange Server November 2024 Security Update (SU) (Version 1 or Version 2), you experience issues when Exchange Server processes calendar-related information and files, such as .ical or .ics attachments. In this situation, you can't preview the files or add them to the calendar.
The issue occurs when you use Outlook on the Web (OWA) and the Exchange Active Sync (EAS) mail client on a mobile device. Additionally, the issue might affect the Exchange Transport service when you process email messages that have .ical or .ics file attachments.
If Exchange Server doesn't process calendar information, it generates event log entries, such as either of the following examples:
w3wp#MSExchangeOWAAppPool,M.Exchange.Net,M.E.E.ExIanaTimeZoneProvider+Cache.AddTimeZone,M.E.ExchangeSystem.InvalidTimeZoneException
Microsoft.Exchange.ExchangeSystem.InvalidTimeZoneException: Time zone id already exists
Cause
This issue occurs because Exchange Server uses a duplicate entry in the IanaTimeZoneMappings.xml file.
Workaround
To remove the duplicate entries, use either of the following workarounds.
Method 1
Follow the steps in Remove-DuplicateEntriesFromIanaMappings.
Method 2
Save the IanaTimeZoneMappings.xml file that's located in the following folder:
<ExchangeInstallationPath>\Microsoft\Exchange Server\V15\Bin
Open the file by using Notepad or another text editor, and search for the following entry (it appears two times):
<Map IANA="Asia/Bishkek" Win="Central Asia Standard Time" />
Delete one of the two entries, and then save the file.
Open an elevated PowerShell window, and then run the following commands:
Restart-Service -Name W3SVC, WAS -Force
Restart-Service -Name MSExchangeTransport
Status
Microsoft has confirmed that this issue affects the products that are listed in the "Applies to" section. Microsoft is actively working on a resolution for the issue in a future update.