Plug and Play Manager stops working when you wake a computer from sleep in Windows

Applies To
Windows 7 Service Pack 1 Windows 7 Enterprise Windows 7 Home Basic Windows 7 Home Premium Windows 7 Professional Windows 7 Ultimate Windows 7 Starter Windows Server 2008 R2 Service Pack 1 Windows Server 2008 R2 Datacenter Windows Server 2008 R2 Enterprise Windows Server 2008 R2 for Itanium-Based Systems Windows Server 2008 R2 Foundation Windows Server 2008 R2 Standard Windows Server 2008 R2 Web Edition Windows 8 Windows 8 Pro Windows 8 Enterprise Windows Server 2012 Datacenter Windows Server 2012 Datacenter Windows Server 2012 Essentials Windows Server 2012 Standard Windows Server 2012 Standard Windows Server 2012 Foundation Windows Server 2012 Foundation

Symptoms

Consider the following scenario:

  • You restart a Windows 7 Service Pack 1 (SP1), Windows Server 2008 R2 SP1, Windows 8, or Windows Server 2012-based computer.
  • You put the computer into Sleep mode.
  • You wake the computer.

In this scenario, Plug and Play Manager may stop working. Additionally, if you plug in a USB device or a Secure Digital (SD) card, the USB device or SD card is not listed in the device manager nor in the "Devices with Removable Storage" section of My Computer.

Cause

This issue occurs because Portcls.sys incorrectly handles the error from audio drivers.

Resolution

Update information

To resolve these issues, install update rollup 2889784. For more information about how to obtain this update rollup package, click the following article number to go to the article in the Microsoft Knowledge Base:

2889784 Windows RT, Windows 8, and Windows Server 2012 update rollup: November 2013

Hotfix information

A supported hotfix is available from Microsoft. However, this hotfix is intended to correct only the problem that described in this article. Apply this hotfix only to systems that are experiencing the problem described in this article. This hotfix might receive additional testing. Therefore, if you are not severely affected by this problem, we recommend that you wait for the next software update that contains this hotfix.

If the hotfix is available for download, there is a "Hotfix Download Available" section at the top of this Knowledge Base article. If this section does not appear, contact Microsoft Customer Service and Support to obtain the hotfix.

Note If additional issues occur or if any troubleshooting is required, you might have to create a separate service request. The usual support costs will apply to additional support questions and issues that do not qualify for this specific hotfix. For a complete list of Microsoft Customer Service and Support telephone numbers or to create a separate service request, visit the following Microsoft website:

http:⁠//support.microsoft.com/contactus/?ws=support Note The "Hotfix Download Available" form displays the languages for which the hotfix is available. If you do not see your language, it is because a hotfix is not available for that language.

PrerequisitesTo apply this hotfix, you must be running one of the following operating systems:

  • Windows 7 SP1
  • Windows Server 2008 R2 SP1
  • Windows 8
  • Windows Server 2012

Registry informationTo apply this hotfix, you do not have to make any changes to the registry.

Restart requirementYou may be prompted to restart the computer after you apply this hotfix.

Hotfix replacement informationThis hotfix does not replace a previously released hotfix.

File information

The global version of this hotfix installs files that have the attributes that are listed in the following tables. The dates and the times for these files are listed in Coordinated Universal Time (UTC). The dates and the times for these files on your local computer are displayed in your local time together with your current daylight saving time (DST) bias. Additionally, the dates and the times may change when you perform certain operations on the files.

Windows RT, Windows 8, and Windows Server 2012 file information

Important Windows 8 and Windows Server 2012 hotfixes are included in the same packages.

Notes

  • The files that apply to a specific product, milestone (RTM, SPn), and service branch (LDR, GDR) can be identified by examining the file version numbers as shown in the following table:

    Version Product Milestone Service branch
    6.2.920 0.16 xxx Windows RT, Windows 8, and Windows Server 2012 RTM GDR
    6.2.920 0.20 xxx Windows RT, Windows 8, and Windows Server 2012 RTM LDR

For Windows RT

File name File version File size Date Time Platform
Drmk.sys 6.2.9200.16720 90,112 21-Sep-2013 02:37 Not applicable
Drmkaud.sys 6.2.9200.16433 5,632 11-Oct-2012 04:30 Not applicable
Portcls.sys 6.2.9200.16723 194,560 24-Sep-2013 22:17 Not applicable
Sysfxui.dll 6.2.9200.16433 340,992 11-Oct-2012 04:50 Not applicable
Wmalfxgfxdsp.dll 6.2.9200.16433 1,144,968 11-Oct-2012 05:10 Not applicable

For all supported x86-based versions of Windows 8

File name File version File size Date Time Platform
Drmk.sys 6.2.9200.16433 83,456 11-Oct-2012 04:39 x86
Drmkaud.sys 6.2.9200.16433 5,120 11-Oct-2012 04:40 x86
Portcls.sys 6.2.9200.16723 219,136 24-Sep-2013 22:19 x86
Sysfxui.dll 6.2.9200.16433 336,896 11-Oct-2012 05:07 x86
Wmalfxgfxdsp.dll 6.2.9200.16433 1,262,744 11-Oct-2012 05:18 x86
Drmk.sys 6.2.9200.20534 83,456 11-Oct-2012 04:44 x86
Drmkaud.sys 6.2.9200.20534 5,120 11-Oct-2012 04:44 x86
Portcls.sys 6.2.9200.20833 218,112 24-Sep-2013 22:19 x86
Sysfxui.dll 6.2.9200.20534 336,896 11-Oct-2012 05:12 x86
Wmalfxgfxdsp.dll 6.2.9200.20534 1,262,744 11-Oct-2012 05:43 x86

For all supported x64-based versions of Windows 8 and of Windows Server 2012

File name File version File size Date Time Platform
Drmk.sys 6.2.9200.16433 111,616 11-Oct-2012 05:18 x64
Drmkaud.sys 6.2.9200.16433 5,632 11-Oct-2012 05:19 x64
Portcls.sys 6.2.9200.16723 288,768 24-Sep-2013 22:18 x64
Sysfxui.dll 6.2.9200.16433 370,176 11-Oct-2012 05:45 x64
Wmalfxgfxdsp.dll 6.2.9200.16433 1,636,672 11-Oct-2012 07:02 x64
Drmk.sys 6.2.9200.20534 111,616 11-Oct-2012 05:17 x64
Drmkaud.sys 6.2.9200.20534 5,632 11-Oct-2012 05:17 x64
Portcls.sys 6.2.9200.20833 285,696 24-Sep-2013 22:18 x64
Sysfxui.dll 6.2.9200.20534 370,176 11-Oct-2012 05:44 x64
Wmalfxgfxdsp.dll 6.2.9200.20534 1,636,672 11-Oct-2012 07:11 x64

Windows 7 and Windows Server 2008 R2 file information

Important Windows 7 hotfixes and Windows Server 2008 R2 hotfixes are included in the same packages. However, hotfixes on the Hotfix Request page are listed under both operating systems. To request the hotfix package that applies to one or both operating systems, select the hotfix that is listed under "Windows 7/Windows Server 2008 R2" on the page. Always refer to the "Applies To" section in articles to determine the actual operating system that each hotfix applies to.

Notes

  • The files that apply to a specific product, milestone (RTM, SPn), and service branch (LDR, GDR) can be identified by examining the file version numbers as shown in the following table:

    Version Product Milestone Service branch
    6.1.760
    1.18xxx
    Windows 7 and Windows Server 2008 R2 SP1 GDR
    6.1.760
    1.22xxx
    Windows 7 and Windows Server 2008 R2 SP1 LDR
  • GDR service branches contain only those fixes that are widely released to address widespread, critical issues. LDR service branches contain hotfixes in addition to widely released fixes.

For all supported x86-based versions of Windows 7

File name File version File size Date Time Platform
Drmk.sys 6.1.7601.18270 81,408 25-Sep-2013 01:48 x86
Portcls.sys 6.1.7601.18270 177,152 25-Sep-2013 01:15 x86
Drmk.sys 6.1.7601.22465 81,408 25-Sep-2013 01:52 x86
Portcls.sys 6.1.7601.22465 177,152 25-Sep-2013 01:19 x86

For all supported x64-based versions of Windows 7 and of Windows Server 2008 R2

File name File version File size Date Time Platform
Drmk.sys 6.1.7601.18270 116,736 25-Sep-2013 02:11 x64
Portcls.sys 6.1.7601.18270 230,400 25-Sep-2013 01:32 x64
Drmk.sys 6.1.7601.22465 116,736 25-Sep-2013 02:15 x64
Portcls.sys 6.1.7601.22465 230,400 25-Sep-2013 01:36 x64

For all supported IA-64-based versions of Windows Server 2008 R2

File name File version File size Date Time Platform
Portcls.sys 6.1.7601.18270 605,696 25-Sep-2013 01:00 IA-64
Portcls.sys 6.1.7601.22465 605,696 25-Sep-2013 01:02 IA-64

      

Status

Microsoft has confirmed that this is a problem in the Microsoft products that are listed in the "Applies to" section.

More Information

For more information about software update terminology, click the following article number to view the article in the Microsoft Knowledge Base:

824684 Description of the standard terminology that is used to describe Microsoft software updates