Backup files that are created by using the Windows Volume Shadow Copy feature are corrupted in Windows Server 2003, Windows Vista, Windows Server 2008, Windows 7, or Windows Server 2008 R2

Applies To
Microsoft Windows Server 2003 Service Pack 2 Windows Server 2008 Enterprise Windows Server 2008 Enterprise without Hyper-V Windows Server 2008 Datacenter Windows Server 2008 Datacenter without Hyper-V Windows Server 2008 for Itanium-Based Systems Windows Server 2008 Foundation Windows Server 2008 Standard Windows Server 2008 Standard without Hyper-V Windows Server 2008 Web Edition Windows Vista Enterprise Windows Vista Enterprise 64-bit Edition Windows Vista Business Windows Vista Business 64-bit Edition Windows Vista Home Basic Windows Vista Home Basic 64-bit Edition Windows Vista Home Premium Windows Vista Home Premium 64-bit Edition Windows Vista Starter Windows Vista Ultimate Windows Vista Ultimate 64-bit Edition Windows Server 2008 R2 Enterprise Windows Server 2008 R2 Datacenter Windows Server 2008 R2 for Itanium-Based Systems Windows Server 2008 R2 Foundation Windows Server 2008 R2 Standard Windows Server 2008 R2 Web Edition Windows 7 Enterprise Windows 7 Home Basic Windows 7 Home Premium Windows 7 Professional Windows 7 Starter Windows 7 Ultimate

Symptoms

Assume that you have a computer that is running Windows Server 2003, Windows Vista, Windows Server 2008, Windows 7, or Windows Server 2008 R2. You use a backup application that uses the Windows Volume Shadow Copy feature to create snapshots and read files from the snapshots. In this situation, one or more corrupted files are found in the snapshots.

Notes

  • The corrupted files can be backed up by using the backup application. The corrupted files can only be noticed during a restore process.
  • The backup data of any third-party back up application can be affected. For example, NTBackup, Windows Server Backup, System Center Data Protection Manager (DPM) can be affected. Please contact your third-party backup solution manufacturer to determine whether they use the Windows Volume Shadow Copy feature to create backups.

Cause

This issue occurs because some regions in the snapshot are not protected when the original volume is changed. When the file is read from the snapshot, the file data is not consistent. Therefore, the file data becomes corrupted. When a backup is taken by using this snapshot, the corrupted file is stored later.  

Free clusters in a volume comply by using the following pattern:

Note White regions in the pattern represent free clusters.

cf351e14-8c57-a5de-2639-c8d4b7e03ef8

The Windows Volume Shadow Copy feature cannot protect the second region that is being used. Therefore, when blocks are read by an application, the old content is overwritten by the new content.

This pattern occurs when the current size of the volume that you extend is a multiple of 8 gigabytes (GB) by a size that is larger than 8 GB. The chances to obtain the pattern are increased in the following conditions:

  • The initial size of the volume that you extend is a multiple of 8 GB.
  • The volume is frequently extended by multiple of 8 GB.

Note The pattern occurs in other situations too. The previous cases of corruption increase the occurrence of the pattern.

Resolution

Update information

How to obtain this update

Microsoft Update

This update is available from the following Microsoft Update website:

http:⁠//update.microsoft.com

Microsoft Download Center

The following files are available for download from the Microsoft Download Center:

Operating system Update
All supported x86-based version of Windows Server 2003 Download Download the update package now.
All supported x64-based version of Windows Server 2003 Download Download the update package now.
All supported IA-64-based versions of Windows Server 2003 Download Download the update package now.
All supported x86-based version of Windows Vista Download Download the update package now.
All supported x64-based version of Windows Vista Download Download the update package now.
All supported x86-based versions of Windows Server 2008 Download Download the update package now.
All supported x64-based versions of Windows Server 2008 Download Download the update package now.
All supported IA-64-based versions of Windows Server 2008 Download Download the update package now.
All supported x86-based versions of Windows 7 Download Download the update package now.
All supported x64-based versions of Windows 7 Download Download the update package now.
All supported x64-based versions of Windows Server 2008 R2 Download Download the update package now.
All supported IA-64-based versions of Windows Server 2008 R2 Download Download the update package now.

For more information about how to download Microsoft support files, click the following article number to view the article in the Microsoft Knowledge Base:

119591 How to obtain Microsoft support files from online services
Microsoft scanned this file for viruses. Microsoft used the most current virus-detection software that was available on the date that the file was posted. The file is stored on security-enhanced servers that help prevent any unauthorized changes to the file.

Prerequisites

To apply this update, you must be running one of the following operation systems:

  • Windows Server 2003 Service Pack 2 (SP2)
  • Windows Vista Service Pack 2 (SP2)
  • Windows Server 2008 Service Pack 2 (SP2)
  • Windows 7
  • Windows Server 2008 R2

For more information about how to obtain a Windows Server 2003 service pack, click the following article number to view the article in the Microsoft Knowledge Base:

889100 How to obtain the latest service pack for Windows Server 2003

For more information about how to obtain a Windows Vista service pack, click the following article number to view the article in the Microsoft Knowledge Base:

935791 How to obtain the latest Windows Vista service pack

For more information about how to obtain a Windows Server 2008 service pack, click the following article number to view the article in the Microsoft Knowledge Base:

968849 How to obtain the latest service pack for Windows Server 2008

Note The fix is included in Windows 7 Service Pack 1 (SP1) and Windows Server 2008 R2 SP1. For more information about how to obtain a Windows 7 or a Windows Server 2008 R2 service pack, click the following article number to view the article in the Microsoft Knowledge Base:

976932 Information about Service Pack 1 for Windows 7 and for Windows Server 2008 R2

Registry information

To apply this update, you do not have to make any changes to the registry.

Restart requirement

You must restart the computer after you apply this update.

Update replacement information

This update does not replace a previously released update.

File information

The global version of this update installs files that have the attributes that are listed in the following tables. The dates and the times for these files are listed in Coordinated Universal Time (UTC). The dates and the times for these files on your local computer are displayed in your local time together with your current daylight saving time (DST) bias. Additionally, the dates and the times may change when you perform certain operations on the files.

Windows Server 2003 file information notes

  • In addition to the files that are listed in these tables, this update also installs an associated security catalog file (KB976329.cat) that is signed with a Microsoft digital signature.
For all supported x86-based versions of Windows Server 2003
File name File version File size Date Time Platform SP requirement
Volsnap.sys 5.2.3790.5059 159,232 21-Aug-2012 12:54 x86 SP2
W03a3409.dll 5.2.3790.4715 44,544 09-Jul-2010 04:25 x86 SP2

      

For all supported x64-based versions of Windows Server 2003
File name File version File size Date Time Platform SP requirement Service branch
Volsnap.sys 5.2.3790.5059 317,440 22-Aug-2012 16:38 x64 SP2 Not applicable
W03a3409.dll 5.2.3790.4715 45,056 22-Aug-2012 16:38 x64 SP2 Not applicable
Ww03a3409.dll 5.2.3790.4715 44,544 22-Aug-2012 16:38 x86 SP2 WOW

      

For all supported IA-64-based versions of Windows Server 2003
File name File version File size Date Time Platform SP requirement Service branch
Volsnap.sys 5.2.3790.5059 496,640 22-Aug-2012 16:38 IA-64 SP2 Not applicable
W03a3409.dll 5.2.3790.4715 43,520 22-Aug-2012 16:38 IA-64 SP2 Not applicable
Ww03a3409.dll 5.2.3790.4715 44,544 22-Aug-2012 16:38 x86 SP2 WOW

      

      

Windows Vista and Windows Server 2008 file information notesImportant Windows Vista updates and Windows Server 2008 updates are included in the same packages. However, only "Windows Vista" is listed on the Update Request page. To request the update package that applies to one or both operating systems, select the update that is listed under "Windows Vista" on the page. Always refer to the "Applies To" section in articles to determine the actual operating system that each update applies to.

  • The files that apply to a specific product, SR_Level (RTM, SPn), and service branch (LDR, GDR) can be identified by examining the file version numbers as shown in the following table.

    Version Product SR_Level Service branch
    6.0.600
    2.
    22xxx
    Windows Vista and Windows Server 2008 SP2 LDR
For all supported x86-based versions of Windows Vista and of Windows Server 2008
File name File version File size Date Time Platform
Volsnap.sys 6.0.6002.18679 224,640 21-Aug-2012 11:47 x86
Volsnap.sys 6.0.6002.22913 225,664 21-Aug-2012 11:47 x86

      

For all supported x64-based versions of Windows Vista and of Windows Server 2008
File name File version File size Date Time Platform
Volsnap.sys 6.0.6002.18679 267,648 21-Aug-2012 11:50 x64
Volsnap.sys 6.0.6002.22913 268,160 21-Aug-2012 11:50 x64

      

For all supported IA-64-based versions of Windows Server 2008
File name File version File size Date Time Platform
Volsnap.sys 6.0.6002.18679 623,488 21-Aug-2012 11:44 IA-64
Volsnap.sys 6.0.6002.22913 626,048 21-Aug-2012 11:44 IA-64

      

Windows 7 and Windows Server 2008 R2 file information notes
Important Windows 7 updates and Windows Server 2008 R2 updates are included in the same packages. However, updates on the Update Request page are listed under both operating systems. To request the update package that applies to one or both operating systems, select the update that is listed under "Windows 7/Windows Server 2008 R2" on the page. Always refer to the "Applies To" section in articles to determine the actual operating system that each update applies to.

  • The files that apply to a specific product, SR_Level (RTM, SPn), and service branch (LDR, GDR) can be identified by examining the file version numbers as shown in the following table:

    Version Product Milestone Service branch
    6.1.760
    0.17xxx
    Windows 7 and Windows Server 2008 R2 RTM GDR
    6.1.760
    0.21xxx
    Windows 7 and Windows Server 2008 R2 RTM LDR
  • GDR service branches contain only those fixes that are widely released to address widespread, critical issues. LDR service branches contain updates in addition to widely released fixes.

For all supported x86-based versions of Windows 7
File name File version File size Date Time Platform
Volsnap.sys 6.1.7600.17122 245,616 06-Sep-2012 16:48 x86
Volsnap.sys 6.1.7600.21320 245,616 06-Sep-2012 19:18 x86

      

For all supported x64-based versions of Windows 7 and of Windows Server 2008 R2
File name File version File size Date Time Platform
Volsnap.sys 6.1.7600.17122 295,792 06-Sep-2012 17:38 x64
Volsnap.sys 6.1.7600.21320 296,304 06-Sep-2012 20:08 x64

      

For all supported IA-64-based versions of Windows Server 2008 R2
File name File version File size Date Time Platform
Volsnap.sys 6.1.7600.17122 677,232 06-Sep-2012 16:38 IA-64
Volsnap.sys 6.1.7600.21320 678,256 06-Sep-2012 19:21 IA-64

      

      

Status

Microsoft has confirmed that this is a problem in the Microsoft products that are listed in the "Applies to" section.

More Information

For more information about this issue, click the following article number to view the article in the Microsoft Knowledge Base:

976329 Error message when you run the ChkDsk.exe utility in read-only mode on a Windows-based computer: "The Volume Bitmap is incorrect" or "Error detected in index $I30 for file 5" For more information about software update terminology, click the following article number to view the article in the Microsoft Knowledge Base:

824684 Description of the standard terminology that is used to describe Microsoft software updates

The third-party products that this article discusses are manufactured by companies that are independent of Microsoft. Microsoft makes no warranty, implied or otherwise, about the performance or reliability of these products.