Applies ToWindows Server 2008 R2 Foundation Windows Server 2008 R2 Standard Windows Server 2008 R2 Enterprise Windows Server 2008 R2 Datacenter

Symptoms

Consider the following scenario:

  • You publish a RemoteApp application on a remote desktop server that is running Windows Server 2008 R2.

  • A user starts the published RemoteApp application on a client computer.

  • The user moves the published RemoteApp application's window to another on-screen location on the client computer.

In this scenario, the memory usage of the Rdpshell.exe process in the same session on the remote desktop server keeps increasing. Eventually, the available memory is completely exhausted on the remote desktop server. When this occurs, all the running applications and services on the remote desktop server stop working. To recover from this issue, the user has to close all of his or her RemoteApp applications on the server and then wait at least one minute for the session to end.Note If you monitor the memory usage of the Rdpshell.exe process, you find that the value of its Private Working Set performance counter keeps increasing.

Cause

This issue occurs because some allocated memory is not released correctly in the Rdpshell.exe process.

Resolution

Hotfix information

A supported hotfix is available from Microsoft. However, this hotfix is intended to correct only the problem that is described in this article. Apply this hotfix only to systems that are experiencing the problem described in this article. This hotfix might receive additional testing. Therefore, if you are not severely affected by this problem, we recommend that you wait for the next software update that contains this hotfix.If the hotfix is available for download, there is a "Hotfix download available" section at the top of this Knowledge Base article. If this section does not appear, contact Microsoft Customer Service and Support to obtain the hotfix. Note If additional issues occur or if any troubleshooting is required, you might have to create a separate service request. The usual support costs will apply to additional support questions and issues that do not qualify for this specific hotfix. For a complete list of Microsoft Customer Service and Support telephone numbers or to create a separate service request, visit the following Microsoft Website:

http://support.microsoft.com/contactus/?ws=supportNote The "Hotfix download available" form displays the languages for which the hotfix is available. If you do not see your language, it is because a hotfix is not available for that language.

Prerequisites

To apply this hotfix, you must be running one of the following operating systems:

  • Windows Server 2008 R2

  • Windows Server 2008 R2 Service Pack 1 (SP1)

For more information about how to obtain a Windows 7 or Windows Server 2008 R2 service pack, click the following article number to view the article in the Microsoft Knowledge Base:

976932 Information about Service Pack 1 for Windows 7 and for Windows Server 2008 R2

Registry information

To use the hotfix in this package, you do not have to make any changes to the registry.

Restart requirement

You must restart the computer after you apply this hotfix.

Hotfix replacement information

This hotfix does not replace a previously released hotfix.

File information

The global version of this hotfix installs files that have the attributes that are listed in the following tables. The dates and the times for these files are listed in Coordinated Universal Time (UTC). The dates and the times for these files on your local computer are displayed in your local time together with your current daylight saving time (DST) bias. Additionally, the dates and the times may change when you perform certain operations on the files.

Windows Server 2008 R2 file information notes

Important Windows 7 hotfixes and Windows Server 2008 R2 hotfixes are included in the same packages. However, hotfixes on the Hotfix Request page are listed under both operating systems. To request the hotfix package that applies to one or both operating systems, select the hotfix that is listed under "Windows 7/Windows Server 2008 R2" on the page. Always refer to the "Applies To" section in articles to determine the actual operating system that each hotfix applies to.

  • The files that apply to a specific product, SR_Level (RTM, SPn), and service branch (LDR, GDR) can be identified by examining the file version numbers as shown in the following table.

    Version

    Product

    SR_Level

    Service branch

    6.1.760 0. 16xxx

    Windows Server 2008 R2

    RTM

    GDR

    6.1.760 0. 21xxx

    Windows Server 2008 R2

    RTM

    LDR

    6.1.760 1. 17xxx

    Windows Server 2008 R2

    SP1

    GDR

    6.1.760 1. 21xxx

    Windows Server 2008 R2

    SP1

    LDR

  • The MANIFEST files (.manifest) and the MUM files (.mum) that are installed for each environment are listed separately in the "Additional file information for Windows Server 2008 R2" section. MUM and MANIFEST files, and the associated security catalog (.cat) files, are extremely important to maintain the state of the updated components. The security catalog files, for which the attributes are not listed, are signed with a Microsoft digital signature.

For all supported x64-based versions of Windows Server 2008 R2

File name

File version

File size

Date

Time

Platform

Rdpinit.exe

6.1.7601.21864

178,688

22-Nov-2011

06:23

x64

Rdpinit.mof

Not applicable

1,197

05-Nov-2010

02:01

Not applicable

Rdpshell.exe

6.1.7601.21864

300,032

22-Nov-2011

06:23

x64

Rdpshell.mof

Not applicable

1,200

05-Nov-2010

02:01

Not applicable

Tserrredir.dll

6.1.7601.17514

13,312

20-Nov-2010

13:27

x64

Rdpinit.exe

6.1.7601.21864

178,688

22-Nov-2011

06:23

x64

Rdpinit.mof

Not applicable

1,197

10-Jun-2009

20:44

Not applicable

Rdpshell.exe

6.1.7601.21864

300,032

22-Nov-2011

06:23

x64

Rdpshell.mof

Not applicable

1,200

10-Jun-2009

20:44

Not applicable

Terminalservices-remoteapplications-clientsku-ppdlic.xrm-ms

Not applicable

3,067

22-Nov-2011

06:42

Not applicable

Tserrredir.dll

6.1.7600.16385

13,312

14-Jul-2009

01:41

x64

Rdpinit.exe

6.1.7601.21864

162,304

22-Nov-2011

05:23

x86

Rdpinit.mof

Not applicable

1,197

05-Nov-2010

02:01

Not applicable

Rdpshell.exe

6.1.7601.21864

261,632

22-Nov-2011

05:23

x86

Rdpshell.mof

Not applicable

1,200

05-Nov-2010

02:01

Not applicable

Workaround

To work around this issue, log off the Remote Desktop Services session which is using the affected Rdpshell.exe process and then create a new session.Note To avoid fast reconnection, you can create a new session 20 seconds after you log off the affected Remote Desktop Services session.

Status

Microsoft has confirmed that this is a problem in the Microsoft products that are listed in the "Applies to" section.

More Information

For more information about software update terminology, click the following article number to view the article in the Microsoft Knowledge Base:

824684 Description of the standard terminology that is used to describe Microsoft software updates

Additional file information

Additional file information for Windows Server 2008 R2

Additional files for all supported x64-based versions of Windows Server 2008 R2

File name

Amd64_7dcb346eab4e3614579d1272522b57d7_31bf3856ad364e35_6.1.7601.21864_none_1f6cd03f68634548.manifest

File version

Not applicable

File size

737

Date (UTC)

22-Nov-2011

Time (UTC)

14:57

Platform

Not applicable

File name

Amd64_d0971b1fd44738244381203d873d941b_31bf3856ad364e35_6.1.7601.21864_none_e0e4cde48005f6ac.manifest

File version

Not applicable

File size

727

Date (UTC)

22-Nov-2011

Time (UTC)

14:57

Platform

Not applicable

File name

Amd64_ef15c4712d9eefb827a368c46cac8fad_31bf3856ad364e35_6.1.7601.21864_none_29956bf1e7c2bb36.manifest

File version

Not applicable

File size

727

Date (UTC)

22-Nov-2011

Time (UTC)

14:57

Platform

Not applicable

File name

Amd64_microsoft-windows-t..-remoteapplications_31bf3856ad364e35_6.1.7601.21864_none_a089d074cc474192.manifest

File version

Not applicable

File size

9,324

Date (UTC)

22-Nov-2011

Time (UTC)

15:40

Platform

Not applicable

File name

Amd64_microsoft-windows-t..lications-clientsku_31bf3856ad364e35_6.1.7601.21864_none_7d54b6c3760942f7.manifest

File version

Not applicable

File size

10,718

Date (UTC)

22-Nov-2011

Time (UTC)

15:40

Platform

Not applicable

File name

Update.mum

File version

Not applicable

File size

2,503

Date (UTC)

22-Nov-2011

Time (UTC)

14:57

Platform

Not applicable

File name

Wow64_microsoft-windows-t..-remoteapplications_31bf3856ad364e35_6.1.7601.21864_none_aade7ac700a8038d.manifest

File version

Not applicable

File size

6,618

Date (UTC)

22-Nov-2011

Time (UTC)

05:59

Platform

Not applicable

Need more help?

Want more options?

Explore subscription benefits, browse training courses, learn how to secure your device, and more.

Communities help you ask and answer questions, give feedback, and hear from experts with rich knowledge.