Unknown time zone information in a remote desktop session when you try to query the time zone information from a Windows 7 SP1-based client computer to a Windows Server 2008 R2-based RDS server

Windows Server 2008 R2 Service Pack 1Windows Server 2008 R2 EnterpriseWindows Server 2008 R2 Datacenter

Symptoms


Consider the following scenario:
  • You have a Windows Server 2008 R2 Service Pack 1 (SP1)-based Remote Desktop Services (RDS) server.
  • The Time Zone Redirection Group Policy setting is enabled on the server.
  • On a Windows 7 SP1-based client computer that is running a different-language version of Windows than the server, you use a remote desktop connection to connect the client computer to the server.
  • You try to query the time zone information by using the TimeDate.cpl Control Panel item in the remote desktop session.
In this scenario, the correct date and time are displayed in the remote desktop session. However, the Control Panel item cannot retrieve the client session's time zone information. Therefore, the time zone information is set to "unknown" in the remote desktop session. Additionally, the applications (for example, Microsoft Dynamics NAV or an application that is built based on the Java rt.jar source) that rely on the GetDynamicTimeZoneInformation API stop working.

Cause


This issue occurs because the GetDynamicTimeZoneInformation API does not redirect time zone information. In a remote desktop session, when time zone information is requested to be redirected, the system calls the older GetTimeZoneInformation API. The GetDynamicTimeZoneInformation API cannot return the time zone information in the remote desktop session. Therefore, the applications that use the GetDynamicTimeZoneInformation API may fail.

Note The GetDynamicTimeZoneInformation API is introduced in Windows Vista. It is available in Windows Vista, Windows Server 2008, or a later version of Windows.

For more information about the GetDynamicTimeZoneInformation API, go to the following Microsoft website:For more information about the GetTimeZoneInformation API, go to the following Microsoft website:

Resolution


Hotfix information

To resolve this issue, install this hotfix on the Windows 7 SP1-based client computer and the Windows Server 2008 R2-based server.

Note If you have update 2592687 installed on the Windows 7 SP1-based client computer, you do not have to install this hotfix on the client computer. For more information about update 2592687, click the following article number to view the article in the Microsoft Knowledge Base:
2592687 Description of the Remote Desktop Protocol 8.0 update for Windows 7 SP1 and Windows Server 2008 R2 SP1

A supported hotfix is available from Microsoft. However, this hotfix is intended to correct only the problem that is described in this article. Apply this hotfix only to systems that are experiencing the problem described in this article. This hotfix might receive additional testing. Therefore, if you are not severely affected by this problem, we recommend that you wait for the next software update that contains this hotfix.

If the hotfix is available for download, there is a "Hotfix download available" section at the top of this Knowledge Base article. If this section does not appear, contact Microsoft Customer Service and Support to obtain the hotfix.

Note If additional issues occur or if any troubleshooting is required, you might have to create a separate service request. The usual support costs will apply to additional support questions and issues that do not qualify for this specific hotfix. For a complete list of Microsoft Customer Service and Support telephone numbers or to create a separate service request, visit the following Microsoft website: Note The "Hotfix download available" form displays the languages for which the hotfix is available. If you do not see your language, it is because a hotfix is not available for that language.

Prerequisites

To apply this hotfix, you must be running Windows 7 SP1 or Windows Server 2008 R2 SP1.

For more information about how to obtain a Windows 7 or Windows Server 2008 R2 service pack, click the following article number to view the article in the Microsoft Knowledge Base:

976932 Information about Service Pack 1 for Windows 7 and for Windows Server 2008 R2

Registry information

To apply this hotfix, you do not have to make any changes to the registry.

Restart requirement

You must restart the computer after you apply this hotfix.

Hotfix replacement information

This hotfix does not replace a previously released hotfix.

Status


Microsoft has confirmed that this is a problem in the Microsoft products that are listed in the "Applies to" section.

More Information


For more information about software update terminology, click the following article number to view the article in the Microsoft Knowledge Base:

824684 Description of the standard terminology that is used to describe Microsoft software updates