Pages load slowly during a Remote Desktop Services session on a server that's running Windows Server

Applies to: Windows Server 2012 R2 DatacenterWindows Server 2012 R2 EssentialsWindows Server 2012 R2 Foundation More

Symptoms


Consider the following scenario:
  • You try to access a Microsoft SharePoint site from a virtual desktop session that uses Microsoft Office Communicator or Microsoft Lync to provide presence status for persons who are listed on the page.
  • The virtual desktop session is running on a Remote Desktop Services server that's running Windows Server 2012 R2, Windows Server 2008 R2, or Windows Server 2008.

In this scenario, it may take 10–45 seconds for a page to load. This time span depends on the number of users who have sessions on the server.

Cause


This problem occurs because of an issue in the CreateToolhelp32Snapshot function for querying the list of processes.

Resolution


To resolve this issue in Windows Server 2012 R2, install update 2919355.
To resolve this issue in Windows Server 2008 R2 and Windows Server 2008, install the hotfix that is described in this article.

Update information for Windows Server 2012 R2

For more information about how to obtain update 2919355, click the following article number to view the article in the Microsoft Knowledge Base:
2919355 Windows RT 8.1, Windows 8.1, and Windows Server 2012 R2 Update April, 2014

Hotfix information for Windows Server 2008 R2 and Windows Server 2008

A supported hotfix is available from Microsoft Support. However, this hotfix is intended to correct only the problem that is described in this article. Apply this hotfix only to systems that are experiencing the problem described in this article. This hotfix might receive additional testing. Therefore, if you are not severely affected by this problem, we recommend that you wait for the next software update that contains this hotfix.

If the hotfix is available for download, there is a "Hotfix download available" section at the top of this Knowledge Base article. If this section does not appear, contact Microsoft Customer Service and Support to obtain the hotfix.

Note If additional issues occur or if any troubleshooting is required, you might have to create a separate service request. The usual support costs will apply to additional support questions and issues that do not qualify for this specific hotfix. For a complete list of Microsoft Customer Service and Support telephone numbers or to create a separate service request, go to the following Microsoft website: Note The "Hotfix download available" form displays the languages for which the hotfix is available. If you do not see your language, it is because a hotfix is not available for that language.

Prerequisites

To apply this hotfix, you must have one of the following installed:

Restart requirement

You must restart the computer after you apply this hotfix.

Hotfix replacement information

This hotfix does not replace any previously released hotfix.

Status


Microsoft has confirmed that this is a problem in the Microsoft products that are listed in the "Applies to" section.

References


Learn about the terminology that Microsoft uses to describe software updates.