Sound is lost for a while on a MIDI device in Windows 8.1 or Windows 7

Applies to: Windows Server 2012 R2 DatacenterWindows Server 2012 R2 StandardWindows Server 2012 R2 Essentials

Symptoms


Consider the following scenario:

  • You have a computer that is running Windows RT 8.1, Windows 8.1, Windows Server 2012 R2, Windows 7 Service Pack 1 (SP1), or Windows Server 2008 R2 SP1.
  • You connect a MIDI device to the computer by using a USB-to-MIDI cable.
  • You run a MIDI application to send MIDI messages to the MIDI device.
In this scenario, some MIDI messages are lost, and you briefly cannot hear sound from the MIDI device.

Cause


This issue occurs because the MIDI driver does not handle the USB Request Blocks (URBs) correctly when it sends the MIDI messages.

How to obtain this update or hotfix


To resolve this issue, we have released hotfixes for Windows 7 or Windows Server 2008 R2, and we have released updates for Windows RT 8.1, Windows 8.1, or Windows Server 2012 R2.

Update for Windows 8.1 or Windows Server 2012 R2

The following update rollup is available.

For Windows 8.1 or Windows Server 2012 R2

Get update rollup 2919394

Hotfix for Windows 7 or Windows Server 2008 R2

A supported hotfix is available from Microsoft. However, this hotfix is intended to correct only the problem that is described in this article. Apply this hotfix only to systems that are experiencing this specific problem.

If the hotfix is available for download, there is a "Hotfix Download Available" section at the top of this Knowledge Base article. If this section does not appear, submit a request to Microsoft Customer Service and Support to obtain the hotfix.

Note If additional issues occur or if any troubleshooting is required, you might have to create a separate service request. The usual support costs will apply to additional support questions and issues that do not qualify for this specific hotfix. For a complete list of Microsoft Customer Service and Support telephone numbers or to create a separate service request, visit the following Microsoft website: Note The "Hotfix Download Available" form displays the languages for which the hotfix is available. If you do not see your language, it is because a hotfix is not available for that language.

Prerequisites

There are no prerequisites for installing this hotfix.

Registry information

To use the hotfix in this package, you do not have to make any changes to the registry.

Restart requirement

You may have to restart the computer after you apply this hotfix.

Hotfix replacement information

This hotfix does not replace a previously released hotfix.

More Information


For more information about software update terminology, click the following article number to view the article in the Microsoft Knowledge Base:  
824684 Description of the standard terminology that is used to describe Microsoft software updates.
For more information about MIDI, go the following Wikipedia website:


Status


Microsoft has confirmed that this is a problem in the Microsoft products that are listed in the "Applies to" section.