"The CA certificate could not be retrieved, element not found" error occurs when the CA server host name is longer than 52 characters

Applies to: Windows 8.1 EnterpriseWindows 8.1 ProWindows 8.1

Symptoms


If the Certification Authority (CA) server host name is longer than 52 characters, you receive the following error message when you select the CA name in Online Certificate Status Protocol (OCSP) revocation configuration:

The CA certificate could not be retrieved, element not found (exception from HRESULT: 0x80070490)

Cause


This problem occurs because OCSP searches the CA by the displayname field. In this case, the CA's displayname field is truncated if it is longer than 52 characters. This causes the CA object not to be found.

Resolution


To resolve this issue in Windows 8.1 or Windows Server 2012 R2, install update rollup 2962409, or install the hotfix that is described in this article.

To resolve this issue in Windows 7 or Windows Server 2008 R2, install the hotfix that is described in this article.

Update information

For more information about update rollup 2962409, click the following article number to view the article in the Microsoft Knowledge Base:
2962409 Windows RT 8.1, Windows 8.1, and Windows Server 2012 R2 update rollup: June 2014

Hotfix information

A supported hotfix is available from Microsoft Support. However, this hotfix is intended to correct only the problem that is described in this article. Apply this hotfix only to systems that are experiencing the problem described in this article. This hotfix might receive additional testing. Therefore, if you are not severely affected by this problem, we recommend that you wait for the next software update that contains this hotfix.

If the hotfix is available for download, there is a "Hotfix download available" section at the top of this Knowledge Base article. If this section does not appear, contact Microsoft Customer Service and Support to obtain the hotfix.

Note If additional issues occur or if any troubleshooting is required, you might have to create a separate service request. The usual support costs will apply to additional support questions and issues that do not qualify for this specific hotfix. For a complete list of Microsoft Customer Service and Support telephone numbers or to create a separate service request, go to the following Microsoft website: Note The "Hotfix download available" form displays the languages for which the hotfix is available. If you do not see your language, it is because a hotfix is not available for that language.

Prerequisites

To apply this hotfix, you must have Service Pack 1 for Windows 7 or Windows Server 2008 R2 installed.



Restart requirement

You do not have to restart the computer after you apply this hotfix.

Hotfix replacement information

This hotfix does not replace any previously released hotfix.

Status


Microsoft has confirmed that this is a problem in the Microsoft products that are listed in the "Applies to" section.

References


Learn about the terminology that Microsoft uses to describe software updates.