"Your request can't" error when accessing an archive mailbox via OWA in Exchange Server 2016

S’applique à : Exchange Server 2016 Enterprise EditionExchange Server 2016 Standard Edition

Symptoms


Consider the following scenario:

  • You install and upgrade to Microsoft Exchange Server 2016 Cumulative Update 6 (CU6).
  • You have a primary mailbox on-premise in Exchange Server 2016, and an archive mailbox is provisioned at Exchange Online.

  • You try to access the archive mailbox through Outlook Web App (OWA).

In this scenario, you receive the following error message:

"Your request can't be completed right now"

If you run the Test-ArchvieConnectivity cmdlet, you receive the following error message:

"Returns:
Cannot find row based on condition. There is no support for this operation.
MapiExceptionNoSupport: Unable to find table row. (hr=0x80040102, ec=-2147221246)"

Cause


This issue occurs because the immutableID property isn't well handled when you access archive mailboxes through OWA.

Resolution


To fix this issue, install Cumulative Update 8 for Exchange Server 2016 or a later cumulative update for Exchange Server 2016.

Status


Microsoft has confirmed that this is a problem in the Microsoft products that are listed in the "Applies to" section.

References


Learn about the terminology that Microsoft uses to describe software updates.