Prerequisite (KB2982006) not satisfied when you try to install Skype for Business Server 2015

Applies to: Skype for Business Server 2015

Symptoms


Assume that you run step 2 (Install or Update Skype for Business Server System > Setup or Remove Skype for Business Server Components) in Microsoft Skype for Business Server 2015 Deployment Wizard in Windows Server 2012 R2. You may find the Deployment Wizard can't check the prerequisite of KB2982006.
When this issue occurs, the installation of Skype for Business Server components fails, and you receive the following error message:

Prerequisite not satisfied: Before you install Skype for Business Server 2015, you must Install an update for Windows Server 2012 R2. For details about the update, see Microsoft Knowledge Base article 2982006, "IIS crashes occasionally when a request is sent to a default document in Windows 8.1 or Windows Server 2012 R2" at http://go.microsoft.com/fwlink/?LinkId=519376."

Cause


This issue occurs because the WMI query result of the prerequisite of KB2982006 isn't reliable.