Symptoms
Consider the following scenario:
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You create a mailbox for a user who will use a mobile device to connect to the mailbox.
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You access the mailbox by using Outlook on the web (OWA) and set up a device partnership (for example, synchronize with the mobile device) to confirm that the Exchange ActiveSync protocol works as expected.
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You move the user to another organizational unit (OU) from Active Directory Users and Computers.
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The user logs into the mailbox by using OWA.
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The user tries to remove the mobile device by using OWA > Options > phone > mobile devices.
In this situation, the user receives an error message that resembles the following:
"UserDisplayName/ExchangeActiveSyncDevices/DeviceName wasn't found. Please make sure you've typed it correctly."
Cause
This issue occurs because the information that's returned by the Get-MobileDeviceStatistics cmdlet doesn't match any longer after the changes in Active Directory. Therefore, the Remove-MobileDevice cmdlet issues a removal request by using incorrect data.
Resolution
To fix this issue, install Cumulative Update 9 for Exchange Server 2016 or a later cumulative update for Exchange Server 2016.
Status
Microsoft has confirmed that this is a problem in the Microsoft products that are listed in the "Applies to" section.
References
Learn about the terminology that Microsoft uses to describe software updates.