Sign in with Microsoft
Sign in or create an account.
Hello,
Select a different account.
You have multiple accounts
Choose the account you want to sign in with.

Symptoms

When you run Microsoft System Center 2012 R2 Configuration Manager Service Pack 1 or System Center 2012 Configuration Manager Service Pack 2 on a server, you may experience the following performance issue or race condition:

  • Performance issue

    After Conditional Access is enabled and deployed, and devices are enrolled and compliant with the compliance policies that are deployed, performance tests reveal up to a 10-minute delay to unblock devices so that they start to receive email messages. The unblocking of devices occurs when compliance messages are received through a fast channel. This processing had dependencies that caused delays.

    This update removes the dependencies on data and obtains this data from the fast compliance messages instead. This provides significant improvement in unblocking time. The unblocking time after the fix is typically less than 1 minute.

  • Race condition

    If you set up on-premises Conditional Access during the Exchange Connector's full/delta sync, a race condition may occur in a rare scenario. This prevents the Conditional Access Policy from taking effect.

    This issue occurs because hybrid conditional access may not be enabled during a full sync of the System Center Configuration Manager Exchange Connector. During the full sync, a shared SQL connection can sometimes prevent the Conditional Access Policy from writing against SQL.

    This update locks the SQL connection during the enabling of Conditional Access.


Cause

This issue occurs because hybrid conditional access cannot be enabled during a full sync of the System Center Configuration Manager Exchange Connector. During the full sync, a shared SQL connection prevents the conditional access policy from writing against SQL.

Resolution

Hotfix information

A supported hotfix is available from Microsoft. However, this hotfix is intended to correct only the problem that is described in this article. Apply this hotfix only to systems that are experiencing the problem described in this article. This hotfix might receive additional testing. Therefore, if you are not severely affected by this problem, we recommend that you wait for the next software update that contains this hotfix.

If the hotfix is available for download, there is a "Hotfix download available" section at the top of this Knowledge Base article. If this section does not appear, contact Microsoft Customer Service and Support to obtain the hotfix.

Note If additional issues occur or if any troubleshooting is required, you might have to create a separate service request. The usual support costs will apply to additional support questions and issues that do not qualify for this specific hotfix. For a complete list of Microsoft Customer Service and Support telephone numbers or to create a separate service request, go to the following Microsoft website:

http://support.microsoft.com/contactus/?ws=supportNote The "Hotfix download available" form displays the languages for which the hotfix is available. If you do not see your language, it is because a hotfix is not available for that language.

Prerequisites

To apply this hotfix, you must have one of the following installed:

  • System Center 2012 R2 Configuration Manager Service Pack 1

  • Cumulative Update 1 for System Center 2012 R2 Configuration Manager Service Pack 1

  • System Center 2012 Configuration Manager Service Pack 2

  • Cumulative Update 1 for System Center 2012 Configuration Manager Service Pack 2


Restart information

You do not have to restart the computer after you apply this hotfix.

Note We recommend that you close Configuration Manager Administration Console before you install this hotfix package.

Hotfix replacement information

This hotfix does not replace any previously released hotfix.

The English version of this hotfix has the file attributes (or later file attributes) that are listed in the following table. The dates and times for these files are listed in Coordinated Universal Time (UTC). When you view the file information, it is converted to local time. To find the difference between UTC and local time, use the Time Zone tab in the Date and Time item in Control Panel.

File name

File version

File size

Date

Time

Platform

Easdisc.dll

5.0.8239.1205

145,584

26-Jun-2015

01:25

x64

Microsoft.configurationmanager.dmpconnector.messagedownload.dll

5.0.8239.1205

44,720

26-Jun-2015

01:25

x86

Update.sql

Not applicable

10,229

26-Jun-2015

01:25

Not applicable


Status

Microsoft has confirmed that this is a problem in the Microsoft products that are listed in the "Applies to" section.

References

Learn about the terminology that Microsoft uses to describe software updates.

Need more help?

Want more options?

Explore subscription benefits, browse training courses, learn how to secure your device, and more.

Communities help you ask and answer questions, give feedback, and hear from experts with rich knowledge.

Was this information helpful?

What affected your experience?
By pressing submit, your feedback will be used to improve Microsoft products and services. Your IT admin will be able to collect this data. Privacy Statement.

Thank you for your feedback!

×