System requirements for Teams for personal use

You can use Teams for your personal life on your mobile or desktop device. These are the minimum requirements to use Teams.

Android phones and tablets:

Teams works with Android devices using the last four major OS versions. 

iPhones, iPads, and iPods:

Teams works with devices using iOS versions 11-14.

Note: For the best experience, use the latest version of iOS and Android.

Windows, Mac, and Web:

To check if your Windows or Mac meets the system requirements, please go to the Hardware requirements for Microsoft Teams page.

For a list of supported browsers, please go to the supported browsers for Teams page. 

Contact us

For more help, contact support or ask a question in the Microsoft Teams Community.

Need more help?

Expand your Office skills
Explore training
Get new features first
Join Office Insiders

Was this information helpful?

Thank you for your feedback!

Thank you for your feedback! It sounds like it might be helpful to connect you to one of our Office support agents.

×