The Detect language automatically option, available in Word and Outlook on Windows, detects the language that you are typing and automatically enables the proofing tools for that language. If you don't have that language already installed you will need to download the free Language Accessory Pack. See Language Accessory Pack for Office.

Detect language automatically

In Word 2019 and 2021 

  1. On the Review tab, select Language. 

  2. Review the languages shown above the double line in the Mark selected text as list. Office can detect only those languages listed above the double line. If the languages that you use are not shown above the double line, you must enable the editing language (turn on the language-specific options) so that Office can automatically detect them.

  3. Select OK.

In Outlook 2019 and 2021

  1. Open a new email message. 

    Note: In Outlook you have to open the message in its own window to get to the Review tab.

  2. Open Edit Language > select Language.

  3. Review the languages shown above the double line in the Mark selected text as list. Office can detect only those languages listed above the double line. If the languages that you use are not shown above the double line, you must enable the editing language (turn on the language-specific options) so that Office can automatically detect them.

  4. Select OK.

In Word  

  1. Open a new document.

  2. Right-click anywhere in the document and select Set Proofing Language. 

  3. Review the languages shown above the double line in the Mark selected text as list. Office can detect only those languages listed above the double line. If the languages that you use are not shown above the double line, you must enable the editing language (turn on the language-specific options) so that Office can automatically detect them.

  4. Select OK.

In Outlook  

  1. Open a new email message. 

    Note: In Outlook you have to open the message in its own window to get to the Review tab.

  2. Select ... and then open Editor > Editor Settings

  3. Review the languages shown above the double line in the Mark selected text as list. Office can detect only those languages listed above the double line. If the languages that you use are not shown above the double line, you must enable the editing language (turn on the language-specific options) so that Office can automatically detect them.

  4. Select OK.

In Outlook 2019 and 2021 and Word 2019 and 2021 

  1. Open a new document or email message. 

    Note: In Outlook you have to open the message in its own window to get to the Review tab.

  2. On the Review tab, in the Language group, click Language.

  3. Click Set Proofing Language.

  4. In the Language dialog box, select the Detect language automatically check box.

  5. Review the languages shown above the double line in the Mark selected text as list. Office can detect only those languages listed above the double line. If the languages that you use are not shown above the double line, you must enable the editing language (turn on the language-specific options) so that Office can automatically detect them.

  6. Select OK.

In Outlook 2010, 2013, and 2016 and Word 2010, 2013 and 2016

  1. Open a new document or email message.

    Note: In Outlook you have to open the message in its own window to get to the Review tab.

  2. On the Review tab, in the Language group, click Language.

  3. Click Set Proofing Language.

  4. In the Language dialog box, select the Detect language automatically check box.

  5. Review the languages shown above the double line in the Mark selected text as list. Office can detect only those languages listed above the double line. If the languages that you use are not shown above the double line, you must enable the editing language (turn on the language-specific options) so that Office can automatically detect them.

Tip: You can get to Set Proofing Language by going to the Microsoft Search box at the top of the window, typing Language, and selecting Language Options > Set Proofing Language.

Notes: 

  • Automatic language detection requires a sentence of text to accurately identify the correct language. Depending on the length of your sentences, you might need to type several sentences before Office has enough contextual information to detect the language and apply the correct dictionary.

  • Words that are spelled the same way in several languages, such as "centre" in English (United Kingdom) and French (France), might cause incorrect language identification. To solve this problem, type more words in the language that you want, or clear the Detect language automatically check box.

Top of Page

See also

Check spelling and grammar in a different language

Need more help?

Expand your skills

EXPLORE TRAINING >

Get new features first

JOIN MICROSOFT INSIDERS >

Was this information helpful?

What affected your experience?

Thank you for your feedback!

×