Update Rollup 2 for Microsoft Azure Backup Server V4

Applies to: Microsoft Azure Backup Server V4

Introduction

This article describes the issues that are fixed in Update Rollup 2 for Microsoft Azure Backup Server V4 (MABS V4). This article also contains the installation instructions for this update.

Note

Existing Microsoft Azure Backup Server customers should upgrade to the latest agent (version 2.0.9249.0 or later). If the latest agent is not installed, online backups may fail, and no Microsoft Azure Backup Server operation will work. 

Issues that are fixed

This update fixes the following issues:

  • Updated the timezone calculation algorithm for file timestamps to ensure that the timestamp displayed in the Recover UI for backed-up file is correct. It should same as file backup time.
  • Enhanced and corrected the connection logic to fully support SQL Server forced encryption configurations, enabling proper SSL/TLS negotiation and encrypted communication channels.
  • Fixed SharePoint Item Level Restore (ILR) operations fail with error 32016 (Unknown error 0x80131513).
  • Added logic to validate shadow copy schedule properties for null values and initialize them from existing schedules or as empty lists before UI operations. To avoid UI crashes and disappears while SQL Workload is being protected.
  • Fixed DPM Exchange Component Enumeration Failure (Error 964). Added a registry-based fallback in GetApplicationVersion(). When COM fails, Exchange version is retrieved from registry keys.
  • Fixed DPMAccessManager Crash issue When Re-Cataloging Imported Tapes Containing VMware VM Backups from Different DPM Servers.
  • Fixed PowerShell Protection Group Creation Crash issue by and NullReferenceException Check when calling Set-DPMProtectionGroup or related cmdlets for disk-based protection groups.
  • Fixed DPM Console crashes when creating a Protection Group with Online protection enabled and users check and uncheck protection content selections.
  • Add retry logic to handle transient timeout errors when attaching VHD files in the Hyper-V VHD helper.
  • Fixed NullReferenceException in SQL alternate location restore with LocationMapping.
  • Fixed a crash during storage-to-storage migration by excluding the MigrateDatasourceDataFromStorageToStorage parameter set from the client datasource presence check.
  • Fixed the issue where the weekly online backup schedule was displayed incompletely.
  • Fixed the issue where the Storage consumed value in the DPM Console’s replica details was displayed incorrectly.
  • Fixed the ACCESS_DENIED error that could interrupt backup operations when files were deleted after replica creation.
  • Fixed traditional Chinese/Korean characters in RibbonMenu drawing issue.

Note

A fresh installation of the Update Rollup agent could cause a restart of the protected server.

Other Improvements and Features

  • In addition to the above fixes, all the issues fixed in SCDPM 2022 UR3 and DPM 2025 UR1 are also included MABSV4 UR2.
  • MABS V4 UR2 also has additional new features introduced. For details on the new features, refer to the documentation here.

Known issues

  • Once the patch extracts, the Patch UI might not show-up. This is due to Visual C++ Redistributable updating runtime files existing on system and a restart is required to take the effect. If so, please restart the machine and try running package one more time.
  • MABS V4 UR2 installs VC++ 2015–2022 Redistributable version 14.38.33135. If a newer version is already installed, no action is needed—the installation will proceed without modification. If an older version exists, it will be automatically upgraded to 14.38.33135 during MABS installation.

How to obtain Update Rollup 2 for Microsoft Azure Backup Server V4

Update packages for Microsoft Azure Backup Server are available from Microsoft Update or by manual download.

Microsoft Update

  1. To obtain and install an update package from Microsoft Update, follow these steps on a computer that has a Microsoft Azure Backup Server component installed:
  2. Select Start, and then select Control Panel.
  3. In Control Panel, double-click Windows Update.
  4. In the Windows Update window, select Check Online for updates from Microsoft Update.
  5. Select Important updates are available.
  6. Select the Update Rollup package, and then select OK.
  7. Select Install updates to install the update package.

Note

MU update might fail initially as shown below or with a different error code. This is due to Visual C++ Redistributable updating runtime files existing on system and a restart is required to take the effect. If so, please restart the machine and try Install Updates one more time.

There were some problems installing updates, but we'll try again later.
If you keep seeing this and want to search the web or contact support for information, this may help: (0x80070643)

Manual download

Go to the following website to manually download the update package from the Microsoft Update Catalog: Download the Microsoft Azure Backup Server update package now.

For information about how to download Microsoft support files, select the following article number to view the article in the Microsoft Knowledge Base:

119591: How to obtain Microsoft support files from online services.

Virus-scan claim

Microsoft scanned this file for viruses, using the most current virus-detection software that was available on the date that the file was posted. The file is stored on security-enhanced servers that help prevent any unauthorized changes to it.

Installation instructions for Microsoft Azure Backup Server

To install this update for Microsoft Azure Backup Server, follow these steps:

  1. Before you install this update, make a backup of the Microsoft Azure Backup Server database.
  2. Install this rollup package on the server that's running Microsoft Azure Backup Server V4. To do this, run Microsoft Update on the server, from the download bit run package **MicrosoftAzureBackup-KB5120099.exe"
  3. In the Microsoft Azure Backup Server Administrator Console, update the protection agents. To do this, use one of the following methods.

Note

You need to restart protected servers to create or change protection groups.

Method 1: Update the protection agents from the Microsoft Azure Backup Server Administrator Console

  1. Open the Microsoft Azure Backup Server Administrator Console.

  2. Select the Management tab, and then select the Agents tab.

    1. In the Protected Computer list, select a computer, and then select Update on the Action pane.
  3. Select Yes, and then select Update Agents.

Method 2: Update the protection agents on the protected servers

  1. Obtain the updated protection agent package from the installation directory of the Microsoft Azure Backup Server at following path: Microsoft Azure Backup Server V4\DPM\DPM\agents\RA\14.0.65.0\amd64\1033\ DPMAgentInstaller_ KB5120099_AMD64.exe
  2. Run the DPMAgentInstaller_ KB5120099_AMD64.exe package on each protected server.
  3. Open the Administrator Console on the Microsoft Azure Backup Server V4.
  4. Select the Management tab, and then select the Agents tab. Select the protected server, refresh the information, and then verify that the agent version number is 14.0.65.0