"The following SQL Server error or errors occurred when accessing the [TableName] table" message when you change the SQL Data Type property for a field in a table in Microsoft Dynamics NAV 2009

Applies To
Dynamics NAV 2009

This article applies to Microsoft Dynamics NAV for all countries and all language locales.

Symptoms

When you change the SQL Data Type property for a field in a table in Microsoft Dynamics NAV 2009, you receive the following error message:

Note

The following SQL Server error or errors occurred when accessing the TableName table: 102,"42000",[Microsoft][ODBC SQL Server Driver][SQL Server]Incorrect syntax near 'Characters'.

Note The TableName placeholder represents the actual Microsoft Dynamics NAV table name and the Characters placeholder represents several random characters from an SQL statement.

This problem occurs if the table name or the relevant field name is unusually long. This problem occurs in the following products:

  • Microsoft Dynamics NAV 2009 R2
  • Microsoft Dynamics NAV 2009 Service Pack 1

Cause

This problem occurs because the long table name or the long field name causes an overflow of the buffer. The buffer is available to contain the SQL statement that applies the change to the underlying table.

Resolution

Hotfix information

A supported hotfix is available from Microsoft. There is a "Hotfix download available" section at the top of this Knowledge Base article. If you are encountering an issue downloading, installing this hotfix, or have other technical support questions, contact your partner or, if enrolled in a support plan directly with Microsoft, you can contact technical support for Microsoft Dynamics and create a new support request. To do this, visit the following Microsoft website:

https:⁠//mbs.microsoft.com/support/newstart.aspx You can also contact technical support for Microsoft Dynamics by phone using these links for country specific phone numbers. To do this, visit one of the following Microsoft websites:

Partners

https:⁠//mbs.microsoft.com/partnersource/support/ Customers

https:⁠//mbs.microsoft.com/customersource/support/information/SupportInformation/global_support_contacts_eng.htm In special cases, charges that are ordinarily incurred for support calls may be canceled if a Technical Support Professional for Microsoft Dynamics and related products determines that a specific update will resolve your problem. The usual support costs will apply to any additional support questions and issues that do not qualify for the specific update in question.

How to obtain the Microsoft Dynamics NAV hotfix or update files

After you request a Microsoft Dynamics NAV hotfix, a hyperlink will be sent to you in an e-mail.

The e-mail will contain a hyperlink and a password. You can use the hyperlink to download the Microsoft Dynamics NAV hotfix or the update files. When you click the hyperlink, the File Download – Security Warning dialog box opens. Then, you are prompted to run, to save, or to cancel the download.

If you click Run, the files start the download and the extraction process. You must specify a folder for the new files, and then provide the password.

If you click Save, you must specify a path for saving the compressed file. When you open the file that you saved, you are prompted to specify a path for the files. Then, you must provide the password provided in the e-mail.

If you click Cancel, the download process stops.

How to install a Microsoft Dynamics NAV hotfix or an update file

The Microsoft Dynamics NAV platform hotfixes and updates are made available as single files. To install a Microsoft Dynamics NAV hotfix or an update, you must replace the existing Microsoft Dynamics NAV installation files with the hotfix or the update files. To do this, follow these steps.

Step 1: Replace the files in the Microsoft Dynamics NAV Classic Client installation

In the Microsoft Dynamics NAV Classic Client installation, replace the following files by using the hotfix or the update file.

File name File version File size Date Time Platform
Dbm.dll 6.0.33869.0 313,552 01-Oct-2012 02:14 x86
Fin.exe 6.0.33869.0 12,603,600 01-Oct-2012 02:04 x86
Finhlink.exe 6.0.33869.0 452,824 01-Oct-2012 02:14 x86
Finsql.exe 6.0.33869.0 12,738,264 01-Oct-2012 02:04 x86
Microsoft.dynamics.nav.dotnetbridge.dll 6.0.33869.0 208,144 01-Oct-2012 02:04 x86
Microsoft.dynamics.nav.transformation.reporting.dll 6.0.33869.0 114,472 01-Oct-2012 02:04 x86
Nc_netb.dll 6.0.33869.0 17,112 01-Oct-2012 02:14 x86
Nc_tcp.dll 6.0.33869.0 19,160 01-Oct-2012 02:14 x86
Nc_tcps.dll 6.0.33869.0 25,816 01-Oct-2012 02:14 x86
Ndbcs.dll 6.0.33869.0 1,140,944 01-Oct-2012 02:14 x86
Slave.exe 6.0.33869.0 38,608 01-Oct-2012 02:14 x86

To replace the existing Microsoft Dynamics NAV files, follow these steps:

  1. Close the Microsoft Dynamics NAV Classic Client.

  2. Locate the Microsoft Dynamics NAV Classic Client installation directory. The Microsoft Dynamics NAV Classic Client is usually installed in the following directory:

    C:\Program Files\Microsoft Dynamics NAV\60\Classic

  3. Copy the files that you downloaded.

  4. Paste the files that you downloaded into the Microsoft Dynamics NAV Classic Client installation directory.

  5. Click Yes to overwrite the files in the directory.

Step 2: Replace the files in the Microsoft Dynamics NAV RoleTailored client installation

In the Microsoft Dynamics NAV RoleTailored client installation, replace the following files by using the hotfix or the update file.

File name File version File size Date Time Platform
Microsoft.dynamics.framework.patterns.dll 1.3.10803.1047 72,048 29-Sep-2012 21:30 x86
Microsoft.dynamics.framework.ui.dll 1.3.10803.1047 702,816 29-Sep-2012 21:30 x86
Microsoft.dynamics.framework.ui.mapping.dll 1.3.10803.1047 104,816 29-Sep-2012 21:30 x86
Microsoft.dynamics.framework.ui.navigation.dll 1.3.10803.1047 35,192 29-Sep-2012 21:30 x86
Microsoft.dynamics.framework.ui.ux2006.dll 1.3.10803.1047 92,528 29-Sep-2012 21:30 x86
Microsoft.dynamics.framework.ui.ux2006.winforms.dll 1.3.10803.1047 67,968 29-Sep-2012 21:30 x86
Microsoft.dynamics.framework.ui.windows.dll 1.3.10803.1047 84,336 29-Sep-2012 21:30 x86
Microsoft.dynamics.framework.ui.winforms.controls.dll 1.3.10803.1047 2,222,472 29-Sep-2012 21:30 x86
Microsoft.dynamics.framework.ui.winforms.dll 1.3.10803.1047 1,173,872 29-Sep-2012 21:30 x86
Microsoft.dynamics.nav.client.builder.dll 6.0.33869.0 211,216 01-Oct-2012 02:03 x86
Microsoft.dynamics.nav.client.exe 6.0.33869.0 149,760 01-Oct-2012 02:03 x86
Microsoft.dynamics.nav.client.serviceconnection.dll 6.0.33869.0 112,936 01-Oct-2012 02:03 x86
Microsoft.dynamics.nav.client.ui.dll 6.0.33869.0 542,984 01-Oct-2012 02:03 x86
Microsoft.dynamics.nav.client.winforms.dll 6.0.33869.0 358,680 01-Oct-2012 02:03 x86
Microsoft.dynamics.nav.client.winforms.tlb Not applicable 2,680 30-Sep-2012 22:42 Not applicable
Microsoft.dynamics.nav.language.dll 6.0.33869.0 2,021,640 01-Oct-2012 02:03 x86
Microsoft.dynamics.nav.types.dll 6.0.33869.0 592,128 01-Oct-2012 02:03 x86
Microsoft.dynamics.nav.watson.dll 6.0.33869.0 43,264 01-Oct-2012 02:03 x86
Microsoft.office.interop.outlook.dll 10.0.4504.0 395,528 01-Oct-2012 02:14 x86

To replace these files, follow these steps:

  1. Close the Microsoft Dynamics NAV RoleTailored client.

  2. Locate the Microsoft Dynamics NAV RoleTailored client installation directory. The Microsoft Dynamics NAV RoleTailored client is usually installed in the following directory:

    C:\Program Files\Microsoft Dynamics NAV\60\RoleTailored Client

  3. Copy the files that you downloaded.

  4. Paste the files that you downloaded into the Microsoft Dynamics NAV RoleTailored client installation directory.

  5. Click Yes to overwrite the files in the directory.

Step 3: Replace the files in the Microsoft Dynamics NAV Server installation

In the Microsoft Dynamics NAV Server installation, replace the following files by using the hotfix or the update file.

File name File version File size Date Time Platform
Httpcfg.exe 5.2.3790.0 22,744 01-Oct-2012 02:14 x86
Microsoft.dynamics.nav.language.dll 6.0.33869.0 2,021,640 01-Oct-2012 02:03 x86
Microsoft.dynamics.nav.ncl.dll 6.0.33869.0 641,280 01-Oct-2012 02:03 x86
Microsoft.dynamics.nav.server.exe 6.0.33869.0 141,568 01-Oct-2012 02:03 x86
Microsoft.dynamics.nav.service.dll 6.0.33869.0 149,768 01-Oct-2012 02:03 x86
Microsoft.dynamics.nav.service.runtime.dll 6.0.33869.0 76,056 01-Oct-2012 02:03 x86
Microsoft.dynamics.nav.service.webservices.dll 6.0.33869.0 149,792 01-Oct-2012 02:03 x86
Microsoft.dynamics.nav.types.dll 6.0.33869.0 592,128 01-Oct-2012 02:03 x86
Microsoft.dynamics.nav.watson.dll 6.0.33869.0 43,264 01-Oct-2012 02:03 x86
Nclcsrt.etx Not applicable 90,329 30-Sep-2012 18:03 Not applicable
Nclcsrt.stx Not applicable 92,128 30-Sep-2012 18:03 Not applicable
Nclcsrts.dll 6.0.33869.0 1,456,344 01-Oct-2012 02:14 x86
Ndbcs.dll 6.0.33869.0 1,140,944 01-Oct-2012 02:14 x86

To replace these files, follow these steps:

  1. Stop the Microsoft Dynamics NAV Server.

  2. Locate the Microsoft Dynamics NAV Server installation directory. The Microsoft Dynamics NAV Server is usually installed in the following directory:

    C:\Program Files\Microsoft Dynamics NAV\60\Service

  3. Copy the files that you downloaded.

  4. Paste the files that you downloaded into the Microsoft Dynamics NAV Server installation directory.

  5. Click Yes to overwrite the files in the directory.

  6. Start the Microsoft Dynamics NAV Server.

Step 4: Replace the files in the Microsoft Dynamics NAV Database Server installation

If you have Microsoft Dynamics NAV Database Server installed, replace the following files in the Microsoft Dynamics NAV Database Server installation by using the hotfix or the update files.

Note If you are running the SQL Server option, skip this step.

File name File version File size Date Time Platform
Atl71.dll 7.10.3077.0 95,440 01-Oct-2012 02:14 x86
Dbm.dll 6.0.33869.0 313,552 01-Oct-2012 02:13 x86
Fin.etx Not applicable 190,020 30-Sep-2012 17:34 Not applicable
Fin.stx Not applicable 220,559 30-Sep-2012 17:34 Not applicable
Hotcopy.exe 6.0.33869.0 927,960 01-Oct-2012 02:14 x86
Navdbmsnapin.msc Not applicable 63,130 29-Mar-2012 22:39 Not applicable
Ndsm.dll 6.0.33869.0 563,920 01-Oct-2012 02:14 x86
Ndsmcontrol.dll 6.0.33869.0 430,816 01-Oct-2012 02:14 x86
Server.exe 6.0.33869.0 1,167,064 01-Oct-2012 02:14 x86
Slave.exe 6.0.33869.0 38,608 01-Oct-2012 02:13 x86
Stopsrv.exe 6.0.33869.0 744,664 01-Oct-2012 02:14 x86

To replace the files, follow these steps.

  1. Stop the Microsoft Dynamics NAV Database Server.

  2. Locate the Microsoft Dynamics NAV Database Server installation directory. The Microsoft Dynamics NAV Database Server is usually installed in the following directory:
    C:\Program Files\Microsoft Dynamics NAV\60\Database Server

  3. Copy the files that you downloaded.

  4. Paste the files that you downloaded to the Microsoft Dynamics NAV Database Server installation directory.

  5. Click Yes to overwrite the files in the installation directory.

  6. Start the Microsoft Dynamics NAV Database Server.

Step 5: Replace the files in the Microsoft Dynamics NAV Application Server installation

If you have Microsoft Dynamics NAV Application Server installed, replace the following files in the Microsoft Dynamics NAV Application Server installation by using the hotfix or the update files.

File name File version File size Date Time Platform
Dbm.dll 6.0.33869.0 313,552 01-Oct-2012 02:14 x86
Nas.exe 6.0.33869.0 2,200,784 01-Oct-2012 02:04 x86
Nassql.exe 6.0.33869.0 2,309,848 01-Oct-2012 02:04 x86
Ndbcs.dll 6.0.33869.0 1,140,944 01-Oct-2012 02:14 x86
Slave.exe 6.0.33869.0 38,608 01-Oct-2012 02:14 x86

To replace the files, follow these steps.

  1. Stop the Microsoft Dynamics NAV Application Server.

  2. Locate the Microsoft Dynamics NAV Application Server installation directory. The Microsoft Dynamics NAV Application Server is usually installed in the following directory:

    C:\Program Files\Microsoft Dynamics NAV\60\Application Server

  3. Copy the files that you downloaded.

  4. Paste the files that you downloaded into the Microsoft Dynamics NAV Application Server installation directory.

  5. Click Yes to overwrite the files in the directory.

  6. Start the Microsoft Dynamics NAV Application Server.

Step 6: Replace the files in the Microsoft Dynamics NAV SDK installation

If you have Microsoft Dynamics NAV SDK installed, replace the following files.

File name File version File size Date Time Platform
Cf.h Not applicable 57,950 30-Sep-2012 22:42 Not applicable
Cfront.dll 6.0.33869.0 1,432,280 01-Oct-2012 02:14 x86
Cfront.ocx 6.0.33869.0 112,856 01-Oct-2012 02:14 x86
Cfrontsql.dll 6.0.33869.0 1,644,760 01-Oct-2012 02:14 x86
Libload.c Not applicable 31,718 30-Sep-2012 16:29 Not applicable
Microsoft.dynamics.nav.cfront.cfrontdotnet.dll 6.0.33869.0 182,560 01-Oct-2012 02:04 x86
Microsoft.dynamics.nav.cfront.cfrontdotnet.xml Not applicable 443,045 30-Sep-2012 16:49 Not applicable
Sample.c Not applicable 28,718 30-Sep-2012 16:29 Not applicable
Sample.exe 6.0.33869.0 32,984 01-Oct-2012 02:14 x86

To replace the files, follow these steps.

  1. Locate the Microsoft Dynamics NAV SDK installation directories. The Microsoft Dynamics NAV SDK is usually installed in the following directories:

    C:\Program Files\Microsoft Dynamics NAV\60\SDK\CFRONT
    C:\Program Files\Microsoft Dynamics NAV\60\SDK\Communication Components
    C:\Program Files\Common Files\Microsoft Dynamics NAV\Communication Component

  2. Choose the SDK to update, either C/Front or Communication Components.

  3. Copy the files that you downloaded.

  4. Paste the files that you downloaded into the appropriate Microsoft Dynamics NAV SDK installation directory.

  5. Click Yes to overwrite the files in the directory.

Note If you downloaded a hotfix or an update for the communication components, you must register the .dll files individually.

Step 7: Replace the files in the Microsoft Dynamics NAV ODBC driver installation

If you have the Microsoft Dynamics NAV ODBC driver installed, replace the following files in the Microsoft Dynamics NAV ODBC driver installation.

File name File version File size Date Time Platform
Cfront.dll 6.0.33869.0 1,432,280 01-Oct-2012 02:14 x86
Dbm.dll 6.0.33869.0 313,552 01-Oct-2012 02:14 x86
Nc_netb.dll 6.0.33869.0 17,112 01-Oct-2012 02:14 x86
Nc_tcp.dll 6.0.33869.0 19,160 01-Oct-2012 02:14 x86
Nc_tcps.dll 6.0.33869.0 25,816 01-Oct-2012 02:14 x86
Nodbc.dll 6.0.33869.0 2,144,464 01-Oct-2012 02:14 x86
Nodbc.xml Not applicable 1,209 29-Mar-2012 22:38 Not applicable
Nodbccfg.cfg 6.0.33869.0 726,016 30-Sep-2012 17:38 Not applicable
Nodbccfg.xml Not applicable 2,538 29-Mar-2012 22:38 Not applicable
Slave.exe 6.0.33869.0 38,608 01-Oct-2012 02:14 x86

To replace the files, follow these steps.

  1. Locate the Microsoft Dynamics NAV ODBC driver installation directory. The Microsoft Dynamics NAV ODBC driver is usually installed in the following directory:

    C:\Program Files\Microsoft Dynamics NAV\60\ODBC

  2. Copy the files that you downloaded.

  3. Paste the files that you downloaded into the Microsoft Dynamics NAV ODBC driver installation directory.

  4. Click Yes to overwrite the files in the directory.

Step 8: Replace the Communication Component

Replace the following files.

File name File version File size Date Time Platform
Msmqbusadapter.dll 6.0.33869.0 283,880 01-Oct-2012 02:14 x86
Npipebusadapter.dll 6.0.33869.0 257,256 01-Oct-2012 02:14 x86
Nscomcom2.dll 6.0.33869.0 237,784 01-Oct-2012 02:14 x86
Socketbusadapter.dll 6.0.33869.0 281,832 01-Oct-2012 02:14 x86

To replace the files, follow these steps.

  1. Locate the Communication Component directory. The communication component is usually installed in the following directory:

    C:\Program Files\Common Files\Microsoft Dynamics NAV\Communication Component

  2. Copy the files that you downloaded.

  3. Paste the files that you downloaded into the Microsoft Dynamics NAV Communication Component directory.

  4. Click Yes to overwrite the files in the directory.

Prerequisites

You must have one of the following products installed to apply this hotfix:

  • Microsoft Dynamics NAV 2009 R2
  • Microsoft Dynamics NAV 2009 Service Pack 1

Special note for Microsoft Dynamics NAV 2009 Service Pack 1
Before you apply this hotfix to a Microsoft Dynamics NAV 2009 Service Pack 1 installation, make sure that the current Microsoft Dynamics NAV 2009 SP1 installation has build number 32074 or a later build number. For more information, visit one of the following Microsoft websites, depending on whether you are a partner or a customer:
Partner

Combined Hotfix Release for Microsoft Dynamics NAV 2009 SP1 and Microsoft Dynamics NAV 2009 R2 Customer

Combined Hotfix Release for Microsoft Dynamics NAV 2009 SP1 and Microsoft Dynamics NAV 2009 R2
If the build number of the current Microsoft Dynamics NAV 2009 Service Pack 1 installation is less than 32074, you must perform one of the following steps before you can install this hotfix:

  • Install hotfix 2496107. For more information, click the following article number to view the article in the Microsoft Knowledge Base:

    2496107 Platform hotfix resource files for Microsoft Dynamics NAV 2009 Service Pack 1

  • Perform a solution upgrade to Microsoft Dynamics NAV 2009 R2. For more information about how to perform a solution upgrade from Microsoft Dynamics NAV 2009 Service Pack 1 to Microsoft Dynamics NAV 2009 R2, visit the following Microsoft website:
    Install and Upgrade Instructions for Microsoft Dynamics NAV 2009 R2

For information about how to find the build number in Microsoft Dynamics NAV, visit one of the following Microsoft websites, depending on whether you are a partner or a customer:
Partner

How to Find the Build Number in Microsoft Dynamics NAV Customer

How to Find the Build Number in Microsoft Dynamics NAV

Status

Microsoft has confirmed that this is a problem in the Microsoft products that are listed in the "Applies to" section.

More Information

For more information, click the following article number to view the article in the Microsoft Knowledge Base:

824684 Description of the standard terminology that is used to describe Microsoft software updates

Note This is a "FAST PUBLISH" article created directly from within the Microsoft support organization. The information contained herein is provided as-is in response to emerging issues. As a result of the speed in making it available, the materials may include typographical errors and may be revised at any time without notice. See Terms of Use for other considerations.