You cannot determine which fields are available and which fields are unavailable when you open a dialog box in Microsoft Dynamics NAV

Microsoft Business Solutions-Navision 4.0 and Microsoft Navision 4.0 are now part of Microsoft Dynamics NAV 4.0. All references to Microsoft Business Solutions-Navision or to Microsoft Navision 4.0 relate to Microsoft Dynamics NAV.

This article applies to Microsoft Dynamics NAV 4.0 for all regions.

Symptoms

When you open a dialog box in Microsoft Dynamics NAV, you cannot determine which fields are available and which fields are unavailable because all the fields appear to be available. This problem occurs if the following conditions are true:

  • You are using Microsoft Dynamics NAV on a Windows Vista-based computer.
  • The Windows Aero color scheme is enabled on the computer.

For example, this problem occurs when you open the Customer Card dialog box in Microsoft Dynamics NAV. When you do this, the Balance field and the Credit Limit field have the same color. However, the Balance field should appear dimmed because it is unavailable.

Cause

This problem occurs because Microsoft Dynamics NAV uses Windows controls that have a different appearance when the computer is running Windows Vista.

Resolution

Hotfix information

A supported hotfix is now available from Microsoft. The hotfix corrects the problem that is described in this article. Apply the hotfix only to systems that are experiencing this specific problem.

To resolve this problem immediately, contact Technical Support for Microsoft Dynamics and related products to obtain the hotfix. You can log on to the Microsoft Dynamics site and create a new support request. To do this, visit the following Microsoft Web site:

https:⁠//mbs.microsoft.com/support/newstart.aspx You can also contact Technical Support for Microsoft Dynamics and related products by telephone at (888) 477-7877.

Note In special cases, charges that are ordinarily incurred for support calls may be canceled if a Technical Support Professional for Microsoft Dynamics and related products determines that a specific update will resolve your problem. The usual support costs will apply to any additional support questions and issues that do not qualify for the specific update in question.

How to obtain the Microsoft Dynamics NAV hotfix or update files

After you request a Microsoft Dynamics NAV hotfix or an update file from Technical Support for Microsoft Dynamics, a hyperlink will be sent to you in an e-mail.

The e-mail will contain a hyperlink and a password. You can use the hyperlink to download the Microsoft Dynamics NAV hotfix or the update files. When you click the hyperlink, the File Download – Security Warning dialog box opens. Then, you are prompted to run, to save, or to cancel the download.

If you click Run, the files start the download and the extraction process. You must specify a folder for the new files, and then provide the password.

If you click Save, you must specify a path for saving the compressed file. When you open the file that you saved, you are prompted to specify a path for the files. You must then provide the password provided in the e-mail.

If you click Cancel, the download process stops.

How to install a Microsoft Dynamics NAV hotfix or update file

The Microsoft Dynamics NAV platform hotfixes and updates are made available as single files. To install a Microsoft Dynamics NAV hotfix or an update, you must replace the existing Microsoft Dynamics NAV installation files with the hotfix or the update files. To do this, follow these steps.

Microsoft Dynamics NAV 4.0 SP3

Step 1: Replace the Microsoft Dynamics NAV Client installation file

In the Microsoft Dynamics NAV client installation, replace the following files by using the hotfix or the update file.

File name File version File size Date Time Platform
Dbm.dll 4.0.3.25206 345,208 13-Sep-2007 20:18 x86
Fin.exe 4.0.3.25206 8,119,416 13-Sep-2007 20:18 x86
Fin.exe.manifest Not Applicable 711 11-Sep-2007 21:13 Not Applicable
Finhlink.exe 4.0.3.25206 119,928 13-Sep-2007 20:17 x86
Finsql.exe 4.0.3.25206 8,168,568 13-Sep-2007 20:18 x86
Finsql.exe.manifest Not Applicable 714 14-Dec-2006 16:41 Not Applicable
Nc_netb.dll 4.0.3.25206 78,968 13-Sep-2007 20:17 x86
Nc_tcp.dll 4.0.3.25206 83,064 13-Sep-2007 20:17 x86
Nc_tcps.dll 4.0.3.25206 91,256 13-Sep-2007 20:17 x86

To replace the existing Microsoft Dynamics NAV files, follow these steps:

  1. Close the Microsoft Dynamics NAV Client.

  2. Locate the Microsoft Dynamics NAV Client installation directory.

    Note Typically, the Microsoft Dynamics NAV Client is installed in the following directory:
    C:\Program Files\Microsoft Business Solutions-Navision\Client\

  3. Copy the files that you downloaded.

  4. Paste the files that you downloaded into the Microsoft Dynamics NAV Client installation directory.

  5. In the
    Confirm File Replace dialog box, click Yes to overwrite the files in the installation directory.

Microsoft Dynamics NAV 2009

Step 1: Replace the Microsoft Dynamics NAV Classic Client installation files

In the Microsoft Dynamics NAV Classic Client installation, replace the following files by using the hotfix or the update file.

File name File version File size Date Time Platform
Dbm.dll 6.0.29415.0 444,232 1-July-2009 9:19 x86
Fin.exe 6.0.29415.0 12,244,792 1-July-2009 9:19 x86
Finhlink.exe 6.0.29415.0 452,432 1-July-2009 9:19 x86
Finsql.exe 6.0.29415.0 12,330,832 1-July-2009 9:19 x86
Nc_netb.dll 6.0.29415.0 108,352 1-July-2009 9:19 x86
Nc_tcp.dll 6.0.29415.0 108,368 1-July-2009 9:19 x86
Nc_tcps.dll 6.0.29415.0 153,408 1-July-2009 9:19 x86
Ndbcs.dll 6.0.29415.0 1,333,072 1-July-2009 9:19 x86
Slave.exe 6.0.29415.0 161,616 1-July-2009 9:19 x86

To replace the existing Microsoft Dynamics NAV files, follow these steps:

  1. Close the Microsoft Dynamics NAV Client.

  2. Locate the Microsoft Dynamics NAV Classic Client installation directory.

    Note Typically, the Microsoft Dynamics NAV Classic Client is installed in the following directory:
    C:\Program Files\Microsoft Dynamics NAV\60\CSIDE Client\

  3. Copy the files that you downloaded.

  4. Paste the files that you downloaded into the Microsoft Dynamics NAV Classic Client installation directory.

  5. In the
    Confirm File Replace dialog box, click Yes to overwrite the files in the installation directory.

Step 2: Replace the Microsoft Dynamics NAV RoleTailored Client installation files

In the Microsoft Dynamics NAV RoleTailored Client installation, replace the following files by using the hotfix or the update file.

File name File version File size Date Time Platform
Dundaswinchart.dll 5.0.0.1692 2,733,904 1-Jul-2009 9:19 x86
Microsoft.dynamics.framework.patterns.dll 1.2.10579.173 71,648 30-Jun-2009 7:21 x86
Microsoft.dynamics.framework.ui.dll 1.2.10579.173 654,280 30-Jun-2009 7:21 x86
Microsoft.dynamics.framework.ui.mapping.dll 1.2.10579.173 101,336 30-Jun-2009 7:21 x86
Microsoft.dynamics.framework.ui.navigation.dll 1.2.10579.173 22,496 30-Jun-2009 7:21 x86
Microsoft.dynamics.framework.ui.ux2006.dll 1.2.10579.173 93,064 1-Jul-2009 9:08 x86
Microsoft.dynamics.framework.ui.ux2006.winforms.dll 1.2.10579.173 39,840 1-Jul-2009 9:08 x86
Microsoft.dynamics.framework.ui.windows.dll 1.2.10579.173 84,952 30-Jun-2009 7:21 x86
Microsoft.dynamics.framework.ui.winforms.controls.dll 1.2.10579.173 2,067,440 30-Jun-2009 7:21 x86
Microsoft.dynamics.framework.ui.winforms.dll 1.2.10579.173 633,824 30-Jun-2009 7:21 x86
Microsoft.dynamics.nav.client.builder.dll 1.2.10579.173 166,792 1-Jul-2009 9:08 x86
Microsoft.dynamics.nav.client.exe 6.0.29415.0 142,200 1-Jul-2009 9:08 x86
Microsoft.dynamics.nav.client.interop.communicator.dll 6.0.29415.0 76,704 1-Jul-2009 9:08 x86
Microsoft.dynamics.nav.client.serviceconnection.dll 6.0.29415.0 76,704 1-Jul-2009 9:08 x86
Microsoft.dynamics.nav.client.ui.dll 6.0.29415.0 428,920 1-Jul-2009 9:08 x86
Microsoft.dynamics.nav.client.winforms.dll 6.0.29415.0 277,384 1-Jul-2009 9:08 x86
Microsoft.dynamics.nav.client.winforms.tlb 6.0.29415.0 2,652 1-Jul-2009 4:37 Not applicable
Microsoft.dynamics.nav.language.dll Not applicable 1,866,616 1-Jul-2009 9:08 x86
Microsoft.dynamics.nav.types.dll 6.0.29415.0 383,856 1-Jul-2009 9:08 x86
Microsoft.office.interop.outlook.dll 10.0.4504.0 396,152 1-Jul-2009 9:08 x86

To replace the existing files, follow these steps:

  1. Close the Microsoft Dynamics NAV RoleTailored Client.
  2. Locate the Microsoft Dynamics NAV RoleTailored Client installation directory. Typically, the Microsoft Dynamics NAV RoleTailored Client is installed in the following directory:
    C:\Program Files\Microsoft Dynamics NAV\60\RoleTailored Client
  3. Copy the files that you downloaded.
  4. Paste the files that you downloaded into the Microsoft Dynamics NAV RoleTailored Client installation directory.
  5. When prompted, click Yes to overwrite the files in the installation directory.

Step 3: Replace the Microsoft Dynamics NAV Server installation files

In the Microsoft Dynamics NAV Server installation, replace the following files by using the hotfix or the update file.

File name File version File size Date Time Platform
Httpcfg.exe 5.2.3790.0 22,352 1-Jul-2009 9:08 x86
Microsoft.dynamics.nav.language.dll 6.0.29415.0 1,865,600 1-Jul-2009 9:08 x86
Microsoft.dynamics.nav.ncl.dll 6.0.29415.0 489,336 1-Jul-2009 9:08 x86
Microsoft.dynamics.nav.server.exe 6.0.29415.0 137,088 1-Jul-2009 9:08 x86
Microsoft.dynamics.nav.server.exe.config Not applicable 211 17-Jun-2009 3:29 Not applicable
Microsoft.dynamics.nav.service.dll 6.0.29415.0 120,704 1-Jul-2009 9:08 x86
Microsoft.dynamics.nav.service.runtime.dll 6.0.29415.0 63,376 1-Jul-2009 9:08 x86
Microsoft.dynamics.nav.service.webservices.dll 6.0.29415.0 128,920 1-Jul-2009 9:08 x86
Microsoft.dynamics.nav.types.dll 6.0.29415.0 382,840 1-Jul-2009 9:08 x86
Microsoft.dynamics.nav.watson.dll 6.0.29415.0 38,784 1-Jul-2009 9:08 x86
Nclcsrt.etx Not applicable 87,279 1-Jul-2009 12:52 Not applicable
Nclcsrt.stx Not applicable 81,083 1-Jul-2009 12:52 Not applicable
Nclcsrts.dll Not applicable 1,394,512 1-Jul-2009 9:19 x86
Ndbcs.dll 6.0.29415.0 1,333,072 1-Jul-2009 9:19 x86

To replace the files, follow these steps:

  1. Stop the Microsoft Dynamics NAV server service.

  2. Locate the Microsoft Dynamics NAV server service installation directory.

    Note Typically, the Microsoft Dynamics NAV server service is installed in the following directory:

    C:\program files\Microsoft Dynamics NAV\60\Service

  3. Copy the files that you downloaded.

  4. Paste the files that you downloaded into the Microsoft Dynamics NAV server service installation directory.

  5. Click Yes to overwrite the files in the directory.

  6. Start the Microsoft Dynamics NAV server service.

Step 4: Replace Common Files files

In the Common Files folder, replace the following files.

File name File version File size Date Time Platform
Customization.xml Not applicable 1,115 17-Jun-2009 3:24 Not applicable
Msoutl.olb 11.0.5510.0 200,248 17-Jun-2009 3:24 Not applicable

To replace the existing files, follow these steps:

  1. Locate the Common Files directory:

    C:\Program Files\Common Files\Microsoft Dynamics NAV\OLSync

  2. Copy the files that you downloaded.

  3. Paste the files that you downloaded into the Common Files directory.

  4. When prompted, click Yes to overwrite the files in the installation directory.

Step 5: Replace Windows\System32 files

In the Windows\System32 folder, replace the following files.

File name File version File size Date Time Platform
Cdo.dll 6.5.7940.0 775,480 1-Jul-2009 9:19 x86
Gapi32.dll 6.5.7940.0 71,488 1-Jul-2009 9:19 x86

To replace the existing files, follow these steps:

  1. Locate the Windows\System32 directory:

    C:\Windows\System32

  2. Copy the files that you downloaded.

  3. Paste the files that you downloaded into the Common Files directory.

  4. When prompted, click Yes to overwrite the files in the installation directory.

Prerequisites

You must have one of the following products installed to apply this hotfix:

  • Microsoft Dynamics NAV 4.0 SP3 with hotfix KB 940718

  • Microsoft Dynamics NAV 2009

Removal information

You cannot remove this hotfix.

Restart requirement

If you are prompted to restart the computer, you must restart the computer after you apply this hotfix.

Status

Microsoft has confirmed that this is a problem in the Microsoft products that are listed in the "Applies to" section.

More Information

For more information about software update terminology, click the following article number to view the article in the Microsoft Knowledge Base:

824684 Description of the standard terminology that is used to describe Microsoft software updates