Update Rollup 4 for System Center 2022 Data Protection Manager

Applies to: System Center 2022 Data Protection Manager

Introduction

This article describes the issues that are fixed in Update Rollup 4 for Microsoft System Center Data Protection Manager 2022. It also contains the installation instructions for this update.

Note

Existing Data Protection Manager to Microsoft Azure customers should upgrade to the latest agent (version 2.0.9249.0 or later).

Issues that are fixed

The update rollup 4 fixes the following issues:

  • Updated the time zone calculation algorithm for file timestamps to ensure that the timestamp displayed in the Recover UI for backed-up file is correct- It should be the same as file backup time.
  • Enhanced and corrected the connection logic to fully support SQL Server forced encryption configurations, enabling proper SSL/TLS negotiation and encrypted communication channels.
  • Fixed SharePoint Item Level Restore (ILR) operations fail with error 32016 (Unknown error 0x80131513).
  • Added logic to validate shadow copy schedule properties for null values and initialize them from existing schedules or as empty lists before UI operations- To avoid UI crashes and disappears while SQL Workload is being protected.
  • Fixed DPM Exchange Component Enumeration Failure (Error 964)- Added a registry-based fallback in GetApplicationVersion()- When COM fails, Exchange version is retrieved from registry keys.
  • Fixed DPMAccessManager Crash issue When Re-Cataloging Imported Tapes Containing VMware VM Backups from Different DPM Servers.
  • Fixed PowerShell Protection Group Creation Crash issue by and NullReferenceException Check when calling Set-DPMProtectionGroup or related cmdlets for disk-based protection groups.
  • Fixed DPM Console crashes when creating a Protection Group with Online protection enabled and users check and uncheck protection content selections.
  • Add retry logic to handle transient timeout errors when attaching VHD files in the Hyper-V VHD helper.
  • Fixed NullReferenceException in SQL alternate location restores with LocationMapping.
  • Fixed a crash during storage-to-storage migration by excluding the MigrateDatasourceDataFromStorageToStorage parameter set from the client datasource presence check.
  • Fixed the issue where the weekly online backup schedule was displayed incompletely.
  • Fixed the issue where the Storage consumed value in the DPM Console’s replica details was displayed incorrectly.
  • Fixed the ACCESS_DENIED error that could interrupt backup operations when files were deleted after replica creation.
  • Fixed traditional Chinese/Korean characters in RibbonMenu drawing issue.
  • Fixed automatically cleans up residual log files when an incremental log restore fails.
  • Fixed an issue where DPM crashed when SMTP AUTH was disabled in Exchange by adding exception handling to prevent the crash.
  • Resolved an issue where encrypted tape media was incorrectly marked as imported when the OMID was too long.
  • Fixed an issue where the keyboard focus indicator was not visible when focus moved to an empty Selected Computers table.
  • Update the name property defined for the spin button present under "Specific short-term goals" tab.
  • Added keyboard accessibility support for table column headers under Select group members.
  • Fixed an issue where screen readers did not announce alert search results in the Monitoring tab.
  • Fixed the keyboard focus order and screen reader announcements when selecting computers for a new Protection Group.
  • Increased the keyboard focus contrast ratio for the left-side All alerts control to at least 3:1.
  • Updated LinkArea to return a period, resolving the “unknown” screen reader announcement for detail labels.
  • Added complete accessible names for the expand/collapse buttons in the left navigation pane of Settings.
  • Fixed an issue where the Management tab's configuration window did not adapt to increased Windows text size settings.
  • Fixed multiple screen reader accessibility issues involving disk values, workday checkboxes, and the backup recovery schedule label.
  • Update the name property defined for the edit field present under "Encryption Settings" tab.
  • Update the name property defined for the Maximum Duration spin button present under choose consistency check screen.

Note

A fresh installation of the Update Rollup agent could cause a restart of the protected server.

In addition to the above fixes, all the issues fixed in SC DPM 2022 UR1, UR1 Hotfix and UR2 Refresh,UR3 are also included in SCDPM 2022 UR4.

Other Improvements and Features

  • SCDPM 2022 UR4 also has additional new features introduced. For details on the new features, refer to the documentation here.

How to obtain Update Rollup 4 for System Center Data Protection Manager 2022

Update packages for Data Protection Manager are available from Microsoft Update or by manual download.

Microsoft Update

  1. To obtain and install an update package from Microsoft Update, follow these steps on a computer that has a Data Protection Manager component installed:
  2. Select Start, and then select Control Panel.
  3. In Control Panel, double-click Windows Update.
  4. In the Windows Update window, select Check Online for updates from Microsoft Update.
  5. Select Important updates are available.
  6. Select the Update Rollup package, and then select OK.
  7. Select Install updates to install the update package.

Note

MU update might fail initially as shown below or with a different error code. This is due to Visual C++ Redistributable updating runtime files existing on system and a restart is required to take the effect. If so, please restart the machine and try Install Updates one more time.

There were some problems installing updates, but we'll try again later.
If you keep seeing this and want to search the web or contact support for information, this may help: (0x80070643)

Manual download

Go to the following website to manually download the update package from the Microsoft Update Catalog: Download the Data Protection Manager update package now.

For information about how to download Microsoft support files, select the following article number to view the article in the Microsoft Knowledge Base:

119591 How to obtain Microsoft support files from online services

To install this update for Data Protection Manager Server, follow these steps:

1⁠. Before you install this update, make a backup of the Data Protection Manager database.

2⁠. Install this rollup package on the server that's running System Center Data Protection Manager 2022. To do this, from the downloaded bit run package "dataprotectionmanager-kb5125272_311d436fb8ccc5671d6a0d33a87893a3536f0cc4.exe".

Note

Once the patch extracts, the Patch UI might not show-up. This is due to Visual C++ Redistributable updating runtime files existing on system and a restart is required to take the effect. If so, please restart the machine and try running package one more time.

Virus-scan claim

Microsoft scanned this file for viruses, using the most current virus-detection software that was available on the date that the file was posted. The file is stored on security-enhanced servers that help prevent any unauthorized changes to it.

Installation instructions for Data Protection Manager Agent

In the Data Protection Manager Administrator Console, update the protection agents. To do this, use one of the following methods.

Note

You need to restart protected servers to create or change protection groups.

Method 1: Update the protection agents from the Data Protection Manager Administrator Console

  1. Open the Data Protection Manager Administrator Console.

  2. Select the Management tab, and then select the Agents tab.

    1. In the Protected Computer list, select a computer, and then select Update on the Action pane.
  3. Select Yes, and then select Update Agents.

Method 2: Update the protection agents on the protected servers

  1. Obtain the updated protection agent package from the installation directory of the System Center Data Protection Manager 2022 server at following path: Microsoft System Center2022\DPM\DPM\agents\RA\10.22.506.0\amd64\1033\DPMAgentInstaller_KB5125272_AMD64.exe.
  2. Run the DPMAgentInstaller_KB5125272_AMD64.exe package on each protected server.
  3. Open the Data Protection Manager Administrator Console on the System Center Data Protection Manager server 2022.
  4. Select the Management tab, and then select the Agents tab. Select the protected server, refresh the information, and then verify that the agent version number is 10.22.506.0.