Stop error on a computer that is running Windows Server 2008 R2, Windows Server 2008, Windows Vista or Windows 7 when the operating system uses a virtual storport miniport driver to save a dump file or a hibernation file: "0x000000D1"

Not sure if this is the right fix? We've added this issue to our memory dump diagnostic which can confirm.

Symptoms

Consider the following scenario:

  • You have a computer that is running one of the following operating systems:

    • Windows Vista
    • Windows Server 2008
    • Windows 7
    • Windows Server 2008 R2
  • You install a virtual storport miniport driver on the computer.

  • You try to put your computer in hibernation, or the operating system tries to save a dump file.

In this scenario, the computer restarts unexpectedly, you receive the following Stop error, and no dump file is generated:

Note

Stop 0x000000D1 (parameter1, parameter2, parameter3, parameter4)
The DRIVER_IRQL_NOT_LESS_OR_EQUAL

Cause

The issue occurs because the Crashdmp.sys and Diskdump.sys driver call an incorrect routine for the virtual storport miniport driver. When this behavior occurs, it leads the operating system to trigger the Stop error code.

Resolution

Hotfix information

A supported hotfix is available from Microsoft. However, this hotfix is intended to correct only the problem that is described in this article. Apply this hotfix only to systems that are experiencing the problem described in this article. This hotfix might receive additional testing. Therefore, if you are not severely affected by this problem, we recommend that you wait for the next software update that contains this hotfix.

If the hotfix is available for download, there is a "Hotfix download available" section at the top of this Knowledge Base article. If this section does not appear, contact Microsoft Customer Service and Support to obtain the hotfix.

Note If additional issues occur or if any troubleshooting is required, you might have to create a separate service request. The usual support costs will apply to additional support questions and issues that do not qualify for this specific hotfix. For a complete list of Microsoft Customer Service and Support telephone numbers or to create a separate service request, visit the following Microsoft Web site:

http:⁠//support.microsoft.com/contactus/?ws=support Note The "Hotfix download available" form displays the languages for which the hotfix is available. If you do not see your language, it is because a hotfix is not available for that language.

Prerequisites

To apply this hotfix, you must be running one of the following operating systems:

  • Windows Vista Service Pack 2 (SP2)
  • Windows Server 2008 Service Pack 2 (SP2)
  • Windows 7
  • Windows Server 2008 R2

For more information about how to obtain a Windows Vista service pack, click the following article number to view the article in the Microsoft Knowledge Base:

935791 How to obtain the latest Windows Vista service pack

For more information about how to obtain a Windows Server 2008 service pack, click the following article number to view the article in the Microsoft Knowledge Base:

968849 How to obtain the latest service pack for Windows Server 2008

Registry information

To use the hotfix in this package, you do not have to make any changes to the registry.

Restart requirement

You must restart the computer after you apply this hotfix.

Hotfix replacement information

This hotfix does not replace a previously released hotfix.

File information

The global version of this hotfix installs files that have the attributes that are listed in the following tables. The dates and the times for these files are listed in Coordinated Universal Time (UTC). The dates and the times for these files on your local computer are displayed in your local time together with your current daylight saving time (DST) bias. Additionally, the dates and the times may change when you perform certain operations on the files.

Windows Vista and Windows Server 2008 file information notes

Important Windows Vista hotfixes and Windows Server 2008 hotfixes are included in the same packages. However, only "Windows Vista" is listed on the Hotfix Request page. To request the hotfix package that applies to one or both operating systems, select the hotfix that is listed under "Windows Vista" on the page. Always refer to the "Applies To" section in articles to determine the actual operating system that each hotfix applies to.

  • The files that apply to a specific product, SR_Level (RTM, SPn), and service branch (LDR, GDR) can be identified by examining the file version numbers as shown in the following table.

    Version Product SR_Level Service branch
    6.0.600
    2.
    22xxx
    Windows Vista and Windows Server 2008 SP2 LDR
  • The MANIFEST files (.manifest) and the MUM files (.mum) that are installed for each environment are listed separately in the "Additional file information for Windows Server 2008 and for Windows Vista" section. MUM files and MANIFEST files, and the associated security catalog (.cat) files, are extremely important to maintain the state of the updated components. The security catalog files, for which the attributes are not listed, are signed with a Microsoft digital signature.

For all supported x86-based versions of Windows Server 2008 and of Windows Vista

File name File version File size Date Time Platform
Diskdump.sys 6.0.6002.22588 19,968 15-Feb-2011 15:43 x86

For all supported x64-based versions of Windows Server 2008 and of Windows Vista

File name File version File size Date Time Platform
Diskdump.sys 6.0.6002.22588 20,480 15-Feb-2011 14:12 x64

For all supported IA-64-based versions of Windows Server 2008

File name File version File size Date Time Platform
Diskdump.sys 6.0.6002.22588 47,616 15-Feb-2011 13:57 IA-64

Windows 7 and Windows Server 2008 R2 file information notes

Important Windows 7 hotfixes and Windows Server 2008 R2 hotfixes are included in the same packages. However, hotfixes on the Hotfix Request page are listed under both operating systems. To request the hotfix package that applies to one or both operating systems, select the hotfix that is listed under "Windows 7/Windows Server 2008 R2" on the page. Always refer to the "Applies To" section in articles to determine the actual operating system that each hotfix applies to.

  • The files that apply to a specific product, SR_Level (RTM, SPn), and service branch (LDR, GDR) can be identified by examining the file version numbers as shown in the following table.

    Version Product SR_Level Service branch
    6.1.760
    0.
    20xxx
    Windows 7 and Windows Server 2008 R2 RTM LDR
  • The MANIFEST files (.manifest) and the MUM files (.mum) that are installed for each environment are listed separately in the "Additional file information for Windows Server 2008 R2 and for Windows 7" section. MUM and MANIFEST files, and the associated security catalog (.cat) files, are extremely important to maintaining the state of the updated component. The security catalog files, for which the attributes are not listed, are signed with a Microsoft digital signature.

For all supported x86-based versions of Windows 7

File name File version File size Date Time Platform
Diskdump.sys 6.1.7600.20882 26,496 17-Jan-2011 05:42 x86

For all supported x64-based versions of Windows 7 and of Windows Server 2008 R2

File name File version File size Date Time Platform
Diskdump.sys 6.1.7600.20882 27,008 17-Jan-2011 06:22 x64

For all supported IA-64-based versions of Windows Server 2008 R2

File name File version File size Date Time Platform
Diskdump.sys 6.1.7600.20882 54,656 17-Jan-2011 05:19 IA-64

Status

Microsoft has confirmed that this is a problem in the Microsoft products that are listed in the "Applies to" section.

More Information

For more information about Storage Virtual Miniport drivers, visit the following Microsoft website:

Initialization of Storage Virtual Miniport Drivers
For more information about the VIRTUAL_HW_INITIALIZATION_DATA structure, visit the following Microsoft website:

General information about the VIRTUAL_HW_INITIALIZATION_DATA structure For more information about software update terminology, click the following article number to view the article in the Microsoft Knowledge Base:

824684 Description of the standard terminology that is used to describe Microsoft software updates

Additional file information

Additional file information for Windows Vista and for Windows Server 2008

Additional files for all supported x86-based versions of Windows Vista and of Windows Server 2008

File name Update.mum
File version Not Applicable
File size 3,078
Date (UTC) 16-Feb-2011
Time (UTC) 12:06
Platform Not Applicable
File name X86_microsoft-windows-diskdump_31bf3856ad364e35_6.0.6002.22588_none_68dfd4f9adc3bc1c.manifest
File version Not Applicable
File size 2,771
Date (UTC) 15-Feb-2011
Time (UTC) 19:13
Platform Not Applicable

Additional files for all supported x64-based versions of Windows Vista and of Windows Server 2008

File name Amd64_microsoft-windows-diskdump_31bf3856ad364e35_6.0.6002.22588_none_c4fe707d66212d52.manifest
File version Not Applicable
File size 3,023
Date (UTC) 15-Feb-2011
Time (UTC) 17:03
Platform Not Applicable
File name Update.mum
File version Not Applicable
File size 3,102
Date (UTC) 16-Feb-2011
Time (UTC) 12:06
Platform Not Applicable

Additional files for all supported IA-64-based versions of Windows Server 2008

File name Ia64_microsoft-windows-diskdump_31bf3856ad364e35_6.0.6002.22588_none_68e178efadc1c518.manifest
File version Not Applicable
File size 3,021
Date (UTC) 15-Feb-2011
Time (UTC) 16:35
Platform Not Applicable
File name Update.mum
File version Not Applicable
File size 2,255
Date (UTC) 16-Feb-2011
Time (UTC) 12:06
Platform Not Applicable

Additional file information for Windows 7 and for Windows Server 2008 R2

Additional files for all supported x86-based versions of Windows 7

File name Update.mum
File version Not Applicable
File size 1,641
Date (UTC) 17-Jan-2011
Time (UTC) 08:49
Platform Not Applicable
File name X86_microsoft-windows-diskdump_31bf3856ad364e35_6.1.7600.20882_none_671b2fb511ba0eaf.manifest
File version Not Applicable
File size 2,150
Date (UTC) 17-Jan-2011
Time (UTC) 06:15
Platform Not Applicable

Additional files for all supported x64-based versions of Windows 7 and of Windows Server 2008 R2

File name Amd64_microsoft-windows-diskdump_31bf3856ad364e35_6.1.7600.20882_none_c339cb38ca177fe5.manifest
File version Not Applicable
File size 2,152
Date (UTC) 17-Jan-2011
Time (UTC) 07:04
Platform Not Applicable
File name Update.mum
File version Not Applicable
File size 1,873
Date (UTC) 17-Jan-2011
Time (UTC) 08:49
Platform Not Applicable

Additional files for all supported IA-64-based versions of Windows Server 2008 R2

File name Ia64_microsoft-windows-diskdump_31bf3856ad364e35_6.1.7600.20882_none_671cd3ab11b817ab.manifest
File version Not Applicable
File size 2,151
Date (UTC) 17-Jan-2011
Time (UTC) 06:48
Platform Not Applicable
File name Update.mum
File version Not Applicable
File size 1,690
Date (UTC) 17-Jan-2011
Time (UTC) 08:49
Platform Not Applicable