KB2960237 - FIX: Error when you execute DQS stored procedure [internal_core].[RestoreDQDatabases] in SQL Server

Applies To
SQL Server 2012 Developer SQL Server 2012 Enterprise SQL Server 2012 Standard SQL Server 2014 Developer - duplicate (do not use) SQL Server 2014 Enterprise - duplicate (do not use) SQL Server 2014 Standard - duplicate (do not use)

Symptoms

Consider the following scenario:

  • You are using Microsoft SQL Server 2012 or SQL Server 2014.

  • You have an existing or newly restored DQS_MAIN database on your Data Quality Services (DQS) server.

  • You execute the following query:

    EXECUTE [internal_core].[RestoreDQDatabases] '<PASSWORD>'
    

In this scenario, you receive the following error:

Note

The master key password is incorrect; please give the master key password which was given in the installation

Note The <PASSWORD> is set to the password for the database master key that you provided during the DQS server installation and it is correct.

Resolution

The issue was first fixed in the following cumulative update of SQL Server.

Cumulative Update 1 for SQL Server 2012 SP2 /en-us/help/2976982

Cumulative Update 2 for SQL Server 2014 /en-us/help/2967546

Cumulative Update 10 for SQL Server 2012 SP1 /en-us/help/2954099

About cumulative updates for SQL Server

Each new cumulative update for SQL Server contains all the hotfixes and all the security fixes that were included with the previous cumulative update. Check out the latest cumulative updates for SQL Server:

      

Status

Microsoft has confirmed that this is a problem in the Microsoft products that are listed in the "Applies to" section.