KB2984907 - FIX: "The current SQL Server edition is not supported by MDS" error when you browse to the MDS website

Applies To
SQL Server 2014 Developer - duplicate (do not use) SQL Server 2014 Enterprise - duplicate (do not use) SQL Server 2014 Standard - duplicate (do not use)

Symptoms

Consider the following scenario:

  • You install Master Data Services (MDS) on one computer.
  • You configure MDS and connect it to an MDS database on a different computer that is running Microsoft SQL Server 2014.
  • You browse to the MDS website.

In this scenario, you receive the following error:

Note

The current SQL Server edition is not supported by MDS.

Resolution

The issue was first fixed in the following cumulative update of SQL Server.

Cumulative Update 3 for SQL Server 2014 /en-us/help/2984923

About cumulative updates for SQL Server

Each new cumulative update for SQL Server contains all the hotfixes and all the security fixes that were included with the previous cumulative update. Check out the latest cumulative updates for SQL Server:

      

Status

Microsoft has confirmed that this is a problem in the Microsoft products that are listed in the "Applies to" section.